Skip to:

BP and BBPress issues.

  • Vast HTML


    I have the forum integrated it seems perfect, except i keep getting There was an error posting that topic. when i try to post on any group.

Viewing 9 replies - 1 through 9 (of 9 total)

  • Andy Peatling


    “Provide Version Numbers & Steps

    When asking a support question, please provide your WPMU & BuddyPress version numbers. Be sure to explain exactly what the problem is, and the steps you can take to reproduce the problem.”

    Vast HTML


    WPMU: v2.8.4a

    BP: v1.0.3

    As i said before the plugin intergration seems to be ok. You can see it in the groups but when you click “Post Topic” you get an error

    “There was an error posting that topic” happens on all groups.



    did you make sure you put the buddypress-enable.php in bbpress my-plugin folder?



    I am getting the same error.

    I have the buddypress-enable file installed

    (WPMU 2.8.2, BP 1.0.3, BBPress

    I’d strongly suggest pbowman you upgrade to the latest versions of WPMU, BP and BBPress. You may be experiencing bugs which have since been fixed. Are you able to upgrade?



    I’ll try, thanks



    Yeah, mine has the same problem too…Ive tested the xmlrpc and the additional “$bb->bb_xmlrpc_allow_user_switching = true” code in bb-config.php file, added the bp-group plugin but still no luck in getting rid off the “There was an error posting that topic” message. It seem to be happening with all the sudden..or it may be a side effect of me activating certain plugins which I may not realize the effect of it.

    Anyway i think my xmlrpc communicates well with the class.ixr file by using a plugin named xmlrpc – Say hello from bbPress. The expected output produces successfully which I think the source of the problem may not be from the xmlrpc thing.

    I’m using bbpress 1.01, WordPress MU 2.8.1 and Buddypress 1.0.3.

    Really appreciate if someone could provide me suggestions.

    You guys rock!!!



    @ tajulsharby: Update to the the latest WPMU (2.8.6) and Buddypress (1.1.2)?



    I wish I could but unfortunately it will take some times for me and my guys to get other customized plugin to work with the new release as we all have been playing with the current version which we had going in to for quite some time.

    Yeah, I know the latest version has the solution but I really hope for a technical solution (hacking the core files i guess?) which will solve the problem logically.

    Anyway, the variable $topic which I debugged through in the bp-groups.php file was not holding any value which I might suspected to be the source of the problem:

    function groups_new_group_forum_topic( $topic_title, $topic_text, $topic_tags, $forum_id ) {
    global $group_obj, $bp;

    if ( $topic = bp_forums_new_topic( $topic_title, $topic_text, $topic_tags, $forum_id ) ) {
    bp_core_add_message( __( 'Topic posted successfully!', 'buddypress') );

    /* Record in activity streams */
    groups_record_activity( array( 'item_id' => $group_obj->id, 'component_name' => $bp->groups->slug, 'component_action' => 'new_forum_topic', 'is_private' => 0, 'secondary_item_id' => $topic['topic_id'] ) );

    do_action( 'groups_new_forum_topic', $group_obj->id, $topic );

    return $topic;
    bp_core_add_message( __( 'There was an error posting that topic.', 'buddypress'), 'error' );
    return false;

    Anyone have ideas what the $topic variable does?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘BP and BBPress issues.’ is closed to new replies.
Skip to toolbar