Skip to:
Content
Pages
Categories
Search
Top
Bottom

bp_get_member_profile_data, xprofile_get_field_data — both have stopped working

  • Profile photo of aendrew
    aendrew
    Member

    @aendrew

    Hi there,
    Somewhere in moving from one server to another, a bit of template code I’ve written has stopped working. In short, it seems like the bp_get_member_profile_data/bp_member_profile_data functions have stopped working — and thus I’m unable to make the members-loop.php display my custom fields. See: http://pastebin.com/bUUVWBPx starting at line 64.

    To make this even weirder, the profile-loop displays the fields fine (I’m guessing because they’re done via a while loop, maybe?).

    This is driving me crazy and is the last thing I need to do before being finished this project. Anyone have a clue what might be causing this? Any help you can give me will be much appreciated.

    Edit: I’m using WP 3.02 and BP1.2.6

Viewing 4 replies - 1 through 4 (of 4 total)
  • Profile photo of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Couple of thoughts that may help:

    Have your profile fields got different IDs on the new server?
    What version of BP were you on on the original server?

    Profile photo of aendrew
    aendrew
    Member

    @aendrew

    Hi Roger! Thanks for the response.

    I’m running the same version of WP and BP on both servers; field IDs are the same. I cannot replicate the issue on the testing server; I’m presently thinking it might be a PHP version issue.

    I thought at one point it might be related to https://trac.buddypress.org/ticket/2171, but moving the custom profile field code to after the functions mentioned doesn’t do anything either…

    Something else I forgot to mention — the “add friend” button now appears twice. Also, I don’t think it’s an issue with my theme — I tried switching to the BP default theme and adding a profile field during the members-loop and had the same issue.

    Profile photo of aendrew
    aendrew
    Member

    @aendrew

    Hi all,

    I got in contact with my client and upgraded their version of PHP to PHP5. Everything works now! Glorious day, glorious day!

    Think this is a candidate for a trac ticket?

    Profile photo of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Double add friend button is a known problem with 1.2.6 upgrade. Search on here for solution

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘bp_get_member_profile_data, xprofile_get_field_data — both have stopped working’ is closed to new replies.
Skip to toolbar