Skip to:

BuddyPress and WordPress 3.0

  • Profile photo of Robert


    1- Installed WordPress 2.9.2

    2- Upgrade to WordPress 3.0 alpha using the Beta Testers plugin – OK

    3- Installed BuddyPress – OK

    4- Created test users and groups with custom avatars – OK

    5- Installed the multi-blogs network: Everything seems to work fine, the users are there and no data was lost with one exception: the custom avatars are missing. Tried to upload a new custom avatar but it doesn’t show on the crop screen. Checking the folders wp-content/uploads/avatars I’ve verified that all the custom avatars are still there and if you upload an image it’s stored there. It doesn’t show on screen.

Viewing 12 replies - 26 through 37 (of 37 total)
  • Profile photo of Phlux0r



    Everything works fine on our site. Media library, post media, avatars…

    Yeah, but poor @Chad Holden isn’t so lucky :)

    Profile photo of Phlux0r


    In that case I’d suggest creating an installation with the same versions used originally on another server or local dev environment and seeing if that makes a difference, if it’s a server config issue maybe or some other mis-configuration somewhere.

    Profile photo of Chad Holden
    Chad Holden


    I’ve tried the installation a few times on WAMP, MAMP and multiple installations on the same server … It should be important to note that THIS site has the same avatar uploading issues with this new template/release.

    This is my htaccess file, which makes the avatar cropper work, but I still get the upload error after :
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]
    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Thanks for all the reading material …

    WP 3.0-Beta2-14508 + BP 1.2.3 (all freshly installed on a clean server)

    … with steps 1 and 2 only from @Phlux0r‘s post above:
    … and replacing the bp-core-avatars.php code completely with this from trac:

    All seems to be working quite well.


    Profile photo of okso


    When I set the upload path to wp-content/blogs.dir/1/files I can get avatars working but it breaks my old media lib at wp-content/uploads. Is there a fix for this issue? Can I move the old uploads dir into to wp-content/blogs.dir/1/files and with the upload path to wp-content/blogs.dir/1/files get the media to link? Thanks.

    Profile photo of André RENAUT


    Hi all !

    Just playing with nightly build wp 3.0 and buddypress 1.2.3.
    As BP can be installed on a standalone WP or WP multi-sites, i though i could install BP on one of my WP site letting other sites working as standalone sites.
    Apparently this is not possible.
    Did i missed a specfic setting ?
    Any idea if future release will allow this ?

    Profile photo of okso


    bp 1.2.4 alleluia, well done, thank you.

    id like to see the new wp 3.0 nav functionality added to the buddy press default theme
    added to functions.php

    add_theme_support( ‘nav-menus’ );

    to show the menu in header.php

    ‘menu_order’, ‘container_class’ => ‘menu-header’, ‘container_id’ => ‘nav’ ) ); ?>
    Profile photo of Ishimwe


    Works like a charm for me!

    WP 3.0 and Buddypress 1.3 in two steps:

    1) Make sure upload_path option is set to wp-content/blogs.dir/1/files
    2) in old .htaccess change

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L] TO

    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]


    Profile photo of Mitch


    Ron said:


    The issue here with 3.0 is that if an existing WP 2.9.2 install with uploaded media upgrades to 3.0 and enables the network the blog option for the upload_path can’t be changed to the blogs.dir folder because the existing media becomes inaccessible.

    So my question is: is there a way to get the pre-existing media to show-up? I went from WPMU 2.9.2 to WP 3.0 – and all of my media is gone? It won’t even show up, if I enter the path to the file directly in the address bar? Shouldn’t it at least show an image if I put the exact path in?

    I also tried to upload new media – and that doesn’t show up either, so I’m not sure if what Ron posted is my issue?


    Profile photo of suman


    the Solutions for Avatar write that line in .htaccess

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    Working fine with one of my latest project check it out

    Thanks to all

Viewing 12 replies - 26 through 37 (of 37 total)
  • The topic ‘BuddyPress and WordPress 3.0’ is closed to new replies.
Skip to toolbar