Skip to:

Buddypress Forums & Group Forums Not Working

  • Hi,

    When a topic is posted from a group this message is displayed in a red bar: “This group does not have a forum setup yet.”

    When a topic is posted and a group is slected from the Forums page this message is also displayed in a red bar: “Please pick the group forum where you would like to post this topic.”

    Everything else works fine.

    I really don’t understand whats wrong, please help me fix this for my members.


Viewing 25 replies - 1 through 25 (of 29 total)

  • @mercime


    == When a topic is posted from a group this message is displayed in a red bar: “This group does not have a forum setup yet.” ==
    Go to that specific Group’s Admin > Settings and click “Enable discussion forum”

    == When a topic is posted and a group is slected from the Forums page this message is also displayed in a red bar: “Please pick the group forum where you would like to post this topic.” ==
    Not quite sure what you mean. Did you post the topic from the specific Group’s > Forum page > New Topic or did you post from Forum Directory page > New Topic page where you should select the group from dropdown provided?

    Hi mercime,

    I tried it with the discussion forum enabled and created different groups trying to post from each one from the groups forum page and the forums main page. Also tried the directory pages with the group name category selected in the dropdown each time.

    It’s the same symptoms as on here:

    I also tried uninstalling and re-installing the buddypress plugin and disabling all other plugins in case of conflict but no luck.

    Here is a link to my site:

    Have you heard of this problem before?


    Same problem here. Groups installed. Forum for groups installed and activated when i create a new group. But when I try to make a new theme is answering that the forum is not configured.



    Same problem here. I must say I am getting very skeptical. I can’t have this kind of nonsense with users. Can someone lend a hand here? Thanks!



    I just found a work around. I created the forum topic from within the group, which sidesteps the “which group” question and seems to have worked.



    I have exactly the same problem. When I try to post in a group forum I get:

    “This group does not have a forum setup yet.”

    If I try to do it from the global forums page section, I get this:

    “Please pick the group forum where you would like to post this topic.” (I did! ¬¬)

    No need to say that of course I had forum enabled option on the group… I’ve been working on this problem for several hours and I’m about getting crazy.

    When I installed forums option on Buddypress I did the following:

    1. Installed forums for all the website (downloaded bbPress, installed and activated)
    2. Installed forums for groups (instead of “using an existing installation option”)

    I think the problem is maybe on not using the “existing installation option”).

    I’m about becoming crazy (and blind), but the only solution I see is locating the database entry on phpMyadmin and fixing it, but I couldn’t find where this options are in there.

    Some help pleeeeease? Thanks… :(



    Please clarify which forum setup you have based on the four available setups here

    Same problem.
    WP 3.2.1 and BP 1.5.1
    reverted back to BP default theme
    Deactivated all plugins
    Created new groups
    and still not able to add a forum topic

    Any suggestions?





    This issue is driving us bonkers – has anyone come up with a solution please?

    It all started when we moved our site ( to its own server (accessed thru cPanel). We have lost all forums and when another group is created it creates multiple groups rather than just 1 (even though the unique ID numbers are the same) – everything was working fine with our previous shared server.

    I’m beginning to think it is a server side issue……

    Some observations

    1. Not a plugin issue – all have been tried and tested
    2. Not a theme issue – was all working fine under the theme (Custom Community)
    3. We are using all latest editions of WordPress, BuddyPress and BBPress…
    4. We’ve followed discussion threads and deleted unique forum ids in MyPhp.

    Absolutely no idea what to do next……

    Please help

    Boone Gorges


    Try toggling forums in a given group. Uncheck “enable forum” and save, then recheck. If that works, it narrows down the issue.

    Also, is it happening with new groups as well as existing ones?

    The error happens even if it is a new group or existing and after toggling the enable forum. I’ve had so many problems installing BP I’m starting to wonder if it will work.



    @tjherman are you on Windows or Linux server? WP 3.2.1 or WP 3.3? BP 1.5.1 or 1.5.2? Have you checked your database if 7 tables were generated for the forums and whether bb-config.php was generated at the root of your WP installation?

    @mercime, Windows server, WP 3.2.1. BP 1.5.2, the only table that mentions forums is one called “wp_bb_forums” and there is a bb-config.php in the root WP installation. Hope that helps!



    According to the link, these should be in my database:


    Those are all present. :(



    Good. See if you have the bb-config.php you should have at the root of your WP install and check if necessary DB information is correct in bb-config.php

    Okay, all the DB info matches up with the wp-config.php.

    I’ve been testing this out on an Apache server, and I get the same error when I try to post to a forum from the forum directory page. If I go into a group forum, I can post there. On the windows based server, I click on forums under a group and nothing happens.

    I’d really prefer sitewide forums, and I’ve looked at bbpress, but it does not support a forum reply rating system. BP does. I’ve tried installing the site wide forums alongside the groups, but nothing happens when I click the button to install it. Says it’s already installed. Is there another solution I’m missing?

    Does anyone have any ideas? :(



    Thanks everyone for the lively discussion – happy that I’m not the only one suffering with this issue but feel sorry for all of us! I’ve eliminated one problem – I was getting a duplication of a group every time I set up a new one – I wasn’t running the latest php version for BuddyPress requirements on my dedicated server. This issue is now resolved.

    However, I am still having problems with forum creation. The bb-config.php file is in the correct place in the root directory and all settings are also OK. This is a real mystery – I was hoping that the new BuddyPress version uploaded this week would solve the problem – no.



    Decided to get rid of the forums and just rely on the comments boxes in the user group activity stream

    I had this problem and have finally solved it.

    Here’s what I did:

    1. deactivate all plugins except buddypress
    2. change theme to default
    3. backup your bb-config.php file
    4. delete bb-config.php
    5. backup /public_html/wp-content/plugins/buddypress/bp-forums
    6. rename /public_html/wp-content/plugins/buddypress/bp-forums
    7. download the latest version of Buddypress
    8. upload new version of /public_html/wp-content/plugins/buddypress/bp-forums
    9. upload rest of the latest version buddypress files
    10. go to your dashboard >Buddypress > components >forums click to install group forums and it will create a new bb-config.php file
    11. create a new group – DO NOT SELECT ENABLE DISCUSSION FORUM
    12. save the group
    13. go back into the group and select enable discussion forum
    14. create a new topic for your new forum
    15. If it works – check the other groups.
    16 If the other groups don’t work – de-select enable discussion forum and save – then select discussion forum and save again – see if that helped.
    17. change to your custom theme – double check again. You may need to redo step 16 for some of your groups
    18. reactivate your plugins and check again – you may need to redo step 16

    I know that seems like a lot of steps – and possible you could skip some of them – but that’s the exact process I used and it worked… woot!!

    Good luck


    I got this problem too. I did a fresh install of WordPress MU today, installed Buddypress and then tried to enable forums. No go. Tried a lot of things, nothing works. Also tried with bbpress, no go.

    I really hope this gets fixed really really soon! This is a very serious bug.



    == Says it’s already installed. Is there another solution I’m missing? ==
    Go to Settings > Forums and check the Archives Base, if you have group forums running change the slug from “forums” to something else e.g. sitewide-forums or discussions

    @zaphod_b are you trying to install sitewide forums?

Viewing 25 replies - 1 through 25 (of 29 total)
  • The topic ‘Buddypress Forums & Group Forums Not Working’ is closed to new replies.
Skip to toolbar