Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress is Not my Buddy… :o(

  • Profile photo of Tom Presler
    Tom Presler
    Member

    @tom-presler

    I’d love to try Buddypress, but I’m not sure that the developers have worked out all the kinks. I’ve tried to accommodate Buddypress (BP) by deleting EVERYTHING. Themes, Plugins, etc. Buddypress = Crash. Every time. Epic Fail. Does anyone know how to make Buddypress work? I have some duct tape and glue standing by… or is it worth it at all?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Profile photo of Tom Presler
    Tom Presler
    Member

    @tom-presler

    The official Buddypress theme song is Dave Matthews’ “Crash into me.”

    Profile photo of Tom Presler
    Tom Presler
    Member

    @tom-presler

    A quote from C3P0 regarding Buddypress: “Sir, it’s quite possible this plugin is not entirely stable.”

    Profile photo of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    There are a lot of people in this forum who would probably be willing to help, but you have to give more information than “Crash. Every time. Epic Fail.”

    Also, it’s unlikely that there will be responses within 11 minutes, so there is no need to bump your post within that period of time.

    Profile photo of @mercime
    @mercime
    Keymaster

    @mercime

    Tom, you should read this, esp. Server and WP configurations https://codex.buddypress.org/getting-started/before-installing/

    I’m having similar troubles. I’ve gone through the pre-install checklist, and my server is up to par and my WP install works perfectly. In an effort to keep it clean, I’m using the latest version of WP 3.1.3 with no other plugins/themes/mods/anything. I can install the plugin, but when I activate I get this:

    “Safari can’t open the page “http://mywebsite.org/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=” because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again.”

    At this point, the site itself and admin area are totally inaccessible. If I manually delete (or change the name) of the buddypress plugin in the plugins folder, all is returned to normal.

    I’ve searched high and low and am not sure where to look. Any help is truly appreciated. THANK YOU!

    Profile photo of stwc
    stwc
    Participant

    @stwc

    BP is CPU and memory-hungry on top of regular WP requirements. Depending on what web host you’re using, if you’re on a shared hosting plan, it may just be dieing due to hard limits on resources. I ran a small BP install (along with other sites) on a Dreamhost shared account for while, but have since moved to a virtual private server, because, well: it’s heavy.

    That may or may not be the problem.

    Thanks, stwc. I’m actually on a dedicated server that I can fully control. Is there a key resource(s) I should look at that can be increased to better accommodate?

    Profile photo of stwc
    stwc
    Participant

    @stwc

    @jtcreate Not sure on that end — I’m more of a front-end kinda guy, with fairly rudimentary server-admin skills. I’m running a couple of VPS’s with 300Mb memory for the MySQL server and 600Mb for the web server, and that’s running a fairly busy BP instance, a very busy forum, and a few other not-very busy sites as well, reasonably happily.

    I did notice a very signification reduction in resource usage after deploying and tweaking W3 Total Cache, though, for what it’s worth.

    Thanks again, @stwc. I’m still working on this issue and will report back with my findings. It has to be something on the sever…

    Ok. Here’s the update. Server checks out with proper versions of PHP and MySQL. Latest version of both WP and BP. Mod_Rewrite is functioning. Proper directories are writeable. WP is fully functional. Raw install… no other plugins active. Default theme. Looked through error log (nothing showed up). I’m stumped. Still getting the same error.

    Server tech guy says “I looked through the logs also, and did not see any errors in the error log either. I also saw that the request for ‘/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=’ returned 200, which means OK, so that is a bit weird.”

    Any insight is supremely appreciated.

    Profile photo of stwc
    stwc
    Participant

    @stwc

    For what it’s worth, I recently tried using mod_php (with XCache and W3 Total Cache, no object caching or minifying) and everything worked except the Activity stream. PHP 5.2 FastCGI seems to be the go, for me, to keep things happy.

    Profile photo of LPH2005
    LPH2005
    Participant

    @lph2005

    If you can control memory through .htaccess then I recommend adding `php_value memory_limit 128M` .. or some other value …

    After much prodding, testing, checking and more, we located the problem. If Zend Optimizer is enabled, BuddyPress will not install. As soon as we disabled it, we had a perfect install of BuddyPress. Woohoo!

    I should also note that we had memory set at 150mb prior to install and actually boosted it to 256mb just to see if that was an issue. But, it made no difference until we disabled ZO.

    I appreciate everyone’s insight and help. Hopefully, this information will help others struggling with this installation issue. Thanks @stwc and @lph2005 for your time and energy.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Buddypress is Not my Buddy… :o(’ is closed to new replies.
Skip to toolbar