Skip to:
Content
Pages
Categories
Search
Top
Bottom

Cannot install BP on a network site

  • Profile photo of harounkola
    harounkola
    Participant

    @harounkola

    Oops, I may have posted my last update in the wrong place, I did it in the group, instead of here in the forum.
    (sorry)

    I’m having trouble installing BuddyPress on a network installation of WordPress on http://socialmediamillionaire.me.
    I’m using the latest versions of WordPress and (potentially) BuddyPress.

    Everytime I attempt to install BP in the network, my site’s just blank.

    Any ideas?

    Thanks
    Haroun

Viewing 7 replies - 1 through 7 (of 7 total)
  • Profile photo of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    What messages are in your web server’s error log?

    Profile photo of harounkola
    harounkola
    Participant

    @harounkola

    Where do I find the server error log please Paul?
    Thanks

    Profile photo of harounkola
    harounkola
    Participant

    @harounkola

    This is the message I get from the Cpanel

    2011-03-28 07:35:02.265 [INFO] [HTAccess] Updating configuration from [/home/socialme/public_html/.htaccess]
    2011-03-28 07:04:16.914 [INFO] [HTAccess] Updating configuration from [/home/socialme/public_html/.htaccess]
    2011-03-28 06:58:12.472 [INFO] [HTAccess] Updating configuration from [/home/socialme/public_html/.htaccess]
    2011-03-28 06:28:54.594 [INFO] [HTAccess] Updating configuration from [/home/socialme/public_html/.htaccess]

    Profile photo of harounkola
    harounkola
    Participant

    @harounkola

    This is what’s in my .htaccess file:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*.php)$ $1 [L]
    RewriteRule . index.php [L]

    Profile photo of @mercime
    @mercime
    Keymaster

    @mercime

    EDIT – Looks like you resolved this on your own. I see all BP components, no blank pages.

    Profile photo of harounkola
    harounkola
    Participant

    @harounkola

    Not quite, I removed the code from the config.php and the above from .htaccess
    The database tables are still there so when I find out what the problem is, I’ll try again :)

    Any ideas please?

    Profile photo of @mercime
    @mercime
    Keymaster

    @mercime

    == Not quite, I removed the code from the config.php and the above from .htaccess ==

    @harounkola so you changed it back to single WP install with BuddyPress. I still see the BP components – groups, members, etc.

    Deactivate all plugins including BuddyPress and change to default twentyten theme before creating a network. There are also other reasons why your pages go blank and/or you can’t access wp-admin. One of them is that you need to increase memory limit in your server. Example of where to change it in your php.ini file e.g. to 32MB first, and if that doesn’t work, increase to 64MBis here.

    Check this out as well: https://codex.buddypress.org/troubleshooting/blank-pages/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot install BP on a network site’ is closed to new replies.