Skip to:

cannot send private messages BP

  • rebekahmeuir


    1. Which version of WordPress are you running? 4.2.2

    2. Did you install WordPress as a directory or subdomain install? root

    3. If a directory install, is it in root or in a subdirectory? root

    4. Did you upgrade from a previous version of WordPress? If so, from which version? from 4.2.1

    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting. yes

    6. Which version of BP are you running?

    7. Did you upgraded from a previous version of BP? If so, from which version? yes from BP

    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    no I temporarily removed all plugins

    9. Are you using the standard WordPress theme or customized theme? 2015 theme

    10. Have you modified the core files in any way? removed lines that contain author’s ip address for comment notification emails

    11. Do you have any custom functions in bp-custom.php? no

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? not running bbPress

    13. Please provide a list of any errors in your server’s log files. none to report

    14. Which company provides your hosting?
    inmotion hosting

    15. Is your server running Windows, or if Linux; Apache, nginx or something else? Apache

    I cannot send a private message. I compose the message. I click Send Message.
    The message does not send. The message does not appear in the Sent folder. The message does not appear in the database.
    I asked my host if there were any errors on the server. There are no errors.
    All fields on the compose message form become empty after clicking send, but the message is not sent.
    I only have 1 plugin active – BuddyPress
    I am using the 2015 Theme.

Viewing 6 replies - 1 through 6 (of 6 total)

  • 5high


    @rebekahmeuir – this has just started happening to me too. All plugins, BP and themes up to date (with theme that’s specifically designed to work with BP).

    On tesing the messaging works if you send it to a member by clicking on the ‘send private message’ in the All members section, but NOT when you compose a message in your own p[rofile section – with subjest line completed, and tested using the memebers’ Name and username. It shows an error message that the message can’t be sent.

    Anyone else experiencing this?

    I’ll check with other plugins and the theme and will update here if I find anything, but any info would be really useful!




    I know this is a VERY old thread but it’s exactly the same problem: – may be helpful if you’re well versed in BP?



    Update; have just tested it with default 2015 theme and all plugins deactivated except for BP and still the same error. I have no idea why this should suddenly happen as i didn’t update BP, only theme and some plugins.

    The other thing I noticed was that when you enetr the @username or the members name it doesn’t auto-populate, or throw up the correct one to add – so this functionality seems to have stopped, which maybe why it doesn’t send???

    Any ideas would be appreciated.



    OK, after some help from the theme team we’ve worked out what’s happening:
    1. message sends OK if only use the username but NO @ sign!
    2. the send to box doesn’t auto=popu;late because i have ‘allow friends’ disabled
    3. error still occurs if you just use the name (not username)

    So it looks my problem is related to not allowing friends rather than anything else. I’ll start a new thread to see if there’s a workaround for this so it still allows to send by member’s name and if it can still auto-populate.

    Hope this helps a bit @rebekahmeuir?



    thanks for the encouraging information @5high

    unfortunately, my private messages still do not work. It allows me to compose the message, but when I click Send Message, the message does not send. I do not get an error. The message form goes empty and the message does not appear in the database. The message does not show in the sent messages. It just disappears.



    OK, sorry I couldn’t help. In fact I resolved my problem by sticking with the BP default/usual setting of enabling friends and everything works as expected now. maybe you have something turned off in the BP settings? Beyond that suggestion you’ll need someone with much more experience of BP than me I’m afraid – good luck!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘cannot send private messages BP’ is closed to new replies.
Skip to toolbar