Skip to:
Content
Pages
Categories
Search
Top
Bottom

Cannot Sign up


  • indra1007
    Participant

    @indra1007

    Hi all…
    help me please…

    i have test my WP without buddypress, then i can signup. my link is up.
    when i installed the buddypress ,my signup link is broken.
    i use WP 4.7.2 and buddypress 2.8.0
    my site :

    Home

    please help me.

Viewing 6 replies - 1 through 6 (of 6 total)

  • danbp
    Moderator

    @danbp

    Hi and welcome to BuddyPress!

    It seems that you didn’t setup correctly your BuddyPress pages. Ensure they exist and are correctly declared. And also don’t forget to activate your permalinks.

    Common advice: read the documentation before installing a plugin.

    Configure BuddyPress


    Slava Abakumov
    Moderator

    @slaffik

    Registration link is broken.

    It should be http://cintaku.id/register/, and NOT http://cintaku.id/index.php/register/.
    Go to permalinks settings and make it like this: http://take.ms/l5qFy
    Then click Save.


    indra1007
    Participant

    @indra1007

    i have setting permalink like you said. i dont works.


    Slava Abakumov
    Moderator

    @slaffik

    @indra1007

    Have you read the article that was linked by @danbp?
    Do you have .htaccess file in the same diretory where you installed WordPress?
    If not, create it with this content:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    More details here: https://codex.wordpress.org/htaccess


    Bradley Ross
    Participant

    @bradleyross

    I have .htaccess
    I have loaded the entire system three times and followed the directions
    I have made sure that all of the files have an owner of _www

    I have already screamed and will probably do so again. I am currently using

    Apple Macintosh macOS 10.12.3
    Wordpress 4.7.2
    Theme: TwentySeventeen
    bbPress 2.5.12
    BuddyPress 2.8.0
    Jetpack 4.6

    The requested URL /blogs/wordpress/template/members/bradleyross/profile/edit/ was not found on this server.
    The page register has the permalink http://localhost/blogs/wordpress/template/index.php/members
    Does this sound correct

    It also appears that multiple attempts to load the software may result in things like members-2 and members-3. You may have to send pages with those permalink to the trash and then empty the trash. Hopefully, you can then recreate the pages correctly

    I now assume that the problem is somewhere in the rewrite module. In the httpd.conf file, I am going to change the line Allow None to Allow FileInfo. Does this sound reasonable and are there any other changes you think that I should make.

    in httpd.conf, I have

    LoadModule alias_module libexec/apache2/mod_alias.so
    LoadModule rewrite_module libexec/apache2/mod_rewrite.so
    #
    # The two following lines had been commented out as part of the
    # update July, 2015. They are now being uncommented to
    # put them back in
    #
    LoadModule php5_module libexec/apache2/libphp5.so
    LoadModule hfs_apple_module libexec/apache2/mod_hfs_apple.so

    and

    <Directory “/Library/WebServer/Documents”>
    #
    # Possible values for the Options directive are “None”, “All”,
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that “MultiViews” must be named *explicitly* — “Options All”
    # doesn’t give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    # The attribute Includes was added 17-Feb-2017
    Options FollowSymLinks Multiviews Includes
    MultiviewsMatch Any

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be “All”, “None”, or any combination of the keywords:
    # AllowOverride FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
    </Directory>


    Bradley Ross
    Participant

    @bradleyross

    From my previous post, changing AllowOverride None to AllowOverride FileInfo seems to have made the member, groups, and other pages operational.

    The following is a diff of the httpd.conf from the Yosemite version of macOS and my current version. Remember that there are three configuration files: httpd.conf, my.cnf, php.ini
    https://bradleyaross.wordpress.com/2017/02/04/wordpress-installation-problems/

    BradleyRossMacBook:apache2 bradleyross$ diff httpd.conf httpd.conf-YosemiteDefault
    22,25d21
    < #
    < # History:
    < # Starting with httpd.conf.pre.update which was dated July 1, 2015
    < #
    107,109d102
    < #
    < # The line for mod_include.so was uncommented 17-February-2017
    < # to allow the use of server side includes
    164,167c157
    < #
    < # The line for mod_cgi.so was uncommented on 17-Feb-2017
    < #
    < LoadModule cgi_module libexec/apache2/mod_cgi.so

    > #LoadModule cgi_module libexec/apache2/mod_cgi.so
    178,186c168,170
    < # See http://askubuntu.com/questions/48362/how-to-enable-mod-rewrite-in-apache
    < LoadModule rewrite_module libexec/apache2/mod_rewrite.so
    < #
    < # The two following lines had been commented out as part of the
    < # update July, 2015. They are now being uncommented to
    < # put them back in
    < #
    < LoadModule php5_module libexec/apache2/libphp5.so
    < LoadModule hfs_apple_module libexec/apache2/mod_hfs_apple.so

    > #LoadModule rewrite_module libexec/apache2/mod_rewrite.so
    > #LoadModule php5_module libexec/apache2/libphp5.so
    > #LoadModule hfs_apple_module libexec/apache2/mod_hfs_apple.so
    235,237d218
    < # Apparently the slash at the end of the Directory open tag
    < # refers to the root of the file system rather than /> indicating
    < # an empty tag
    269,270c250
    < # The attribute Includes was added 17-Feb-2017
    < Options FollowSymLinks Multiviews Includes

    > Options FollowSymLinks Multiviews
    278,281c258
    < # The attribute None was changed to FileInfo 17-Feb-2017:wq
    <
    < #AllowOverride None
    < AllowOverride FileInfo

    > AllowOverride None
    453,455c430,431
    < # The following two lines were uncommented on 17-Feb-2017
    < AddType text/html .shtml
    < AddOutputFilter INCLUDES .shtml

    > #AddType text/html .shtml
    > #AddOutputFilter INCLUDES .shtml
    BradleyRossMacBook:apache2 bradleyross$

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar