Skip to:

Comments are not working!

  • Suddenly, the comments button in my activity stream does not work. When I click “comment” on an update it does nothing but reload the page. I am getting this error when I examine it with Firebug:

    ‘BP_DTheme is not defined’
    ‘jq(this).before( ‘<li class="show…+ BP_DTheme.comments + '‘ ); ‘

    I noticed it was because there was an update in my stream that had 7 comments. It seemed like the script did not know how to hide it, which I guess it is supposed to if it is over 5? So I got rid of that update and everything is working when I delete it, but this happens randomly everytime an update gets 5 or mor comments. PLEASE HELP asap as my site is live and my members cannot comment on each others activity. thank you!!

Viewing 9 replies - 1 through 9 (of 9 total)

  • @mercime


    I have this issue as well. Just migrated from a shared hosting environment to a VPS. This is the only change I’ve made. My stats:
    Wordpress 3.1
    Buddypress 1.2.8
    Default Favicons
    Root Directory
    Core files untouched

    BuddyPress Template Pack
    W3 Total Cache with Object Cache & Minify active
    MarkItUp RTE (manual JS plugin install)

    So the issue is only on some groups. On both groups that work properly and don’t, there are no obviously problematic HTML validation errors. On the groups that are problematic, MarkItUp doesn’t appear on the textarea, and when “reply” is clicked, the page reloads (hashtag visible), and no comment box appears. Oddness. Thoughts?

    Can anyone help here? This is causing A LOT of problems on my site.

    Seriously guys, if someone could PLEASE help me out. I am going to lose members because of this. It breaks my main activity steam. It happens when a status update reaches 5 comments or more. I can post any more data if required.

    Here is a permalink to the issue:




    Hi, I know you posted this long ago but I just faced the same issue, and was able to come up with a temporal fix.

    As you mentioned, there is a limit of 5 posts there, to get displayed. just change them to a bigger number. i changed to 50 so the site works, until i can find a better solution.

    To maje the change, just go to:


    then edit this code, to be 50:

    /* Hide long lists of activity comments, only show the latest five root comments. */
    function bp_dtheme_hide_comments() {
    	var comments_divs = jq('div.activity-comments');
    	if ( !comments_divs.length )
    		return false;
    	comments_divs.each( function() {
    		if ( jq(this).children('ul').children('li').length  li');
    		var comment_lis = jq(this).children('ul').children('li');
    		var comment_count = ' ';
    		if ( jq('li#' + parent_li.attr('id') + ' a.acomment-reply span').length )
    			var comment_count = jq('li#' + parent_li.attr('id') + ' a.acomment-reply span').html();
    		comment_lis.each( function(i) {
    			/* Show the latest 50 root comments */
    			if ( i < comment_lis.length - 50 ) {
    				if ( !i )
    					jq(this).before( '
  • ' + BP_DTheme.show_all + ' ' + comment_count + ' ' + BP_DTheme.comments + '
  • ' ); } }); }); }

    Hope its not too late to help! 🙂





    Hi Leo…ran across this while searching for a solution to just posting comments in general. I’ve been having problems posting to the BP forums and know one has responded to my previous posts with a solution that works…



    Okay….I am completely frustrated at this point guys.
    I started off with a fresh install of 1.6.2 and tried applying the patches thru cpanel as suggested. First I tried 6326 suggested by mercime but as wpte pointed out it was from upstream which didn’t work.
    Then I did another fresh install along with a fresh install of bb Press and tried 4510 no luck. Then as r-a-y suggested I tried the 6704 same result and finally broke down and just installed 1.6.3. Still no go.



    I’ve been experiencing the same issues since I started this process over 2 weeks ago. I can create groups, forums and post replies… however, within the group and/or forum or even after going in using the “Activity” link on my sidebar to access the “Activity Stream Directory” page, I CAN NOT do the following:
    1. Post to the text box which is should expand the box and generate a button. Neither actions are functioning.
    2. When commenting on a previous member’s post using the 3 shaded buttons ,
    , member avatar along with an expanded text box should be generated along with a “button” and the instruction
    Neither of these are functioning by design as well.
    When pressing the button, the command generates the avatar, text input box and “button” with the instruction but then it just refreshes the page. Not allowing you to post the comment.



    What strikes me as odd is that if it has something to do with the activity stream files why am I still able to “Load More” activity using the button at the button of the page? At this point I dunno what’s wrong.

    Does it have anything to do with my Artisteer Theme or maybe a plugin I have installed?
    Sorry to bother you guys and again forgive me as I’m just an end user with a little knowledge trying to get the social part of my site functioning properly. If anyone can give me some advice or has time to take a look at it for me it would be greatly appreciated.
    Thanks in advance…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Comments are not working!’ is closed to new replies.
Skip to toolbar