Skip to:
Content
Pages
Categories
Search
Top
Bottom

“Create group” returns me to home


  • athimm
    Member

    @athimm

    When I try to create a group the URL changes to http://the.site/groups/create/step/group-details/, but the contents shown are the WP Loop, e.g. I never get to enter any group details to create a group.

    I am using a very fresh WP 3.1.3 and BP 1.2.8 as well as a couple standard plugins like Akismet, Analytics etc. The theme is the standard bp-default theme that ships with BP. I wiresharked the traffic and there is no 302 redirect to the top level URL (like some other bug reports stated). There is also no output in httpd’s error log.

Viewing 6 replies - 1 through 6 (of 6 total)

  • @mercime
    Keymaster

    @mercime

    Some thoughts:
    – Have you checked Apache if “Allow Override All” is enabled ( not commented out)?
    – Where is your WP installed – at domain root or in subdirectory? If in subdirectory, the subdirectory name should not named the same as that of BP components – Groups, Members, Activity, Forums. If name of subdirectory is same , you would have to “rename” matching BP component name to something else in your wp-config.php file e.g. `define ( ‘BP_GROUPS_SLUG’, ‘sections’ );` or if your subdirectory is named members, `define ( ‘BP_MEMBERS_SLUG’, ‘scouts’ );`


    Doug
    Participant

    @dougdaulton

    I think I am experiencing the same behavior. (WP 3.1.3 + BP 1.2.8). Screencast shows the behavior:

    http://screencast.com/t/4la4PnA8X


    athimm
    Member

    @athimm

    @mercime: I tried AllowOverride All and there was no difference. WP/BP is installed under root, there is no subdirectory. BTW the URL in question is http://planetdsa.gr
    @doug.daulton: Your case is a bit different, I’m not even getting to the group create form, I immediately get to the home page even though the address bar says http://planetdsa.gr/groups/create/step/group-details/


    athimm
    Member

    @athimm

    I also turned off all plugins but BP itself and the problem is still the same. :/


    Doug
    Participant

    @dougdaulton

    @athimm – Thanks for the clarification. Have you done a “tail” on your apache error log? Mine is showing this:

    [Sat Jun 04 08:46:13 2011] [error] [client 24.234.182.233] File does not exist: /vol/sites/neoncon.com/dev/groups, referer: http://dev.neoncon.com/groups/
    [Sat Jun 04 08:46:21 2011] [error] [client 24.234.182.233] File does not exist: /vol/sites/neoncon.com/dev/groups, referer: http://dev.neoncon.com/groups/create/step/group-details/


    @mercime
    Keymaster

    @mercime

    @athimm could be the permalink structure like this ticket https://buddypress.trac.wordpress.org/ticket/1766

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Create group” returns me to home’ is closed to new replies.
Skip to toolbar