Skip to:

Delete Selected not working

  • Famous


    Delete Selected in messages – when checking the checkboxes and clicking Delete Selected nothing happens.

Viewing 10 replies - 1 through 10 (of 10 total)

  • bp-help


    You need to supply your info as it instructs in the above link on every support topic you open because it is isolated to your individual setup! Otherwise it is just a pure guess which usually doesn’t fix the issue.



    1. Which version of WordPress are you running? latest

    2. Did you install WordPress as a directory or subdomain install? directory

    3. If a directory install, is it in root or in a subdirectory? root

    4. Did you upgrade from a previous version of WordPress? If so, from which version? been upgrading to latest

    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting. wordpress works fine

    6. Which version of BP are you running? latest

    7. Did you upgraded from a previous version of BP? If so, from which version? been upgrading to latest

    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones? none

    9. Are you using the standard BuddyPress themes or customized themes? using 2012

    10. Have you modified the core files in any way? no

    11. Do you have any custom functions in bp-custom.php? no

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? Version 2.3.1

    13. Please provide a list of any errors in your server’s log files. TypeError: jQuery.easing[jQuery.easing.def] is not a function
    Line 1455

    14. Which company provides your hosting? godaddy

    15. Is your server running Windows, or if Linux; Apache, nginx or something else? lamp

    @famous the function works fine. Ensure you do have a selection of messages checked and that you have then selected the type of message to delete i.e ‘read’, ‘unread’ click delete selected and the will be removed.



    When I do what you said, and click the link, I just get pushed back to the top of the page like an anchor link with no effect.



    I am having the exact same issue.
    I can delete one by one, but if I select all and hit Delete Selected it scrolls to the page top.
    The link on delete selected is this : /timebank/members/name/messages/#

    It does the same whether admin or not.

    Disabled all other plugins, still no result.

    bp-custom.php? = no
    WP 3.8
    BP 1.9.1
    Twenty Fourteen
    Directory install

    Nishant Kumar


    Hello All,

    I found a solution for this and already have created a ticket for this. See link below for solution.

    Nishant Kumar

    Nishant Kumar


    Don’t know why my link was not posted. Here it is if it can.



    @nishant_official I can confirm your fixed worked great!

    I cringed when modifying the core file outside of a child theme but needed the fix. Previously the delete link was redirecting me to the top of the page by adding “#” to the end of the page URL. Added the change you outlined in your ticket and it work flawlessly. Thanks for taking the time to look into and create a ticket!

    BuddyPress 1.9.2, WordPress with Multisite 3.8.1.

    Nishant Kumar


    @backpackersunion, you are welcome.

    As per the ticket status. It was already fixed in trunk.

    Thanks community.



    This is claimed as fixed, though I am using the most updated version of buddypress and still having the same problem. Do I have to pull from the trunk to get the truly most updated version or do y’all push it to the wordpress plugin repo?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Delete Selected not working’ is closed to new replies.
Skip to toolbar