Skip to:

external-group-blogs & group-twitter doesn't work

  • I installed the updated plugin from andy on my testinstall with bp 1.2 but thes don’t seem to do anything. Although there were tweets (with and without an @mention) and there were for sure alot of new blogposts – nothing showed up in the activity.

    With the old external-group-blog-plugin there was a bug fetching the new content (… you had to visit the groupblog-page. Now nothing like that exists anymore (which totally makes sense!), but maybe that’s the problem.

    Any others experiencing the same?

Viewing 25 replies - 1 through 25 (of 28 total)

  • Anton


    I’ve installed the group twitter plugin on my BP 1.2 and WPMU but it doesn’t show the latest tweets so yes, I’ve got the same problem.

    Maybe Andy should say something about it, for he is the creator of those plugins… :-)

    Are you using the newest versions? 1.1?

    They will only work with trunk NOT the 1.2 beta.

    Thanks – I didn’t know that. I updated to trunk now and it seems to work. I think there are some issues, still (at least in my install):

    1. Twitter: The latest tweet showing is 4 days old… (many more tweets in the time between

    2. Twitter & External-Group-Blog: In other languages – in my case german – the “Umlaute” like äöü are showing strange like ü (I guess this is an easy one :-))

    3. External-Group-Blog: The latest rss-entry showing is about 3 days old – there were many others in between

    4. The “view” of an item from those plugins does not show in the “normal” narrow-way, but is just in the group (but mybe that’s on purpose…)

    A further suggestion:

    Wouldn’t it be nice, when tweets with a @somebody wouldn’t be fetched/showed… It could be pretty confusing with ¨@somebodys from twitter and other ¨@username from buddypress…

    But besides that: Thanks for the update. Great additions!!!

    Andy, I think the problem is still the same as in the first version of the plugin. It doesn’t really fetch the new stuff. When I visit the backend, and push the update buttons (both twitter and external-blogs) then the stuff gets fetched (I just found out).

    For the “old” version somebody recommended a solution to this ( did you consider that?

    It would be great, if those plugins would work correctly with the release of BP 1.2 :-)

    If 15 minutes have passed since the last update and someone visits the group, it will update again. I’ll look into that link, but after 1.2 is released.



    Is there a way to make group-twitter and external-group-blogs work with BP 1.1.3 and WPMU 2.9.1?

    There was another thread with some code fix suggestions, but I can’t find it now.

    It’s the Link I have posted above.

    : ok, thanks.



    @Michael Berra, there was yet another thread with several suggested solutions, not that one.

    Andy, I really think it doesn’t work the way you mentioned. I visit the group, but nothing happens. I have to fetch the new information through pressing the update-buttons.

    It would also be great, if the gruop would have to be visited to fetch the information.It would be great, if it just fetches the info from time to time (cron-job or something).

    Thanks for checking it again after the big release :-)

    on RC2 and using both plug-ins…

    Everything imported fine during the initial seed but I found the records in the activity table started to disappear – the newest items (rss feed either blog posts or twitter statuses) to a point where only items from 3 months ago was present.

    Each time I visited the group it was incrementally removing the items. ie first day everything showed, next was 3 days off, a week, month, then 3 months ago and so forth.



    I’m getting the following when adding a new external feed in BP 1.2. Also, an extra slash is added to the External Blogs Admin URL (between the group name and admin). Anyone else?

    Warning: array_map() [function.array-map]: Argument #2 should be an array in …/plugins/buddypress/bp-groups.php on line 2454

    Thanks for updateing, Andy. It works now alot better (as far as I can tell after this little time…)

    But still in the Twitter-Plugin the problem with foreign characters (like german Umlaute)

    It the shows like that: Ein wunderschöner Tag – und ich sitze im Büro… Aber was macht man nicht alles für den Herrn! :-) (oder macht er grad diesen Tag für mich?)

    By the way: If I want to translate those plugins – how must the .po file be named, and where does it need to be put (and, I you would like, andy, where should I send the translation)?

    Andy I sent you a message but the duplication issue is still present.

    I had to update the bp_activity_get_activity_id and groups_record_activity to use the 'secondary_item_id' => wp_hash( $post['link'] ) instead of the blogurl. Unfortunately that leads to a slippery slope problem when removing a feed as the code under edit_screen_save() references the blogurl

    possible to hook into the bp_activity_meta table to assign the blogurl?

    Also the group twitter at times is not saving the “in the group” link

    and a feature suggestion -> limit the number of rss feeds (or published date) when fetching

    I just found out, that those plugins and “Group Activity Email Notifications” doesn’t really nicely work together. Everytime it fetches, the notification-plugin sends out emails… :-( But I guess it’s a “bug” there and I post it there as well…

    *just as a warning*

    yes – a limit would be very good (important!) – I guess there is none?



    I have a problem with the plugin on my bp 1.2 wp single site. I’ve added the plugin and added a rss to a test group. It seems that it adds the same item more than once in the external blog posts. Is there a way to prevent duplicates? Can I set this in the code that it should first check for duplicates and only show unique posts?




    see my post above – that fixed the problem for me and duplicates. (basically get_activity_id kept looking at the hashed blogurl instead of the posturl) i also had to remove the action piece from the get_activity_id




    This is still broken. Does multiple posts.

    WP 2.9.2 single BP 1.2.1

    I’ll look at fixing them this weekend.



    Thanks Andy! This is a great plugin for Single WP to allow users to have a “blog” onsite.



    Yep. Feel the same. Great plugin!

Viewing 25 replies - 1 through 25 (of 28 total)
  • The topic ‘external-group-blogs & group-twitter doesn't work’ is closed to new replies.
Skip to toolbar