Skip to:

feedwordpress and php warning

  • Profile photo of Mark Schafer


    Since upgrading to Buddypress 1.1 I have been getting the errors below on blogs using feedwordpress. The first error is not on every page visit. It will appear on the frontend (under buddypress bar) and it generates a lot of entries in my php error_log. The second error is related and occurs less often. I did not have this error with BP 1.0.3 and I do not have the issue when Buddypress is disabled – so it is not directly a wpmu issue. Are others using BP 1.1 and feedwordpress seeing this error? If you do not have this error I wonder if you are using BP 1.1. Could loading the Buddypress Bar cause a conflict with feedwordpress?

    PHP Warning: Illegal offset type in /public_html/wp-includes/rss.php on line 1459

    PHP Warning: Cannot modify header information -headers already sent by (output started at /wp-includes/rss.php:1459) in /wp-includes/feed-rss2-com

    WPMU 2.8.4, BP 1.1.1, PHP 5.2.5, using current rss files from the Magpie folder in feedwordpress (2009.0707).

    Enjoy the error here:

Viewing 3 replies - 1 through 3 (of 3 total)
  • Profile photo of Jeff Sayre
    Jeff Sayre


    What happens when you disable FeedWordPress?

    If the errors go away, then there is an incompatibility issue with that plugin and the current version of BP and/or version 2.8.4 of WPMU. Contact the plugin developer, provide them with the details about your issue, and ask when the plugin will support BP 1.1.1 and WPMU 2.8.4.

    Looking at the listing for FeedWordPress ( ), it does not mention that it is even compatible at all with BP. It also indicates that it is only compatible up to version 2.8.1 of WP.

    Profile photo of r-a-y


    @mark, make sure you upgrade your FeedWordpress plugin as I’m guessing you upgraded from WPMU 2.7.1 to 2.8.4a.

    FeedWordPress has undergone major changes since then to be compatible with 2.8+.

    Oh! and also overwrite the default WordPress RSS library with FWP’s Magpie RSS library.

    For more, read the upgrade installation instructions:

    Profile photo of Mark Schafer


    @jeff, no problem when feedwordpress is disabled. And yes, compatibility up to 2.8.1 is a problem

    @r-a-y thanks for feedback. My setup consists of the latest plugin and RSS libraries. Issue still exists but further discussion should take place here:

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘feedwordpress and php warning’ is closed to new replies.
Skip to toolbar