Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Fixed] Duplicate & Missing Pages on Upgraded Buddypress Installation


  • KylieSocial
    Member

    @kyliesocial

    Hi, I upgraded my Buddypress site to the latest version, but I have duplicate pages of ‘Members’, ‘Forums’, ‘Activity’ and ‘Groups’. I also can’t post a new status update as the ‘activity/post’ page is missing. Help?! Thanks :)

Viewing 14 replies - 1 through 14 (of 14 total)

  • @mercime
    Keymaster

    @mercime

    What theme are you using? Could be that it needs to be updated.

    Re duplicate pages of Members, Forums, Activity and Groups – do they have the same content as the original pages with same name?


    KylieSocial
    Member

    @kyliesocial

    I was using Jooc and now switched to bp-default and the duplicate pages have gone – thanks :)

    But, the ‘activity/post’ page is still missing, so users can’t post status updates.

    Thanks Mercime for your quick response.


    Boone Gorges
    Keymaster

    @boonebgorges

    > But, the ‘activity/post’ page is still missing, so users can’t post status updates.

    Does this mean that there is no page when you go to http;//example.com/activity? Have you activated the Activity component? Or do you mean that there is no form for users to enter activity updates on the existing page?


    KylieSocial
    Member

    @kyliesocial

    There is an activity page and a place to post a status, but when you click ‘Post Status’, it takes you to http://example.com/activity/post – which doesn’t exist so displays a Page not Found. The http://example.com/activity page does exist and is functional.


    KylieSocial
    Member

    @kyliesocial

    Sorry if I’ve not made myself clear, but when you click the ‘Post Status’ button, you are automatically taken to a page called http://www.example.com/activity/post – which doesn’t exist. Just tried a few other BP sites and when you leave a status update on those you stay on your profile and the status appears, but now on mine you are re-directed, but because the page doesn’t exist, the status doesn’t post.


    BlogNostics
    Member

    @blognostics

    hi KylieSocial .. you are not alone as we are getting the same 404 error. I hope someone can up with a solution
    Cheers

    Hey guys

    Regarding /activity/post/ being broken. If you are using the default theme, and have javascript disabled, you will get this problem. If you are using a 3rd party theme without BP-Default’s javascript, problem will also occur. I’ve just fixed this bug in core: https://buddypress.trac.wordpress.org/ticket/3612

    It will be in BP 1.5.1


    BlogNostics
    Member

    @blognostics

    thanks Paul but what do we do as in how do we resolve the problem now? Or do we wait for the update?
    Cheers

    It’s as simple as adding one exclamation mark. Look at https://buddypress.trac.wordpress.org/changeset/5187 — red is deleted, green is added or modified.


    BlogNostics
    Member

    @blognostics

    Cheers mate, it’s always an exclamation mark… pesky buggers :)


    KylieSocial
    Member

    @kyliesocial

    Thanks so much :)

    We’re sorry we made the typo. :)


    BlogNostics
    Member

    @blognostics

    Is there also a typo for the Reply button too? as that ceased to work


    BlogNostics
    Member

    @blognostics

    any way i can get the previous version back as that was working great?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Fixed] Duplicate & Missing Pages on Upgraded Buddypress Installation’ is closed to new replies.
Skip to toolbar