Skip to:

Forums Bug: There are no posts for this topic.

  • Hi Guys,

    Since migrating a site from my local XAMPP install to our live LAMP server I have encountered a problem with the forums.

    I can successfully post a new topic, it appears on the global forum and group forums as normal however when clicking through to the topic page, it states ‘There are no posts for this topic.’ and has no post new topic form.

    I have tried disabling ALL plug-ins except for BuddyPress and have tried re-installing the forums.

    Is there a known cause for this issue? I’ve noticed that several users have encountered the same problem but with no response, so any help on fixing this would be massively appreciated!



Viewing 13 replies - 1 through 13 (of 13 total)

  • Lisa Sabin-Wilson


    I have encountered this bug, as well – many times….typically when I have moved a WP/BP site from a localhost to a new domain – – or when I’ve assisted in the transfer of the site to a new host.

    After banging my head for awhile – I resolved it by reinstalling the forums (easy – just click the Forum Setup in the BuddyPress section in your Dashboard. and click re-install) – then went into each group that has forums enabled, as admin – disabled the forums for that group, then re-enabled the forums for the group…after that, it worked.

    Not sure if its a bug, or if this is the accepted solution – however, it’s what worked for me on three completely different sites where I experienced this particular problem.

    Timely, yes (especially on a site with lots of Group forums) – but it worked.

    Additionally, this thread reports that this problem was caused due to the bbPress sitemaps plugin – not sure if you’re using that:

    Good luck!

    Hi Lisa,

    Thanks a lot for your reply! Much appreciated.

    I’ve re-installed the forums via the dashboard, disabled and then re-enabled forum discussion on all groups. Unfortunately though, no luck.

    When re-installing the forums, no topics are lost – is that correct or are the forums just not re-installing correctly? Is it worth wiping the database?

    Running out of ideas!

    Check your bbpress config file, I remarked on this on another thread this morning also I outlined the steps in another on ensuring that group forums re-saved but that is more for situations where one tries to create a topic but gets told it wasn’t possible to create the new topic or reply.

    Don’t at this stage wipe your DB!

    Hi hnla,

    Cheers for getting back to me.

    Anything in particular I should be checking for within the bbpress config file? Any common issues?


    * The base configurations of bbPress.
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys and bbPress Language. You can get the MySQL settings from your
    * web host.
    * This file is used by the installer during installation.
    * @package bbPress

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for bbPress */
    define( ‘BBDB_NAME’, ‘XXXXXXX’ );

    /** MySQL database username */
    define( ‘BBDB_USER’, ‘XXXXXXX’ );

    /** MySQL database password */
    define( ‘BBDB_PASSWORD’, ‘XXXXXXX’ );

    /** MySQL hostname */
    define( ‘BBDB_HOST’, ‘webmysqlc’ );

    /** Database Charset to use in creating database tables. */
    define( ‘BBDB_CHARSET’, ‘utf8’ );

    /** The Database Collate type. Don’t change this if in doubt. */
    define( ‘BBDB_COLLATE’, ” );

    * Authentication Unique Keys.
    * Change these to different unique phrases!
    * You can generate these using the { @link secret-key service}
    * @since 1.0
    define(‘BB_AUTH_KEY’, ‘FFle:4nNpJdjc?ZN Rd|-wU?(^#q0;|G<JV~h7ge2U/c+:GQpVlt<-k+N~d6(}K2');
    define(‘BB_SECURE_AUTH_KEY’, ‘jIavIN_$k[JQvTd,*@>=v92p2408oq|c-L=*<~y;5k,*9!u2]CR18g8&=%V{D3u');
    define(‘BB_LOGGED_IN_KEY’, ‘rgY,]@|N>P/s.-wC,~0F~pP+uX)e|PfpuZcYd7g}+-f GL6mV+ki)!~tFq20c+90’);
    define(‘BB_NONCE_KEY’, ‘A6gR;@/XnI#L}VVwojdCWrKJ;uUN:AE|!’);

    * bbPress Database Table prefix.
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    $bb_table_prefix = ‘wp_bb_’;

    * bbPress Localized Language, defaults to English.
    * Change this to localize bbPress. A corresponding MO file for the chosen
    * language must be installed to a directory called “my-languages” in the root
    * directory of bbPress. For example, install to “my-languages” and set
    * BB_LANG to ‘de’ to enable German language support.
    define( ‘BB_LANG’, ” );

    $bb->custom_user_table = ‘wp_users’;
    $bb->custom_user_meta_table = ‘wp_usermeta’;

    $bb->uri = ‘;;
    $bb->name = ‘Forums’;

    define(‘BB_AUTH_SALT’, ‘put your unique phrase here’);
    define(‘BB_LOGGED_IN_SALT’, ‘put your unique phrase here’);
    define(‘BB_SECURE_AUTH_SALT’, ‘put your unique phrase here’);

    define(‘WP_AUTH_COOKIE_VERSION’, 2);


    You just need to ensure that this file has same access details for DB as wp-config -also is that path correct ‘’ ‘test’?

    Path is correct however the ‘test’ directory is password enabled, would this be a possible cause of the problem?

    I shall double check with IS that the file has the correct DB permissions. There’s a chance it may not.

    I shall let you know the outcome!

    Hi Guys,

    Still having troubles with this bug, just a quick question.

    Do the SALT strings require values?




    I am having the same issue.
    I also deactivated all plugins, wiped and reinstalled BuddyPress, and even dropped all bp_ and bb_ tables from the database.
    Still not working. My case is not even a migration of a site to live. This is a site that has only been developed locally on XAMPP.
    BP 1.2.8 and WP 3.1 on XAMPP
    Any one have any solutions for this yet?



    @munman Did you enable mod_rewrite on XAMPP?

    Did anyone resolve this? I have BuddyPress 1.2.8 installed on WordPress 3.1 (not multisite). I am using the default theme. I have not installed any other plugins. Seems I’m in the same situation as munman. mod_rewrite is enabled.

    The cause of the problem seems to have been identified here. Manually creating the wordpress_bb_posts table seems to fix it.

    this is the answer you need guys: it help me out too…

    Here is solution:
    1) delete buddypress.
    2) It might be useful to check if the tables for bbpress were deleted. Check also there is no bb-config.php in the web root folder.
    3) reinstall buddypress
    4) change ‘TYPE = MYISAM’ to ‘ENGINE = MYISAM’ in /wp-content/plugins/buddypress/bp-forums/bbpress/bb-admin/includes/ before creating groups and using forums.
    5) create groups and test forums.

    And I find it here:

    a member @fladnag pointed this out in a different thread…

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Forums Bug: There are no posts for this topic.’ is closed to new replies.
Skip to toolbar