Skip to:

I cannot find .htaccess file to moderate it

  • Hello,

    I have installed buddypress and I have activate it. but I got a message to moderate manually .htaccess file because it is not writable. The problem is that I cannot find .htaccess file. Where exactly is, I mean under which subfolder?


Viewing 9 replies - 1 through 9 (of 9 total)

  • intimez


    @angelntini The .htaccess file may be hidden. Depend on what program you use to access your files, you need to show all files.

    The standard WordPress .htaccess will be on the root directory of your website (once you enable pretty permalinks, at least).

    thanx for replying intimez and Paul. I use Filezilla, and I have enabled have enabled the option to show “hidden files”. However I still can’t find the .htaccess file under the “/” folder.

    What do you mean by enabling “pretty permalinks” Paul?




    @DJPaul is referring to the pretty permalinks setting within the admin dashboard. Scroll down and click on Settings and then click on Permalinks. Say you select the second choice and save, you will see .htaccess in same folder as wp-config.php



    @angelntini You’ll probably have to create the file if that folder’s not writeable. I use to have to do that. Just create a blank .htaccess file. Then, paste the code in. Or make it writeable so that it can be updated from within WordPress.

    Thanx intimez and Paul. I select settings->permalinks and then a common setting like the second (date and name) or third (month and name) but when I click “Save Settings” there is a message (in greek this is the translation) on the bottom of the page that “if the .htaccess file was writable then save will be automatically be completed, but it seems that it is not. Here are the rules mod_rewrite that you must enter into the .htaccess file.

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    So, I cannot save settings and I cannot find .htaccess file. I have manually (I uploaded the folder with filezilla) installed buddypress, because there was a problem with automatic installation. Maybe it is the “same” problem again…

    I also tried to create the “.htaccess” file as Paul suggests but since I have windows xp, it is impossible to create a file without a filename.
    I tried to make the “/” folder writeable also (I give you the procedure I followed). I logged in with filezilla and I right clicked on “/” folder. Then I clicked on file properties and I ticked “write” on owner, group and public and I also selected to apply this setting to subfolders.
    Unfortunately, the problem remains :(

    you don’t want write on public for your root folder – the recommended permissions for htaccess file is 644 -rw-r–r– try just modyfying the permissions for the actual file .

    this page of the WP codex is helpful if you haven’t already run across it.

    I would give it a read as it sounds as though you may well have set slightly dangerous file/folder permissions now.

    Editing a file without filename on windows systems is possible you just need to use a decent code/text editor, but definitely not notepad or the like, failing that you should be able to upload say htaccess.htaccess and simply rename it once uploaded to the remote server removing the filename.

    thanx hnla! it was very helpful the link about the file permissions.

    I created the .htaccess file using notepad++ and I copied there the code as suggested. However, when I upload the .htaccess file on the root directory, and try to save or move away from the page I see a blank page and the message:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    When I remove the .htaccess file everything goes back to “normal” again, so obviously there is a problem here… :(

    Sounds as though there is an error in your rules within the .htaccess file, any small error in syntax can cause server error.

    Notepad++ should be able to save files without a name, but as long as you have the file uploaded you should be able to download, modify in notepad++ and re-upload without issues.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘I cannot find .htaccess file to moderate it’ is closed to new replies.
Skip to toolbar