Skip to:

Members list not showing – BP1.2

  • designodyssey


    My install.

    * BP1.2 Beta

    * WP2.9.1

    * Hybrid – Parent Theme

    * Hybrid News – Child theme (modified with BP1.2 beta folders, functions & styles)

    On the members page, /members, the number of members is displayed, but the list of members is not displayed. Checking the files, I tried un-commenting the following from /members/index.php, which is now in they Hybrid News folder:

    <div id="members-dir-list" class="members dir-list">
    // The loop will be loaded here via AJAX on page load to retain selected settings and not waste cycles.
    // If you're concerned about no-script functionality, uncomment the following line.
    locate_template( array( 'members/members-loop.php' ), true );
    </div><!-- #members-dir-list -->

    That worked to get the active users showing, but I’m afraid I’m missing the AJAX functionality because the ajax files can’t be found due to my crazy structure.

    Where is the call to the ajax and where is it looking for it? What else should I do?

    On the same page, the link for “All Members” doesn’t work because (in my structure) it’s pointing to wrong location. My crazy structure works for version control, but plugins HATE IT!

    <a href="<?php bp_root_domain() ?>"><?php printf( __( 'All Members (%s)', 'buddypress' ), bp_get_total_member_count() ) ?></a>

    Where is this function (bp_root_domain) found and should I try to change it or make some other modification? Right now it points to where the files are /core, but not the root of my installation /projectname

    Thanks in advance. I’m excited it’s working this well as a Child of Hybrid at this point.

Viewing 1 replies (of 1 total)

  • designodyssey


    Solved it, but the problem is weird.

    • Tracked down ajax calls in global.js.
    • Firebug showed global.js was not loading
    • Search of theme files showed global.js only called from functions.php
    • The wp_enqueue_script that calls global.js uses a defined constant “HYBRID_NEWS_URL”
    • The definition of that constant read define( HYBRID_NEWS_URL, get_stylesheet_directory_uri() );
    • Changed it to define( 'HYBRID_NEWS_URL', get_stylesheet_directory_uri() ); where I added apostrophes.

    Apparently, others have gotten it to work without the apostrophes, but I had no luck and stumbled on the solution by comparing other ‘define’ usages to my own. Hope it helps someone later.

Viewing 1 replies (of 1 total)
  • The topic ‘Members list not showing – BP1.2’ is closed to new replies.
Skip to toolbar