Skip to:

New Install, Several Mysterious Issues (usability)

  • OpheliaPayne


    Hi! I’m running the latest version of BP on the latest version of WP, and I’m having several issues I can’t nail down.
    1. Pagination on member pages doesn’t work – clicking on next or a page number doesn’t do anything.
    2. We’d tried BP earlier, but we’re a super active site, we unistalled because our load time was severely affected – old BP folders in our old theme files have cemented themselves in my server, and won’t allow me to delete, move or even change the permissions for the old files, so I can’t get rid of them.
    3. There’s no submit button on the status messages.
    4. I was unable to use bbpress, it would initialize correctly, but most of the buttons didn’t work. Like pagination, clicking caused no action at all.

    We’re not using the BP default theme, I modified a different theme.

    We’re using WP Total Cache, along with CloudFlare, for optimization.

    Other plugins – SmushIt, WPTouch, CubePoints + BP integration, Edit Flow, Google Analytics, Google sitemaps, Jetpack, Fast Secure Contact form (Contact Form 7 allowed 20-30 spam contacts per day), UExtend Comment, Mood Thingy, Sexy Bookmarks, Wang Guard and wp-Typography. I’ve turned them all off an on to see if there was a conflict, and the issues remain under any configuration.

    We’ve been using WP for over a year, and everything worked fine pre-BP install. My members really want all the features you can give, so any help you can give me will be greatly appreciated!

    Site addy:

Viewing 4 replies - 1 through 4 (of 4 total)

  • ronia


    I had the problem of “no submit button” on status message with the latest BP – it was due to some other plugin using some sort of jquery. I had to disable one by one and get back the “submit button”. Thus apparently it was not fault of the latest BP. You have mentioned you have turned off all BUT sometimes, I have seen, js files remaining in browser /server cache/memory whatever.

    What happens (for member pages) if it is ordered by alphabetical ?

    Stubborn files not getting deleted may be deleted by FTP or Control Panel/Admin Panel of your webhost but this may also break things so backup!

    A good idea will be test things on locathost with WAMP or similar, with latest stable BP and WP and see whether things are working for you. If they do work, it will mean cleaning/changing files manually and/or db tables will get the things back in shape.

    I am not a pro, in fact really have no expertise but these are somethings I do myself when stuck.



    Okay, figure it out, it’s the BP template pack. Any ideas how to work around it? Now everything works, but it looks terrible.

    Does this mean I can only use the BP default theme?

    ETA – I’m not able to remove the old BP template pack files through FTP or on the server side (I have a dedicated server) and even with full admin access, I can’t change the file permissions so I can delete them.



    The BP Template Pack plugin makes your WP theme compatible with BuddyPress. Looks like you still need to go through Step 3 of the BP compatibility process. Check out links to walkthroughs at the bottom of this page

    == I’m not able to remove the old BP template pack files through FTP or on the server side ==
    This is a strange and serious issue which you need to take care of. First time I’ve heard it happen on dedicated server.



    I got through all of the steps with the template pack, and everything seemed to work okay (and it all looked great) but I lost the ability to use the pagination and there was no submit button for activity stream statuses or content. When I disabled template pack, those buttons came back, but I lost all the styling, including friend buttons.
    We’re trying to build the CSS from scratch without the template pack activated, to see if that fixes the ugliness and brings back the add friend and send message buttons, without losing the submit button.
    I’m going to contact my server company and see if they can help get rid of the old files, I’ve never seen anything like it anywhere, and it makes me nervous.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘New Install, Several Mysterious Issues (usability)’ is closed to new replies.
Skip to toolbar