Skip to:

No activation mail received only for hotmail and live addresses

  • Profile photo of Rian Rietveld
    Rian Rietveld



    I have a wpmu 2.9.2 site with buddypress (, sorry all in Dutch, and yes, the design is crap).

    Registration works fine, just the activation mail is not received by users with a hotmail or live account.

    Other email addresses get the mail, just not the hotmail/live addresses.

    No, im not on the blacklist

    Yes, I Installed the plugin Mail From.

    Below I copied the source code of the mail.

    Can anyone please help me with the following questions:

    Is this a WPMU issue or a BuddyPress issue?

    Or am I doing something wrong?

    Or is Microsoft just way to critical on mail?

    Kind regards, Rian

    Return-Path: <>

    X-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on


    X-Spam-Status: No, score=-4.4 required=4.0 tests=ALL_TRUSTED,BAYES_00

    autolearn=ham version=3.2.5

    X-Spam-Relay: _RELAYCOUNTRY_


    Received: from ( [IPv6:2a02:990:100:1:0:500::])

    by (Postfix) with ESMTP id 84F0C1FA0006

    for <>; Tue, 6 Apr 2010 12:22:14 +0200 (CEST)

    Received: from (localhost.localdomain [])

    by (8.13.8/8.13.8) with ESMTP id o36AMEC4002687

    for <>; Tue, 6 Apr 2010 12:22:14 +0200

    Received: (from mypet@localhost)

    by (8.13.8/8.13.8/Submit) id o36AMEc1002686;

    Tue, 6 Apr 2010 12:22:14 +0200


    Subject: [myPet] Activeer je account

    Date: Tue, 6 Apr 2010 10:22:14 +0000

    From: myPet <>

    Message-ID: <>

    X-Priority: 3

    X-Mailer: PHPMailer ( [version 2.0.4]

    MIME-Version: 1.0

    MIME-Version: 1.0

    Content-Transfer-Encoding: 8bit

    Content-Type: text/plain; charset=”UTF-8″

    X-Virus-Scanned: clamav-milter 0.96 at

    X-Virus-Status: Clean

    Bedankt voor het registreren! Om je account te activeren kun je op onderstaande link klikken:

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same issue. Tried installing plugins, changing email to a “legit” one rather than the standard, tried sending through SMTP rather than mail()

    Nothing works.

    Most likely Hotmails spam filter reacts to the activation link, that would be my guess at least.

    sometimes it depends on your host too. emails from my default bp install on dreamhost tend to make the junk/spam folder (yahoo, gmail, etc)

    in my case though, it doesn’t even get into the junk folders. It’s just lost in space never to be seen or heard from again.

    gmail/yahoo etc are not an issue tho, mails are there in seconds.

    Profile photo of dinoraptor101


    Me too My issue remains the same.. I installed “Mail From” Plug in that solved the problem of sending the emails in the first place.

    but the big problem are hotmail.. doing EVERYTHING I couldn’t get through their SmartScan Security.. “Or so as I was told in another blog” BuddyPress should really make a solution to this or at least specify the cause if it’s not related to BuddyPress..

    it can me due to usage of free domains? that are listed at Microsoft’s BlackList? That can be my only conclusion.

    Profile photo of Beck B
    Beck B


    I had a problem with a xxxxxx[at] address–as @liveview said, it never appeared in the junk folder even. But then I had no problem with a xxxxxx[at] address a few days later. So it’s not even entirely consistent for me. I have yet to create more accounts to do further testing.

    Profile photo of Anointed


    If you are on shared hosting accounts, you will need to check and make sure that your ip address is not blacklisted on the major email filter systems. The problem with almost all shared hosting setups is they share ip’s among many sites. It could be a completely separate site using the ip that is blacklisted, which will affect you. Many hosts like dreamhost have entire blocks of ip’s that are blacklisted, and just because the domain name on the ip changes, it does not remove the blacklisted ip. I can almost guarantee that is the root cause of most people’s problems as I had the same problem years back. It was only after I went dedicated and purchased ‘clean’ blocks of ip’s that all my problems went away.

    Profile photo of liveview


    Necroing this rather than post again in a new one. My install is running on a VPS with dedicated IP, and hotmail issues remain…

    Profile photo of Hugo Ashmore
    Hugo Ashmore


    Then likely you are being rejected as a sender by hotmail servers (do you get to see mailer-daemon failure notices?) , it’s perhaps a SPF policy issue, this sort of issue can arise if trying to send from an address that can’t be checked back.

    Profile photo of liveview


    Nope, as earlier stated it’s simply abducted by cybespace-aliens. Nothing gets to hotmail and I get no error/failure-notification in return.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No activation mail received only for hotmail and live addresses’ is closed to new replies.
Skip to toolbar