Skip to:
Content
Pages
Categories
Search
Top
Bottom

Private message timestamp errors


  • snark
    Participant

    @snark

    I just posted a bug report to Trac for this, along with a screenshot illustrating the errors: http://trac.buddypress.org/ticket/2250

    I wanted to post it here too in case it is something I can fix as opposed to something that BP needs to fix. Not sure what could be causing this error, and I’ve looked all over and can’t find other reports of it.

    Something to do with Ajax perhaps?

Viewing 8 replies - 1 through 8 (of 8 total)

  • Jamie Marsland
    Participant

    @jamesmarsland

    Is your server hosted in a different time zone to where you are?


    snark
    Participant

    @snark

    Yes @jamesmarsland it is.


    Jamie Marsland
    Participant

    @jamesmarsland

    I think that may be your problem. I moved my hosting co to one in the uk because I couldn’t find a fix. That was 6 months ago.


    3sixty
    Participant

    @3sixty

    Please search my recent posts for some code I wrote to fix this exact issue. In short, BP Messages fetches server time when it is inserting the timestamp. I think I also filed a trac on this. We should probably cross refence our tracs so the developers can get all the info in one place.


    Paul Gibbs
    Keymaster

    @djpaul

    If there are duplicate trac tickets for the same issue, obviously, just close them all down except for one of them and put a note in the others pointing to that ticket. Thanks again everyone for your time and effort in reporting bugs :)


    3sixty
    Participant

    @3sixty

    Np! Where is my Bug Hunter badge?? :)


    snark
    Participant

    @snark

    @3sixty — I found this topic of yours, https://buddypress.org/forums/topic/time-zones-different-in-messages-and-forums-bbpress, but it doesn’t link to your Trac ticket, and I couldn’t really follow your suggested fix, where to make the changes, the caveat, etc. (I’m not codesmart enough, sadly…).


    Anton
    Participant

    @antonrsaopencirclecoza

    I’m experiencing the same problem.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Private message timestamp errors’ is closed to new replies.
Skip to toolbar