Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem: Cropping image doesnt work in profile!


  • khappamj
    Participant

    @khappamj

    Hi please i have a problem,
    if i wanna change or add an avatar or profile image, once the upload has finished and i have to edit the image, the cropping square appears to be 1×1 pixel large.
    Everything seems to be working just like cropping icon and function but the rectangle is just 1×1 pixel.
    How can i solve this?

Viewing 17 replies - 1 through 17 (of 17 total)

  • r-a-y
    Keymaster

    @r-a-y

    What version of BuddyPress are you using?

    Can you upload the avatar that you wanted to use somewhere so we can test?


    khappamj
    Participant

    @khappamj

    Hi man , the Buddypress version i use is 2.9.0 and this problem is about every images. Its working but the cropping image tool is very very small, just 1×1 or 2×2 pixels, so its unusable for users.
    I dont think the issue is about images,
    so what can i do?


    khappamj
    Participant

    @khappamj

    is there a way to solve this? Even using another plugin that can substitute cover and avatar uploading… maybe using Ajax!


    gnasralla
    Participant

    @gnasralla

    @khappamj I am facing the same problem now. Were you able to fix that issue by any chance?


    r-a-y
    Keymaster

    @r-a-y

    It’s probably something to do with your theme’s CSS if I had to guess.

    Try switching temporarily to one of the WordPress default themes to see if it works. If it does, can you list your theme? Perhaps we can hardcode some CSS rules so the cropping box is correctly-sized.


    gnasralla
    Participant

    @gnasralla

    Hello Keymaster and y’all, I tried changing the theme to WP Twenty fifteen but I still got the same issue when I crop profile images… I get the image handles close together like a bold dot and when I try to expand the handles with the arrow handle the image size and handles get reduced to a tiny dot. Even the loader looks different with the upload button to the side instead of in the middle.


    r-a-y
    Keymaster

    @r-a-y

    I would wager that a plugin is conflicting with the image cropper size.

    Can you try deactivating all your plugins except BuddyPress to see if the image cropper is the correct size? Afterwards, if the image cropper is indeed the correct size, can you activate each plugin one-by-one to determine which plugin is causing the tiny image cropper and let us know which one it is?


    gnasralla
    Participant

    @gnasralla

    Hello again, I deactivated all plugins and it is still the same. Not sure what to do next.


    r-a-y
    Keymaster

    @r-a-y

    I’m afraid I can’t duplicate your problem. Tested on Twenty Fifteen with the bp-legacy and bp-nouveau template packs.
    Perhaps it’s the browser you are using? Try another browser like Firefox, Chrome, or Microsoft Edge. Are you using a mobile device?

    If no one can provide us with steps to replicate the issue, then we can’t debug the problem.


    redshujin
    Participant

    @redshujin

    I am having this issue on our site. It is running KLEO Child theme. When a user tries to upload an image for the avatar you will only see a small box in the left top hand corner of where the picture preview should be. I have tried Chrome and Firefox browsers in which this happens on both. I have attempted to deactivate plugins and am not seeing this resolving. Please let me know what additional troubleshooting that you would like to see done or tested and I would be glad to do what I can to assist

    WordPress 4.9.7
    BuddyPress 3.1.0


    r-a-y
    Keymaster

    @r-a-y

    @redshujin – Change your theme temporarily to a WordPress default theme and give it another try.

    If that doesn’t work, set up a fresh install of WordPress (either locally or somewhere else on your server) and only have the BuddyPress plugin activated. Next, attempt to upload a photo. If that works, then it has something to do with your particular install. Probably due to a plugin.


    redshujin
    Participant

    @redshujin

    @r-a-y – I was able to resolve this today after a lot of testing. I ended up having to switch themes to a default theme, disable ALL plugins, re-enable all plugins and then switch back to our KLEO theme. This was the only solution that fixed the issue during my testing.


    nirgalo
    Participant

    @nirgalo

    Hi, got the same problem, cannot upload picture on profile, crop doesn’t work and displays an error. I have imageMagick enabled. I read the above disabling plugins/changing theme but really… what is that? Profile photo upload used to work and now it is broken, the problem must be in BuddyPress no? I am using BuddyPress 3.1.0.
    Also why do I have to crop the image? I upload a square picture, I would expect the backend to get this and do what it has to do with it, why asking me to crop??


    redshujin
    Participant

    @redshujin

    Issue has returned for me again. Seems to be a temp fix only for what I did that made it work. Any suggestions?


    jpfowler21
    Participant

    @jpfowler21

    I managed to fix this on my site. The issue I found was with the Jetpack settings. I turned off the lazy loading option for images and viola!


    Carsten Lund
    Participant

    @carsten-lund

    I have the same issue, and have tried all the suggested solutions with no luck.

    The issue occurs randomly, you can’t detect what is causing it. I have a suspicion it is the order plugins are installed but this is impossible to test with 30 plugins or more.

    This is how it looks:

    View post on imgur.com

    The image is cropped from the top left:

    View post on imgur.com

    Regards


    Carsten Lund
    Participant

    @carsten-lund

    This issue has been known for over a year, why hasn’t buddyPress come up with a solution by now?
    When can we expect to see an update from BuddyPress?

Viewing 17 replies - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.
Skip to toolbar