Skip to:

Problem with activating BuddyPress within wordpress 3.1

  • I just finished setting up wordpress 3.1 on my server. I transferred all files to my ftp in the plugins folder and when I went to wordpress>plugins I tried to activate the plugin and its giving me this error:

    Parse error: syntax error, unexpected $end in /home/content/82/7556082/html/wp-content/plugins/buddypress/bp-core/bp-core-templatetags.php on line 49

    not sure if this is a chmod 777 problem or something else that might be triggering this error but I am trying to fix this myself but someone may be able to help me out. Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m also having a problem with activaing BuddyPress. I’ve just done a fresh install of WordPress 3.1.

    I tried the automatic install from within WordPress and it just sits at the following message and doesn’t go any further. I’ve let it site for half an hour:
    Installing Plugin: BuddyPress 1.2.8
    Downloading install package from…

    I’ve also tried to install manually. I’ve uploaded the “buddypress” folder to the “wp-content/plugins” folder and when I go into WordPress Plugins and try to activate, I receive the following message:
    Error 500 – Internal server error
    An internal server error has occured!
    Please try again later.

    I’m using 1and1 hosting…. any suggestions?




    yes buddypress 1.2.8 I looked at the particular line it was talkin about in the error and here is the whole function where the error started….

    if ( (int)$this->total_member_count && (int)$this->pag_num ) {
    $this->pag_links = paginate_links( array(
    ‘base’ => add_query_arg( ‘upage’, ‘%#%’ ),
    ‘format’ => ”,
    ‘total’ => ceil( (int)$this->total_member_count / (int)$this->pag_num ),
    ‘current’ => (int)$this->pag_page,
    ‘prev_text’ => ‘←’,
    ‘next_text’ => ‘→’,
    ‘mid_size’ => 1
    ) );

    maybe it has something to do with the membor count starting out as zero or no members atall or something Im lost, should I turn WP_ERROR off and that might bypass this?



    bhain3s – Your error sounds like BuddyPress was partially uploaded and activated. If possible, try a manual upload to your /wp-content/plugins/ directory and reactivate BP:


    @mercime Thank you!!! It was my .htaccess file.

    I had to add the following line to the end of my .htaccess file. This tells the webserver to user PHP5 instead of PHP4 (for anyone that doesn’t know). I had to do this with my other 1and1 hosted sites, including my Joomla sites.

    AddType x-mapp-php5 .php



    @JunVette Glad you resolved it and thanks for sharing your solution.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Problem with activating BuddyPress within wordpress 3.1’ is closed to new replies.
Skip to toolbar