Skip to:

Problem with /invitations/ BP component.

  • honoluluman


    I am not sure if anyone else is facing the same problem.

    I have been testing and debugging for several hours for this problem.
    I am using premium theme boombox , but also tried on Twenty Twenty-Two. Everywhere the same issue.

    I have deactivated all plugins, minimum set up.

    My website is on GR language in the frontend and i get the url of invitations component like that /members/user/προσκλησεις/ (with the GR translation). It should be /members/user/invitations/ like the rest of the components. I get an error page as a return. The component is not active.

    When i change default front lang to UK that i can see the /invitations/ component and invitations are working normal.

    Of course i have been saving permalinks, disabling-enabling invitations settings

    Could anyone help please??

Viewing 3 replies - 1 through 3 (of 3 total)

  • Takashi Matsuyama


    Hello @honoluluman

    I am facing the same problem.
    My website is on Japanese language (ja) in the frontend and I get the url of invitations component like that /members/user/招待状/ (with the ja translation).
    And I get the same problem on Simplified Chinese (zh_CN : /members/user/邀请/).

    I was looking for a solution and found it here.
    I don’t have a solution, but I want to let you know that there are languages and users who have the same problem.

    Thank you.



    Thank for your reply @takashimatsuyama.

    I have tried 2 alternatives to solve the problem but without success.

    1. I’ve tried to override the language files according to this (2. How to use custom language files) so that i can set my own english traslantion for the components slug . But for some reason the po/mo doesn’t override.

    2. I’ve tried to use the filter bp_get_members_invitations_slug in but again without success.

    At the moment i just translated the po/mo manually to make to component work.

    Takashi Matsuyama


    Hi @honoluluman
    Thank you for your reply as well.

    I think the problem started with “v10.0.0”. I had no problem with “v9.2.0”.


    I will look into it some more as well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar