Skip to:
Content
Pages
Categories
Search
Top
Bottom

Register and Activate Association Problem


  • lightslave
    Participant

    @lightslave

    Hello there,

    I’ve installed buddypress on several servers allready and I am familiar with most of the settings. But in my actual installation I have problems setting up the needed directories.

    I’ve created the site register and activate but I can’t associate them in the settings.
    screenshot (dashboard - buddypress)

    Can anyone help me please?

    I use WordPress 4.1/ Buddypress 2.2 and I have no other plugin activated.

Viewing 10 replies - 1 through 10 (of 10 total)

  • r-a-y
    Keymaster

    @r-a-y

    Hi,

    Did you turn on registration?

    Login to the WP admin dashboard and navigate to “Settings > Reading”. Click on the “Anyone can register” checkbox. If you’re on multisite, you can turn on registration by going to “Network Admin > Settings > Network Settings”.


    imath
    Moderator

    @imath

    @r-a-y is right, pages will come back as soon as signups are allowed.

    But if you are using a plugin like invite anyone, you might need to set these pages. We’re currently working on a patch and if you are in this case please consider testing/giving your feedback about this script https://gist.github.com/imath/07e79c2244c5ab2e0a1b (simply add it in a bp-custom.php file at the root of your plugins directory)


    lightslave
    Participant

    @lightslave

    First of all thank you so much for taking the time to try to figure out where the problem is.

    Anyone can register is acitvated and now my pages appear. It looks a bit different then in the past. But it works.

    Now…when I click on my sineup button (on the right corner of my website/ http://kompanio.de) I get an Error that says this: “ERR_TOO_MANY_REDIRECTS”

    Is this a wordpress/buddypress issue or is this a total different error that has other reasons?


    imath
    Moderator

    @imath

    Adding a trailing slash is fixing the issue : http://kompanio.de/register/


    Matt2012
    Participant

    @matt2012

    Not sure if this related but I can’t set the register and activate fields when I have s2member active.
    If I disable the s2member plugin – the buddypress fields for register and activate are filled in again.

    What I would like ideally is that s2member does not interfere with the current login / register set up just gives me an option to add paid levels inside the membership loggedin area.

    Is this a set up issue or is it a related bug?


    David S
    Participant

    @affordablewebsitesdenvercom

    I looked over this page and checked everything. Signups are allowed. Comments are allowed. My site still does not allow anyone to Register or Activate BuddyPress forum accounts. There are currently no other plugins enabled. Can anyone please look at the site and let me know what is going on if you have a few minutes? I understand if you can’t help and appreciate the time but I just want to try to troubleshoot what’s going on as something is missing and it’s either something on my end that I can’t find or BP is just not working with this theme or something else.

    It is not possible for me to associate pages with the settings shown in the screenshot above. I’ve tried to do this at least five times and it simply will not save the changes no matter. I’ve checked the settings. The pages exist, there are slashes, but it’s still dead.

    It’s chubbybunny.info


    djsteveb
    Participant

    @djsteveb

    @matt2012 – you should ask at the s2member site about that.

    @affordablewebsitesdenvercom – have you checked your web server error logs? I would also check with your host to see if they are employing “modsec” – I had semi-similar problems when my host updated the modsec module for the web server, and it prevented almost all “ajax-post” or ajax-save things that were going on with one of my bp installs.


    David S
    Participant

    @affordablewebsitesdenvercom

    Thanks for a great idea. I’ve taken the site down with a “under maintenance” page and am reviewing everything for a while.

    I think if I go through each setting with a fine-toothed-comb (very ironic coming from a bald guy) I’ll find a setting that needs to be checked or unchecked. Go Daddy seems to be pretty good with hosting so far.


    os.dale
    Participant

    @osdale

    @imath
    I have just tried your patch however it does not seem to work 🙁

    ps. you missed the closing ?>


    Matt2012
    Participant

    @matt2012

    For me the issue was
    1) Allow registration in general settings
    2) After enabled s2member plugin I needed to allow Open Registration in s2member > General Options

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Register and Activate Association Problem’ is closed to new replies.
Skip to toolbar