Skip to:
Content
Pages
Categories
Search
Top
Bottom

Register Issue with Elementor


  • niccrockett
    Participant

    @niccrockett

    I’ve found an issue with BuddyPress working with pages created using Elementor. In BuddyPress’ Settings an admin can set the Register page to a page they’ve created. Assigning it isn’t an issue. However, if you assign a page built using Elementor, you can no longer access Elementor’s editing interface for that page. This means even minor text edits aren’t possible.

    As long as you leave the Register page set to -None- Elementor’s editing interface works and you can still use the page built as the register page for the site without setting this option in BuddyPress’ Settings. This however, gives the admin this error message constantly:

    The following active BuddyPress Components do not have associated WordPress Pages: Register. Repair

    If there’s a fix for this let me know. If not, can this be added to BuddyPress’ update list. FYI, I’ve tried this on two sites and gotten the same issue. I’m on the latest updates for WordPress, themes, and plug-ins.

Viewing 3 replies - 1 through 3 (of 3 total)

  • shanebp
    Moderator

    @shanebp

    BuddyPress will not add support for Elementor any time soon, if at all.
    afaik – there is an extension plugin for Elementor re BuddyPress.
    Please contact them for more info.


    niccrockett
    Participant

    @niccrockett

    It’s not a big deal, I’m not looking for BuddyPress to have support for Elementor. However, I do find it interesting that a simple redirect from BuddyPress breaks Elementor. The page I created is separate from BuddyPress and successfully works with or without the BuddyPress Register redirect set-up correctly. I would think telling BuddyPress what page to use for the Register page would be a simple redirect and independent of BuddyPress. Thus support for Elementor would be irrelevant. I realize there may be more at work than I can see, just my two cents. Either way, I think BuddyPress is a great plug-in, I just wanted to offer some feedback about the issue I found. Good luck with the future of the plug-in!


    tiktokaccountant
    Participant

    @tiktokaccountant

    This really needs to be fixed. Its driving me crazy.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar