Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Call to undefined function bb_get_id_from_slug()


  • jwack
    Participant

    @jwack

    I have the latest versions of MU and BP running on my local machine so I can play with it. I set up a group and created a forum within that group. Everything worked fine, but the other day when I clicked on the forums link I got this error.

    Fatal error: Call to undefined function bb_get_id_from_slug() in C:\xampp\htdocs\mu\wp-content\plugins\buddypress\bp-forums.php on line 185

    I installed 2 plugins, WordPress Video Plugin and WP-prettyPhoto. I tried deactivating both of them to see if maybe that was the issue but it didn’t help.

    Besides the 2 plugins I have no idea why im getting the error, the forums where working at one point!

Viewing 7 replies - 1 through 7 (of 7 total)

  • r-a-y
    Keymaster

    @r-a-y

    Sounds like your install of BuddyPress isn’t complete.

    Deactivate BP, download a fresh copy of BP and activate it.

    See if your problem comes back.


    jwack
    Participant

    @jwack

    Hmm, I uninstalled BP from within WP, re-downloaded and installed it again and i’m still getting the same error, Any ideas what is going on? I haven’t edited any files in WP or BP, both are fresh installs.


    jwack
    Participant

    @jwack

    I went back into “forums setup” and ran that and it fixed the issue.


    Marcus
    Participant

    @netweblogic

    Same thing here, latest versions, same error. jwack’s solution fixed the issue.

    Thanks jwack for posting your fix, you saved me from a potential timewaster!


    Jure
    Participant

    @jcvikl

    Yes it really works, thank you very much: Forumov Setup
    A configuration file could not be created. No problem, but you will need to save the text shown below into a file named bb-config.php in the root directory of your WordPress installation before you can start using the forum functionality.


    Youraj Pawar
    Participant

    @youraj

    [RESOLVED] Root cause was meta_value in table wp_bb_meta remain unchanged after migration to other site.
    Scenario: I had similar problem on forum. I tried removing and re-installing many times. Re-installing means copying my complete wordpress with plugin buddypress folder still didn’t worked. Sometimes i used to get HTTP Error 403 Forbidden while accessing forums. This was error was esp when i used existing installation option from admin page in forums setup under buddypress.
    But when I click on setup new bbpress installation I could post on forums but could not see topics.
    REASON: I checked the database for table wp_bb_forums and it had entry of new topic, then I checked wp_bb_meta in that incorrect meta value was setup for field meta_value where meta_key is uri , I corrected the url stored in meta_value it was url of my previous website name. I had done migration to new site so the problem. If you face similar conditions just check these values.


    drwebstein
    Member

    @drwebstein

    I’ve run into this same issue, but none of the suggestions in this thread helped me to resolve it.

    Has anybody else encountered this and confirmed that their file structure is correct and the meta_value for the record with meta_key = uri in table wp_bb_meta is the correct URL?

    Any other ideas? Is this bb_get_id_from_slug() function actually defined somewhere?

    Thank you for any help you can offer.

    Adam

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Call to undefined function bb_get_id_from_slug()’ is closed to new replies.
Skip to toolbar