Skip to:

[resolved] Member Profile URL Incorrect

  • abbie2636


    Hi – I have searched extensively throughout this forum and tried many, many fixes (which I will list below). However, none have worked.

    The issue is that when I go to the Members Page and click on a member listed there, or I go to click on my own user profile link anywhere on the site, I am redirected back to the home page.

    I can see that the link is websitename/members/username when it should be either websitename/members/username/profile or websitename/members/username/public/profile

    Why is it doing this and how can I fix it?

    I am on a multisite with Buddypress active on only one of the sites (site #3).

    I am using the Buddypress default theme.

    I am using the s2Member plugin

    So far I have tried:

    – reinstalling Buddypress (a long process!)
    – changing the permalinks
    – adding the code as suggested here –
    – deactivating all my plugins.

    A multiple other ideas I can’t now recall.

    I would love your ideas. I am in now way an expert at this type of thing and am new to Buddypress but happy to give anything a try!

Viewing 14 replies - 1 through 14 (of 14 total)

  • Roger Coathup


    Hi Abbie,

    a couple of observations, although not a solution:

    Your link URLs are correct – they don’t need /profile on the end of them. BuddyPress will capture /websitename/members/username and direct it to the default page for your profile.

    s2member is compatible with BuddyPress – so again, that shouldn’t be a problem.

    I’m fairly sure redirection of links to the home page has been discussed before — hopefully someone else (or Google) can point you to the previous threads / help further. It might be an idea to share details of your hosting (is it Apache for example), and any mods to your .htaccess files. Also, which permalink structure have you chosen?

    Cheers, Roger



    Thanks Roger! Glad to hear the URLs are correct!

    I will keep up the searching and see if something can help.

    The permalink structure I have chosen is day & name – 2012/07/20/sample-post/ – but it doesn’t seem to matter what I choose – it doesn’t make a difference.

    I am using (from what I can see) Apache 2.2.22 – I’m hosted on Hostgator Linux CentOS

    Are you referring to if I have made any changes myself to the .htaccess files? If so then no I haven’t made any but if I need to go and look at it, let me know.

    I will continue the search and greatly appreciate any help anyone can give me!


    Current/old versions of BP had this strange quirk where, if something should really 404, it actually redirects you to the home page. We spent some time straightening this out for 1.6.

    Can you share a couple of sample links of these members that redirect to the homepage?
    Please also confirm that if you create a regular WordPress page, write some content, then publish, you can access it as usual from the front-end — also, please share the URL of this test page.

    Just trying to ascertain if your rewrite rules are working correctly for WordPress content, and why BP might be redirecting.



    Thanks Hopefully you can access these pages – I’ve have changed my privacy settings for now.

    Here is the main page –

    I can access the membership page –

    Then when I go to click on the member names to go to their profiles it just diverts to the home page. Use the usernames Abbie or Tim as the other two shouldn’t really have access to this site.

    I’ve just done a test page and put it under the menu and it is working no problems.




    PS I only installed Buddypress the first time the other day – 2 days ago – so I would have thought it was the latest version.



    FYi – This doesn’t work for me and I have already gone and changed all the usernames and nicknames to eliminate spaces and unusual characters –






    All I needed to do was add the following into the wp-config.php file:


    Thank you to this thread for help –

    I really hope this helps some other people. All seems to be working for me now.

    You can find more information here –

    I’m glad you’ve figured it out — but I can’t see your site (wants me to log in). Please can you share a URL of a member profile that (was) causing the redirect? Just to understand why the compatibility mode toggle made it work.



    Hi Paul,

    I have just removed the privacy settings so hopefully you can see the site.

    I did solve the Profile URL issue but now the Activity link is diverting to the home page!! I have tried to fix today but with no luck.

    Link again is

    If you have any ideas on this it would be great! If I have to start a new thread I will do.

    Er, wow. It certainly shouldn’t be causing problems with the type of usernames that the two users on your site have. The activity redirect is very odd as well. Yes, make a new thread, if only because this one says “resolved” in the title.



    Thanks Paul! Very strange.


    I’m having the same issue as Abbie, but the UsernameCompatibility didn’t help me. Forums and Groups rewrite correctly, Activity and Members do not. Activity will go to Home, Members will write to Members, but then when I click on a Member, it rewrites to Home.

    Please make your own topic. The affect may be similar, but the cause might be difficult. We’ll need all the type of information that Abbie provided in this topic for your site to begin to understand what might happnening.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[resolved] Member Profile URL Incorrect’ is closed to new replies.
Skip to toolbar