Skip to:

[Resolved] Permalink issues with BP1.5 and 1.5.1 versions

  • my versions BP 1.5.1
    WP 3.2.1
    Theme: Buddypress default theme. All other plugins are inactive
    Permalink structure: Custom (/blog/%post_id%/%postname%/

    Other than home page all other pages & posts are getting 404 not found error.
    If I set permalinks to ‘Default’ then all pages opens up with no content, all posts shows up content. If I set permalink to any other settings both pages and posts gets ‘404 Not found error’. Same issue happened when I was even on BP1.5

    “Not Found
    The requested URL /stg/activity was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

Viewing 7 replies - 1 through 7 (of 7 total)

  • @mercime


    Deativate BuddyPress. Delete the “blog” slug in custom permalinks. Re-run Settings > Permalinks. You have to resolve permalink issues in WP install before activating BuddyPress.

    Tried..still no luck. But your comments are right.
    When buddypress is inactive, I still have the same problem to go to blog posts and pages. That means core wordpress issue. It works with default setting, but doesn’t work with custom permalink setting. As most of the buddypress users have to use wordpress, does any one can point to me right settings ?

    My WP & BP are installed in a sub-directory. I never had any problem until I testing the upgraded version.



    Is this on single WP or multisite? What’s in your .htaccess file?

    Its is multi site (WPMU) installation but I only have one site. here is my .htaccess file

    # BEGIN WordPress
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .register*
    RewriteCond %{HTTP_REFERER} !.** [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) [R=301,L]

    # protect wpconfig.php

    order allow,deny
    deny from all

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    SecFilterEngine Off
    SecFilterScanPOST Off

    # END WordPress

    no one had same issue ? strange.

    You might get better luck with this on the forums, since you’ve identified the problem is with your WordPress permalinks.

    After correcting the .htaccess as below it worked

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /abc/
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /abc/index.php [L]

    # END WordPress

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Permalink issues with BP1.5 and 1.5.1 versions’ is closed to new replies.
Skip to toolbar