Skip to:

[Resolved] Site Wide forums stopped working after 1.6 upgrade

  • smartmwp


    I am getting a 404 for site wide forums after upgrading to Buddypress 1.6. I have published only one forum which was working earlier with version 1.5.7. I have checked all settings. Pleas help!

Viewing 3 replies - 1 through 3 (of 3 total)

  • @mercime


    @smartmwp do provide more information about your installation like — Single or Multisite? Custom theme or have you tried changing to bp-default to see if issue is corrected? Plugins installed? etc.



    @mercime Thanks so much for replying. I am using a theme Supermassive by themeforest and this theme is BP compatible. Was working fine with BP1.5.7. Plugins Installed (all at their latest versions)

    jw player,
    members (for tweaking user roles),
    BP Group Email Subscription,
    Buddypress Group forum extras(deactivating this didn’t work),
    enhanced Buddypress widgets,
    WP Super Cache

    Site Wide Forum settings – I have checked “Allow BuddyPress Groups to have their own forums”
    and Group Forums Parent as “Forum Root”. The pages assigned under Buddypress – Settings have not changed, nor I made any changes to the Site Wide Forum Settings after upgrading to version 1.6. There are only 2 options for me at Buddypress->Settings-> Forums
    1. Uninstall Group Forums
    2. Configure Site Wide Forums

    Thanks and would really appreciate all advise.



    Resolved – here are the steps to resolve it:
    1. Uninstall bbpress plugin,
    2. Go to Buddypress->Settings->Pages and set the Group forums page to Forums (with “forums” slug)
    3. Go to Buddypress->Settings->Forums and press the button “Install Site wide forums”. This would install bbpress plugin.
    4. Once Installed and activated, you will be redirected to installed plugins page so again go back to Buddypress->Settings->Pages and set Group Forums page to a new page “Group-Forums”.
    That should do it. at least this worked for me…:)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Site Wide forums stopped working after 1.6 upgrade’ is closed to new replies.
Skip to toolbar