Skip to:
Content
Pages
Categories
Search
Top
Bottom

Say Hi to BuddyPress 11.0.0 “La Scala”

Viewing 25 replies - 1 through 25 (of 30 total)

  • The Network Manager
    Participant

    @netmanuth

    Hey there Viet, appreciate your work with BuddyPress. Just wanted to let you and your team know that there may be some concerns with the latest version 11. I attempted to updated three times today and it brought my site down each time. I did three times because I wanted to be absolutely certain that the update was the cause of the site crashing.
    IT may be some sort of conflict with my these as the error message pointed to a javascript page associated with my theme.
    I currently use version, 10.6.0 and that works fine for me.
    So you all are aware.
    Next time I will catalog the error info for sharing with you all, this time I was preoccupied with bringing the website back to full functionality.
    Thanks.


    helga006
    Participant

    @helga006

    Hi Mathieu,
    Yesterday I updated Buddy Press to version 11.0.0 and found that the login page stopped working after the update. The system simply prevents users from logging in. When a user tries to log in, the message “Session expired, please refresh the page and try again” appears. And so all the time. This may be some sort of conflict with my Rehub theme. I’ll check later. In the meantime, I had to roll back to the previous version.
    Anyway, thanks a lot to the Buddy Press team for such a great plugin.


    Lars Henriksen
    Participant

    @adjunkten

    Hi developers,

    I updated to 11.0.0 with no other issues than some translation missing. I use the BuddyX-theme.
    Thanks for your work with this plugin.

    Cheers, Lars

    My experience is the same as Helga006’s. I also reach-out out to the developer of the theme I use since Lars appear not to have any challenge updating using the BuddyX-theme.
    Here is the error I receive.

    “There has been a critical error on this website. Please check your site admin email inbox for instructions.
    Learn more about troubleshooting WordPress.”

    After the update I am not able to access the admin backend.


    philippklaschka
    Participant

    @philippklaschka

    tried 3 times to update and every time it blows up my backend with this fatal error. Have to roll back all plugins via database and reactivate all just to roll back this patch.
    Can someone decipher whats going on here?

    Fatal error: Uncaught TypeError: call_user_func_array(): Argument #1 ($callback) must be a valid callback, function “ass_install_emails” not found or invalid function name in /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php:308 Stack trace: #0 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(”, Array) #1 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #2 /homepages/17/d4296816486/htdocs/wordpress/wp-content/plugins/buddypress/bp-core/admin/bp-core-admin-schema.php(555): do_action(‘bp_core_install…’) #3 /homepages/17/d4296816486/htdocs/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-update.php(770): bp_core_install_emails() #4 /homepages/17/d4296816486/htdocs/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-update.php(291): bp_update_to_11_0() #5 /homepages/17/d4296816486/htdocs/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-update.php(159): bp_version_updater() #6 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php(308): bp_setup_updater(”) #7 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array) #8 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #9 /homepages/17/d4296816486/htdocs/wordpress/wp-content/plugins/buddypress/bp-core/admin/bp-core-admin-actions.php(120): do_action(‘bp_admin_init’) #10 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php(308): bp_admin_init(”) #11 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array) #12 /homepages/17/d4296816486/htdocs/wordpress/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #13 /homepages/17/d4296816486/htdocs/wordpress/wp-admin/admin.php(175): do_action(‘admin_init’) #14 /homepages/17/d4296816486/htdocs/wordpress/wp-admin/plugins.php(10): require_once(‘/homepages/17/d…’) #15 {main} thrown in /homepages/17/d4296816486/htdocs/wordpress/wp-includes/class-wp-hook.php on line 308

    Hi @philippklaschka

    Thanks for your report, this issue seems to be caused by this plugin https://github.com/projectestac/wordpress-invite-anyone/ It hooks to bp_core_install_emails to run the function ass_install_emails that does not exist see: https://github.com/projectestac/wordpress-invite-anyone/blob/master/by-email/by-email.php#L1710

    I advise you to deactivate this plugin, update BuddyPress and then reactivate this plugin once done. The bp_core_install_emails hook is only fired by BuddyPress when you install/upgrade and use the tool to reinstall emails, so it should be ok. But I strongly advise you to contact the plugin author so that he fixes this issue.

    Hi @netmanuth

    Thanks for your report, I’ll check BuddyX, but I doubt issue is with this theme.

    Very cool, thanks for the solution. Worked nicely for me.
    Thanks Phillip for submitting the debug error info.


    Martin Beneš
    Participant

    @drivezone

    Hello! After last update are missing some strings to translate (I use Loco translate), such as all “ago” formats. Biggest problem after update I have is that all posts (articles from WP) are not sent to global activity stream, they are not visible in whole BP network. I was forced to rollback to version 10.6. which works fine for me. I did not have any other plugins updates which can affect BP so far while updating BP.


    evacc
    Participant

    @evacc

    HELLO, I WOULD LIKE TO KNOW HOW I CAN GET THE BUDDYPRES API I NEED TO BE ABLE TO CREATE AN APP, THANKS


    fantamily
    Participant

    @fantamily

    Error After Installing BuddyPress Update 11.0.0

    Hi, after installing update buddypress 11.0.0 I have an error in the first view of users: “Warning: array_filter() expects parameter 1 to be array, bool given in /home/customer/www/staging43.fantamily.it/public_html/wp-content/plugins/buddypress/bp-messages/bp-messages-template.php on line 1577″…
    Is it possible to fix the problem? Thank you all


    yoshibot
    Participant

    @yoshibot

    Hello, urgent help. Your latest update creates a bug that causes notifications to fail and make them inaccessible. I am attaching screenshots and I hope they fix it soon. 🙁

    Thank you

    View post on imgur.com

    View post on imgur.com


    yoshibot
    Participant

    @yoshibot

    Summary no user can access your notifications. thank you

    Hi @drivezone, @fantamily & @yoshibot

    Thanks a lot for your feedbacks. We’re going to investigate about the issues you reported.


    yoshibot
    Participant

    @yoshibot

    Hello,

    Identified a new update problem user accounts take a long time to open

    https://www.nintenderos.com/usuarios/yoshi-2/profile/

    Please tell me where we can download the previous version. This new version doesn’t work 🙁

    Hi @yoshibot,

    Here’s the link to download previous version of BuddyPress: https://downloads.wordpress.org/plugin/buddypress.10.6.0.zip

    FWIW, I can’t reproduce the issue you shared about notifications. For me everything works as expected, see:

    Notifications screen


    yoshibot
    Participant

    @yoshibot

    Thanks, Nintenderos is a big community Since it was updated the plugin stopped working 🙁

    Hi @fantamily

    Thanks a lot for your feedback. The issue is actually caused by some custom code wrongly using the bp_get_send_message_button_args filter. Instead of returning an empty array to disable the private button on members profile header, this custom code retuns false.

    That being said. We should be more cautious about this potential wrong usage, so we’ll have it fixed asap (next minor version 11.1.0).

    See https://buddypress.trac.wordpress.org/ticket/8800 to follow our progress about it.


    Kustian
    Participant

    @tiy4ns

    Anyway, thanks to the Buddy Press team for such a great plugin


    Jakobuz
    Participant

    @jakobuz

    Hello, since the new version I can not update posts anymore. I reverted it back to version 10.6.0 and everything is working fine. It would be nice if someone could help me out. Thank you!

    WordPress version 6.1.1
    BuddyPress (version 11.0.0)
    PHP version 8.0.26

    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 233 van het bestand /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-blogs/bp-blogs-activity.php. Foutmelding: Uncaught ArgumentCountError: 3 arguments are required, 2 given in /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-blogs/bp-blogs-activity.php:233
    Stack trace:
    #0 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-blogs/bp-blogs-activity.php(233): sprintf()
    #1 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/class-wp-hook.php(308): bp_blogs_format_activity_action_new_blog_post()
    #2 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/plugin.php(205): WP_Hook->apply_filters()
    #3 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-activity/bp-activity-functions.php(1633): apply_filters()
    #4 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-activity/classes/class-bp-activity-activity.php(209): bp_activity_generate_action_string()
    #5 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-activity/classes/class-bp-activity-activity.php(167): BP_Activity_Activity->populate()
    #6 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-activity/bp-activity-functions.php(2379): BP_Activity_Activity->__construct()
    #7 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-content/plugins/buddypress/bp-activity/bp-activity-functions.php(4176): bp_activity_post_type_update()
    #8 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/class-wp-hook.php(308): bp_activity_catch_transition_post_type_status()
    #9 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
    #10 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/plugin.php(517): WP_Hook->do_action()
    #11 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/post.php(5347): do_action()
    #12 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/post.php(4607): wp_transition_post_status()
    #13 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-includes/post.php(4819): wp_insert_post()
    #14 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-admin/includes/post.php(426): wp_update_post()
    #15 /home/deb74155/domains/rugzaklopers.nl/public_html/wordpress/wp-admin/post.php(227): edit_post()
    #16 {main}
    thrown


    Mathieu Viet
    Moderator

    @imath

    Hi @jakobuz

    This is really weird, because:
    sprintf() is not used at line 233 in https://buddypress.trac.wordpress.org/browser/tags/11.0.0/src/bp-blogs/bp-blogs-activity.php#L233. Have you edited this file?
    – “3 arguments are required, 2 given”: 3 arguments were required in BuddyPress 10.6.0 and below but only for multisite configs. Are you using multisite?
    – It looks like you still had 10.6 code inside 11.0 for the bp_blogs_format_activity_action_new_blog_post() function.
    – Have you kept the bp-blogs/bp-blogs-activity.php file you had when you upgraded to 11.0, I’d be curious to see it.

    I’ve tested everything into this area for regular and multisite configs and I can’t reproduce.


    Jakobuz
    Participant

    @jakobuz

    Hai Mathieu,
    I have no multisite and also did not keep old files, but I Think I found something: near line 233 of the bp-blogs/bp-blogs-activity.php file there is an note which says /* translators: 1: the activity user link. */.
    This note triggered me to change the site language from Dutch to Engish, and the problem is solved! So in my opinion it has to do with the (Buddypress) translation to Dutch. I searched for the translation files in Buddypress, but couldn’t find anything ….


    Jakobuz
    Participant

    @jakobuz

    edit: I found the error.
    It is indeed a translation error.
    I found the translation of Buddypress in wp-content/languages.
    With PoEdit I saw that “%s wrote a new post” was translated as “%1$s heeft een nieuw bericht %2$s geschreven”.
    I changed the translation to “%s heeft een nieuw bericht geschreven”.
    PoEdit generated a new mo-file which I uploaded to wp-content/language. Now the problem is solved (for me).


    Jakobuz
    Participant

    @jakobuz

    FYI: I have suggested “%s heeft een nieuw bericht geschreven” as a new translation for “%s wrote a new post” at https://translate.wordpress.org/projects/wp-plugins/buddypress/stable/nl/default/


    yoshibot
    Participant

    @yoshibot

    Hello, I give you the details of my fatal error, the messages I receive from my wrod press are what I copy and paste below (I hope you understand since my website is in Spanish) that fatal error prevents the system from working now and how Regardless of previous messages, I hope this new information sheds light on your project and you can update it without errors. Thank you


    yoshibot
    Participant

    @yoshibot

    Detalles del error
    ==================
    Se ha producido un error del tipo E_ERROR en la línea 543 del archivo /home/nintenderos/web/nintenderos.com/public_html/wp-content/plugins/buddypress/class-buddypress.php. Mensaje de error: Uncaught Error: Call to undefined function bp_get_deprecated_functions_versions() in /home/nintenderos/web/nintenderos.com/public_html/wp-content/plugins/buddypress/class-buddypress.php:543
    Stack trace:
    #0 /home/nintenderos/web/nintenderos.com/public_html/wp-content/plugins/buddypress/class-buddypress.php(153): BuddyPress->includes()
    #1 /home/nintenderos/web/nintenderos.com/public_html/wp-content/plugins/buddypress/bp-loader.php(49): BuddyPress::instance()
    #2 /home/nintenderos/web/nintenderos.com/public_html/wp-content/plugins/buddypress/bp-loader.php(93): buddypress()
    #3 /home/nintenderos/web/nintenderos.com/public_html/wp-settings.php(447): include_once(‘/home/nintender…’)
    #4 /home/nintenderos/web/nintenderos.com/public_html/wp-config.php(112): require_once(‘/home/nintender…’)
    #5 /home/nintenderos/web/nintenderos.com/public_html/wp-load.php(50): require_once(‘/home/nintender…’)
    #6 /home/nintenderos/web/nintenderos.com/public_html/wp-login.php(12): require(‘/home/nintender…’)
    #7 {main}
    thrown

Viewing 25 replies - 1 through 25 (of 30 total)
  • You must be logged in to reply to this topic.
Skip to toolbar