Skip to:
Content
Pages
Categories
Search
Top
Bottom

Showing Display Name instead of Username in BP Profile Header

  • Profile photo of sjjenkins
    sjjenkins
    Participant

    @sjjenkins

    I’m using the Kleo theme, which shows the username, but not the display name on the profile. Mine is set up to look like this:

    BP Profile

    It’s ALMOST perfect… but I’d rather have the display name there instead of the username.

    Any nudges in the right direct as to how to do that. I’d like to not edit the native BP or theme files if possible, and just work in the functions.php file of my child theme.

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Profile photo of Rosyteddy
    rosyteddy
    Participant

    @rosyteddy

    http://seventhqueen.com/support/forums/forum/kleo/kleo-general-questions

    Hi @sjjenkins

    This should not be very difficult. Some small change in the template file but since they have no downloadable version its difficult to say.
    This may contain some clue –

    Showing some profile fields in member’s profile header not working after update


    Just curious, how does the Whats New box looks like when you use
    buddypress-activity-privacy, buddypress-activity-plus and any Media plugin like rtmedia ?
    Whats your site (if its not private) url ?

    Thanks.

    Profile photo of sjjenkins
    sjjenkins
    Participant

    @sjjenkins

    Hi @rosyteddy. I got it figured out! It was a combo of tinkering in functions.php and then copying the /wp-content/themes/kleo-child/buddypress/members/single/member-header.php file into my child theme folder and editing it there!

    I don’t think I’m using the activity privacy stuff… I’m combining S2Member Pro with BuddyPress… and so far I’m really liking it!

    Profile photo of AlexanderCnb
    AlexanderCnb
    Participant

    @alexandercnb

    Would you be so kind to share the function and the tinkering you did? 🙂

    I’d also like the display name to be shown instead of the @username, but I’m not sure where to start. I stumbled on older topics that suggested plugins, but they are outdated and don’t seem to work. Hopefully, your solution could also work for me

    Profile photo of 5high
    5high
    Participant

    @5high

    Hi, @sjjenkins – please can you post details of what you did (and where!) to get this to work? I did have something working,but now it isn’t – not sure why!
    Cheers,

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar