Skip to:

sub domain problem

  • hi

    im using wp301 and bp126

    i have 2 problems that are related, after making all possible tests, the problem seems to be coming from the buddypress settings. when i installed it, it asked me for a url of some kind and i changed it to my blog address, instead of keeping it in default (not sure what it was).
    now if i create a subdomain in my site, it works, but when i put back WP+BP, it stops for an endless redirection.

    another problem that might point out to the problem is that when i hover a post’s title in my blog, the address that is shown is: (doubled URL)

    where can i change back that address settings from the installation? i didnt find it in the admin page of BP
    please please please please help me or tell me where can i get help regarding this problem

Viewing 5 replies - 1 through 5 (of 5 total)
  • partially fixed!
    in WP there is wordpress adress and site address
    apparently, the new installation made the 2 fields the same while they shouldnt be.
    i changed it and now it works
    the doubled url problem when hovering each post’s title is still there
    any ideas?

    one problem down, 2 new ones:
    now works!
    BUT doesnt!
    it brings me to a page saying: Page Not Found – The page you were looking for was not found.

    2nd: if i logout the user that is currently logged in im redirected to my homepage! instead of the blog’s homepage “/blog/”

    doubled URL problem was solved through the wp->settings->permalinks

    now i noticed another problem
    when im on the main page and logging in with my user (im the admin)
    instead of back to the blog homepage im redirected to the wp-admin! page where i can manage my WP but i didnt ask for it!



    the site urls are setted in WP.
    go to your main site dashbord.
    in super admin menu, is the link to all your blogs
    Under your main site name click on edit
    in the first area, enter (no ending slash)
    in the area named path, enter /
    in the area in wp1_options, texarea home, enter (with ending slash)
    save your changes

    Now go to wp-config.php
    i suppose you are under sub-domains.
    If yes you must see this somewhere

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);
    define(‘VHOST’, ‘yes’);
    $base = ‘/’;
    define(‘DOMAIN_CURRENT_SITE’, ’’ );
    define(‘PATH_CURRENT_SITE’, ‘/’ );
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOGID_CURRENT_SITE’, ‘1’ );

    normally all is ok now ! ;-)

    first of all thank you for your reply
    secondly, what do you mean by “in super admin menu, is the link to all your blogs”
    super admin menu? where is it?

    in wp-config i have nothing of what you wrote, the closest thing i saw is
    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    i didnt touch it ofcourse

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘sub domain problem’ is closed to new replies.
Skip to toolbar