Skip to:

Testing BP 1.7b1 and having some issues

  • philipt18


    Is there a forum specifically for BP 1.7 beta issues?

    In any case I’ve seen some odd things. I’ve installed BP 1.7b1 on a fresh install of WP 3.5.1 Multisite. I have the admin and two users. I sent out friend requests to the users from the admin. I then accepted friendship from a user, and was shown the following message:

    There was a problem accepting that request. Please try again.

    However, the friendship was actually accepted.

    Second, in the Activity list it shows that the admin and user are now friends, but the user’s avatar (which uses a default avatar) is shown twice. i.e. it says “Admin and [] [] User are now friends.” where the [] is the avatar and links to the user’s member profile.

    Also, when editing a profile and saving it, nothing happens. Everything in the custom fields get erased, and nothing is saved. This is in a profile that was created before I added custom fields, if that matters. Speaking of which, when listing the custom fields to be edited, the description of the field is in italics under the box – i.e. Title, Edit Box, Description. That’s a little confusing – it would be nice if there was a box around all the elements to show they’re connected, or lines between the elements, or even putting the description under the title instead of at the end.

    A similar problem occured when I tried to add a group. I was logged into my superadmin account, clicked on Groups, clicked ‘Create a Group’, entered a title and description, clicked ‘Create a Group and Continue’ and it just cleared the fields.

    I’m using Chrome on a Mac if that matters.

Viewing 8 replies - 1 through 8 (of 8 total)

  • @mercime


    What theme are you using? If you change to BP Default theme, is the issue corrected?



    I’m using Buddypress Social from WPMU.

    I switched to BP Default and:

    – didn’t see the double avatar in the Activity list
    – same problem with updating my profile
    – same problem trying to create a Group

    For the first issue, of confirming a friend, it was a little more complicated. I used Safari which was logged into antoher user account to accept friendship. It worked normally. I then went to the Friends list, and cancelled the friendship. I’m not sure why the friend was still listed there, but I took advantage of that and clicked on the Add Friend button. It loaded a new page that said:

    Are you sure you want to do this?

    and then a link that said:

    Please try again.

    which links back to my Friends page, which this time was blank. In any case, the combination of ‘Are you sure…’ and ‘Please try again.’ seems out of place.

    I then went to the Members page, and clicked Add Friend again. I then went to the Members page using my admin account (the account I requested friendship of) and it listed the members including the account I requested from – and next to that name it had a button labeled ‘Cancel Friend Request’ which seems backwards. However, I noticed two notifications in the top menu, one which said the user had accepted my friendship request, and another saying the user had requested my friendship. I selected the second one and was taken to the Requests page. I clicked Accept and it seemed to work normally.

    Hope that’s all clear…



    Per the BuddyPress Social theme page
    The theme’s compatible up to BP 1.6.3 so you’d most probably need to upgrade the theme for BP 1.7

    As for the issue you encountered while using the BP Default theme on BP 1.7 beta, have you tried deactivating plugins except BuddyPress to check if there’s a plugin conflict? If you created a bp-custom.php file, did you check whether there’s any friends or freindship functions you added which might have caused the issue you’re encountering?



    I’ll post a message on the WPMU forum, but if there’s an issue it’s still worth pointing out here I think. Especially since 1.7 is supposed to work with all themes. In any case, that was a minor issue.

    I haven’t created a bp-custom.php file.

    I disabled all the plugins except Buddypress, and tried creating a Group again, but the problem still exists.

    Paul Wong-Gibbs


    If you use 1.7 on a BuddyPress theme, then the theme compatibility won’t be used. It’s definitely worth asking the WPMU team to test it against the 1.7 beta to see if they need to fix anything (or if we’ve caused any regressions).



    I’ll let you know what the WPMU folk say, but in any case the major problems happened with BP Default. Let me know what else I can test other than removing all the plugins.

    @djpaul not sure if i am high jacking this thread but can you please confirm, in my group forums when i click on subscribe or add to favorite i get redirected to the groups page when i use the buddypress theme. When i use canvas woo theme or any other themeforest theme i get 404 error for the same action.

    I expect to stay on the forum thread even after i click subscribe or add to favorite ….is this a bug in 1.7 and yes i see the same behavior of redirecting to groups page in 1.6.4 too. I am using latest version of bbpress and wordpress



    Hi @djpaul,

    Does uses 1.7-beta1 bp-custom.php for slug translation?

    РMy bp-custom.php working correctly in 1.6.4 BP but not working correctly in 1.7-beta1.

    These slugs are translated just for user profile, not group profile. It is OK?

    define ( ‘BP_MEMBERS_SLUG’, ‘clenove’ );

    define ( ‘BP_FORUMS_SLUG’, ‘klubovna’ );

    Thanks for idea, help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Testing BP 1.7b1 and having some issues’ is closed to new replies.
Skip to toolbar