Skip to:

The requested URL /register/ was not found on this server.

  • Profile photo of Jonperry


    I just installed wordpress 2.9.2,

    I changed permalinks to: /index.php/%postname%/

    I installed the new buddypress 1.2

    I activated the plugin

    Activated the theme

    But now when I press any button like ‘Activity’ or ‘Members’ I get the following error:

    Not Found

    The requested URL /activity/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    WebServerX Server at Port 80

    Anyone know what is happening?



Viewing 21 replies - 26 through 46 (of 46 total)
  • Profile photo of Andrea Rennick
    Andrea Rennick


    No, he means you installed mu in the /Case_study/ folder instead of the root. As in, right at /.


    Thank you for your reply, so would you suggest that I take wordpress mu out of the Case_study folder and put it in the root?

    Profile photo of @mercime


    Yes jhull. Get MU out of subfolder to root of domain.

    Thank you mercime, I will try that and reinstall everything.

    Profile photo of jhull


    I just recently installed wordpress mu and everything worked, I am still able to access the dashboard through my blog:, however if I try to do anything now after I installed buddypress, for example add a new group or click on anything on the front page, I receive object not found 404 error.

    Can you please help me and see if there is something I am doing wrong?

    Thank you so much,


    Profile photo of ivan


    i’ve solved the problem, if u r using wamp you have to make a click on the taskbar icon, then apache, then apache modules, and then put a check on rewrite_modules

    Profile photo of gravelhunter


    maby this will help . . .it helped me

    Profile photo of keeperman


    I’ve tried all methods as far as I know, .htaccess , rewrite module etc…… but it still doesn’t work. how? why? =( .
    still have this”The requested URL /register/ was not found on this server”
    who can help

    Profile photo of balasacss



    The issue was solved.
    You need to enable the mod_rewrite in Apache…

    Profile photo of racin36er


    and when mod_rewrite IS enabled, and .htaccess looks how it should according to this thread – then what? WP works just fine until I try and use any BP links (accounts/members/etc etcetc) all result in 404s.

    **edit** as a side note, i’ve had this problem for a year plus trying to figure out how to use BP. all the links come up as 404 stating that it doesnt exist in /blog-DIR/ – well duh? all the BP stuff shows up in /blog-DIR/wp-content/plugins/buddypress – NOT in the main DIR. even after moving the BP folder into the root /, still nothing. makes it worse, in fact.

    i’m REALLY looking for a viable answer here. why do all BP links point to the root DIR? this is NOT where the files are!

    Profile photo of @mercime


    Run Settings > Permalinks and set to other than default i.e. pretty permalinks is a must. Double-check WP configurations and if you have a problem there, resolve it in forums before installing BuddyPress.

    You do not move BuddyPress plugin folder/files around in your server at all. You can install BP in either of these two ways:
    1. auto install via dashboard menu Plugins > Add New > BuddyPress then network activate. or
    2. Upload buddypress plugin in wp-content/plugins/ folder in your server, then go to dashboard to activate BP

    After either #1 or #2 above, Install a BP-compatible theme like and you’re good to go.

    Profile photo of racin36er


    Thanks mercime,

    Permalinks are not set to default.
    WP install had no problems previously – 404’s started after installing BP and only occur on BP related links (activity, members, etc)
    Was installed via the Plugin menu in WP (automatic)
    Have a BP ready theme installed and it’s working – its the links that do not.

    Profile photo of @mercime


    What BP/WP versions are you on? What BP Theme are you using? Have you deactivated all other plugins except BuddyPress and changed to bp-default theme while you’re resolving this issue?

    Profile photo of racin36er


    both are the newest versions available. WP is 3.0.5 and BP is 1.2.7 (latest addition i could find). through the course of my troubleshooting I have indeed removed all plugins just BP enabled. theme is “Simple WP Community Theme 1.6”, however I have also tried with just the standalone BP theme included, BuddyPress Default 1.2.7. I have also completely removed BP and completed a fresh install twice – still the same problem.

    Profile photo of racin36er


    I’ve heard BP doesnt like subdirectories much – so I gave it a shot just in the root DIR – same problem.

    There has to be some issues with permissions/virtual directories somewhere. Any insight?

    Profile photo of simon1202


    Hey Guys,

    See if that video can help you like it helped me –


    Had the same problem on a fresh BP 1.2.8 install on a fresh WP 3.1. Changed theme to bp default, changed permalink settings, made sure .htaccess contained rewrite rules as generated by BP. mod_rewrite was definitely activated. However, the .htaccess in the BP root (a subdirectory under a local domain) was not evaluated at all. Ubuntu 10.04 server edition, everything installed via packet management except for WP/BP which were simply unzipped from the download archives.

    This entry in httpd.conf helped:
    Options FollowSymLinks
    AllowOverride FileInfo Options
    Allow from all

    After that all the links on tabs, registration etc. worked fine.

    Profile photo of dkmonroe45


    ftrenkam – Where is that file located and what is it called? I have tried everthing in this thread and nothing has worked to this point.

    Appreciate your help,

    I just went though every post and do not see anybody with a problem mentioning whether you are working with sweet potatoes or white potatoes. Just to mention that they are not the same thing, not even close, and the same refers to Apachi vs. MS IIS.

    I’m running Win 2008r2 Server with IIS7.5 (key information), any BuddyPress links are missing index.php in the url. Does anyone have a solution for this case (plese do not tell me that I need to enable mod_rewrite or any other silly thing)

    Thank you,


    Profile photo of linne81


    I solved the problem, just do as Tom Gosling said: “I’m 99.9 percent sure that you guys need to enable mod_rewrite in Apache…” I just enable “rewrite_module”

    Profile photo of facs01


    I Just wanted to post this solution, as I spent a lot of time trying to find what was not working, because the /register/ page wasn’t loading after installing buddypress. In fact the problem was solved after enabling the mod_rewrite in Apache but in devian linux you have to follow this procedure to enable it also modifying the files suggested by this url:

    Hope this helps more!

Viewing 21 replies - 26 through 46 (of 46 total)
  • The topic ‘The requested URL /register/ was not found on this server.’ is closed to new replies.
Skip to toolbar