Skip to:
Content
Pages
Categories
Search
Top
Bottom

There was a problem cropping your profile photo.


  • WalkerDesign1
    Participant

    @walkerdesign1

    I currently have BuddyPress Version 2.5.1 installed and I am uploading an avatar to the members profile. The avatar uploads but I receive the error message – There was a problem cropping your profile photo. And then the upload fails.

    I am running PHP Version 5.4.43 with the current host.

    Does anyone know if this is a php version issue or if there is another fix for this issue?

Viewing 11 replies - 1 through 11 (of 11 total)

  • Henry Wright
    Moderator

    @henrywright

    The PHP version you’re using shouldn’t matter unless it’s < 5.2. Also JavaScript is responsible for the actual cropping. I’m guessing you’ve either modified your template in some way or are using some conflicting JavaScript elsewhere?


    WalkerDesign1
    Participant

    @walkerdesign1

    Figured out the problem. The file name for the profile image was too long. It needed to be shortened. Upload and cropping is working great.


    Henry Wright
    Moderator

    @henrywright

    Great 😀


    Michele Riva
    Participant

    @micheleriva

    Same problem here, I’ve tried to upload an image called “believe.jpg” but it’s not working… I’ve tried with php7, php5.4 and php5.6, nothing seems to fix the problem 🙁


    dcrowe
    Participant

    @dcrowe

    I am having the same issues. I can upload and set the crop marks but then when I click save I get “There was a problem cropping your profile photo.”

    I have updated buddypress and bbpress, made sure my file permissions on the avatar and uploads folder are set to 777

    No clue why this is happening.


    kalico
    Participant

    @kalico

    Thank you @walkerdesign1. I’m not sure I would have ever considered that the filename would be too long, but that fixed the problem for me. This could really use some improved error handling.


    sadasoundarya
    Participant

    @sadasoundarya

    First give ‘777’ permission to uploads folder using

    sudo chmod -R 777 uploads then

    Run the following commands in your server

    sudo apt-get install php5-gd /*After installing above package*/

    sudo apt-get update /*After updating all the packages*/

    sudo service apache2 restart


    Henry Wright
    Moderator

    @henrywright


    press786
    Participant

    @press786

    I am still facing this issue, even after giving all the permission & uploading an image with a small name.
    Using
    Buddypress 2.8.2
    wordpress 4.7.5
    Please provide a resolution to this, I want to have an upload avatar option in the register page.
    I am using “Buddypress avatar upload ajax” plugin for this.


    Mahaprabhu
    Participant

    @mpcd108

    I used a shorter name.. it worked.
    does anyone know if there is a way to provide a link to the photo – just like it takes it from Gravatar.. can we provide a link from another picture to be able to accept it as Profile Photo

    I am thinking this way we can avoid cropping GIF and be able to use GIF as profile photo

    any help on this
    ?


    metalhead
    Participant

    @aaronthomas1979

    Thanks for sharing your solution. Shortening the filename worked for me too.

    I’m going to search Buddypress Trac and see if the authors are aware of it. I’ll report it if it’s not in there.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Skip to toolbar