Skip to:

Transation with Loco Translate

  • werny


    I updated Better Messages
    I am using this on a German Website and I translated all the strings from EN to GERMAN with Loco Translate.
    But after each update the whold plugin is ENGLISH again on my frontpage and I have to translate all the strings again to GERMAN.

    Why do I have to do this after each update?
    Is there a way to avoid it?

Viewing 1 replies (of 1 total)
  • What you have to do is to the PolyGlott translation web site:

    Get familiar with the translation system there (you can also download and upload files)
    and after proposing about say a hundred translations,
    join the WordPress DE Slack and in the #polyglots channel,
    and kindly ask to become a PTE (Plugin Translation Editor) for BuddyPress.

    I did this now and reviewed and translated all over 1000 missing or bad German translations!

    If the informal “Du” (not the formal “Sie”) translation is enough for you,
    let your WordPress installation download the latest translations by setting the global
    Language in Settings > General > Language to “German”.

    Otherwise, WordPress may also download my new translations automatically,
    at least when you update the Plugin or switch the language.

    The German translation I completed now is not yet perfect and 100% consitant,
    so I am looking for reviewers, testers and contributors!

    Please, by any means: Everyone using BuddyPress in “German”:

    Flip your Site Language, and on the switch back to German (Du), it should download
    soon download the new translation and try them out!

    You can also review my translations here:

    If you have improvements proposals, please register on the site and submit your improvements!
    (If you also drop me a note, I should be able to review and include your fixes!)

    Thanks and I hope it works for everyone…!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.
Skip to toolbar