Skip to:

Upgraded to 1.2.4 and now No Blogs Showing!

  • russnm


    Just upgraded to 1.2.4 (using WPMU, BP default theme) and everything seems to work fine…EXCEPT all blogs are missing (except for a couple that were registered just after the upgrade). They are missing from the top (BP) menubar, and also from the Blogs page. Did backup the database…thankfully…but not sure how to make the necessary repair. Any advice? Anyone else experience this problem. Big problem for me as I host nearly fifty independent blogs on this site:

    NOTE: Just discovered that while the custom avatars are still showing on the Members and Activities pages, they are no longer showing in the top (BP) menubar under the Blogs pick. Been replaced by a default “mystery man” avatar. Any help with these issues would be greatly appreciated.

Viewing 25 replies - 1 through 25 (of 39 total)

  • abcde666


    seems like BP 1.2.4 was tested with only, which unfortunately is not running on WPMU anymore…..would be better to have a with Single-WP and another test-website with a WPMU-install.

    This would also help developers to compare their own WPMU-BP-website against a default WPMU-BP-install (like but with WPMU).



    This is a huge issue no? I would assume that a large portion of BP users are running WPMU, given that BP until just recently didn’t run on a single WP install. I’m certainly glad I poked through the forums before upgrading tonight (as I had intended to.) Hope there is a fix soon. Perhaps a note on the main blog is in order once this is sorted.

    Sam Steiner


    I’m wondering if this has to be fixed in a BuddyPress version or in a WPMU version (coming closer to WP Single)? I agree it is a huge issue since most/all installs that are active in the meantime (meaning the “older” installs) will be running WPMU.

    @erich73 — “seems like BP 1.2.4 was tested with only.” Sorry, but that’s ridiculous. I for one have been using what become 1.2.4 on WP/MU 2.9-3.0 since work started on it. The testbp site is to let people try out BuddyPress and learn what it is, without having to setup their own install; it’s not for testing code (although it is handy for validating bugs).

    @russnm – the avatar problem has been reported (#2400) and @r-a-y‘s contributed a solution. There may be several avatar problems.

    Please someone report any other issues, including this blog list one, to I’m wondering if something added for WP 3.0 has broken WP 2.9.x installs.

    Hi Folks,

    I had exactly the same issue…fortunately I’ve only got 13 blogs so I was able to fix it manually.

    For anyone that is interested, this is what I did. I’m no mySQL expert so this is very manual (I tried to upload the records using ‘import’ but as usual some setting was correct…couldn’t be bothered dickin’ with it so I went manual :-P)

    It seems that the BP 1.2.4 empties the following Db Table – ‘wp_bp_user_blogs’.

    Fortunately I did a backup before venturing with yet another notorious BP Update.

    In my Db Backup (which is pretty big), I just did a ‘Find next’ search for ‘user_blog’. The info. your looking for looks like this:

    “LOCK TABLES `wp_bp_user_blogs` WRITE;
    /*!40000 ALTER TABLE `wp_bp_user_blogs` DISABLE KEYS */;
    INSERT INTO `wp_bp_user_blogs` (`id`, `user_id`, `blog_id`) VALUES (1,1,1),(2,3,1),(21,1,14),(20,1,13),(19,6,12),(17,1,12),(22,1,15),(23,1,16),(28,1,18),(25,1,17),(26,10,16),(27,10,13),(29,1,19);
    /*!40000 ALTER TABLE `wp_bp_user_blogs` ENABLE KEYS */;

    If you open you Db in myPHP Admin, click on the ‘wp_bp_user-blogs’ table, and when it’s empty row appears, just go up the top and click ‘Insert’. This will present you with a list of the 3 rows in the table. Their ‘Field’ names are respectively ‘id’, ‘user_id’ and ‘blog_id’ as it says above.

    Just take each block of 3 numbers in from your backup info. (I’d advise not using my numbers above :-P), and pop them in, to the respective rows, 1 set at time. That is to say, place 1 each of the first set of 3 numbers on each row in its respective Field, then click ‘Go’. That will create a row in the Table. Then repeat the procedure for each set of 3 numbers.

    I hope that helps someone.

    Next MAJOR Problem is that I no longer have BP Admin Bars appearing at the top of my Blogs. If anyone has a fix I’m all ears.

    These are prettty major issues. This is my first BP Update…I’m now terrified of future ones.

    Anyway, now I’m off to spend more hours troubleshooting this other MAJOR PROBLEM.


    Stephen G

    Oh! I forgot to mention:

    I’m using WPMU 2.9.2, on a Linux Server.

    I updated to BP 1.2.4 from 1.2.3.

    I deactivated all other BP Plugins and deactived BP Templates before Updating. Then when that stuff happened. I removed all BP Plugins and rebuilt the BP side of things one step at a time. End result was the same…no blogs, no BP Admin bar on Blogs.


    Stephen G again…

    Oh! This just keeps getting better and better. I’ve lost pretty much all BP Functionality on my Blogs…i.e. no Member Widgets, no Group Widgets etc…

    On checking the Dashboards for individual Blogs, there are no BP Widgets therein!!!

    Again! This has got to be pretty basic stuff to check during pre-release testing…hasn’t it?

    I’m going back to 1.2.3.


    Stephen G

    Oh! And it may be worth noting that BuddyPress used to appear in the Site-Wide Plugins list in WPMU…it now appears in the normal plugins list…which would in theory (I have checked it and I’m not going to try), that Users would be able to Activate/Deactivate BP via their Blog Admin (unless of course I hid it).


    Stephen G

    @noshitwft, sounds like you enabled BP from the upgrade screen. Disable BuddyPress, then go back to the plugins page and re-enable it sitewide. That should fix many of your issues, but not the blog lists one. Working on a fix for that now.



    Ok, guys, this is very easy to fix, IF you have a backup of your DB tables.

    Open the backup .sql file and do a search for wp_bp_user_blogs (substitute wp_ for whatever your DB prefix is). Find the line that starts with:
    INSERT INTO `wp_bp_user_blogs`

    Copy that line, open phpMyAdmin and paste the code into the SQL tab. Hit enter and the blogs reappear.

    If you don’t have a DB backup, then you have to manually enter all your blogs into that DB table. Or write a little script that does it for you.

    Hope this helps you guys!

    @shawnkhall and @Travel-Junkie

    Thanks guys…I’ll give it a whirl.


    Stephen G

    Thought I’d test this blog DB issue.

    Chose an older test install with BP 1.2 – deactivated ALL plugins, removed all old BP folder and files, brought WPMU up to latest version from 2.9.1. Confirmed WPMU & blogs running correctly

    Downloaded BP 2.2.4 Activated (doesn’t activate sitewide?!) enabled default theme but NO other plugins; visit site no blogs!

    Check DB and confirm table dropped :)

    Reset table rows as before, nothing still no blogs under BP & and of course no primary blog so can’t get back to dashboard normally :)

    Feels as though 2.2.4 is built for WP 3.0? doesn’t feel backward compatible.

    Not sure how this made it through any basic testing really to release candidate.

    I would hope this release was retracted very quickly until the issue is resolved before others trot of and god forbid upgrade production sites with large numbers of user blogs and inadequate backups.

    Ok! That’s a vast improvement! Doh! Sitewide Activation…what a thing to miss.

    @shawnkhall Yep! That fixed most issues. The only one I can see now (just having a quick look, not a thorough test), is that the Group Avatars are not showing up in the ‘Groups’ Widgets….but they are showing ok on the ‘Groups’ page on the Primary Blog. It would be nice to be able to fix that, but it’s hardly what I’d call a Major Issue. Thanks again for your help.

    @Travel-Junkie…yep! That worked fine too…thanks :-)


    Stephen G



    Ok, I have over 400 blogs on my site and I didn’t back up my database before doing this update…
    I’m a complete newbie when it comes to SQL and stuff, is there anyone who would help me get my blogs back ?



    All the blogs show up in Site Admin | Blogs in the backend, is there a way to import them straight into the wp_bp_user_blogs ?



    After the upgrade from 1.2.3 to 1.2.4:
    1) Myblogs – empty
    2) White screen on all blogs except main
    3) in the web server logs: “.. Call to undefined function bp_core_add_root_component ()..”, although the function is present in 1.2.3 and 1.2.4 … (“Swears” plug-bp-events)


    doing a merge of the 1.2.3 and 1.2.4 – looks like this function changed and is called during the installation process. I don’t run WPMU/MS – if anyone can verify this is the problem and submit a trac ticket

    function bp_blogs_record_existing_blogs() {
    global $bp, $wpdb, $current_site;

    /* Truncate user blogs table and re-record. */
    $wpdb->query( “TRUNCATE TABLE {$bp->blogs->table_name}” );

    $blog_ids = $wpdb->get_col( $wpdb->prepare( “SELECT blog_id FROM {$wpdb->base_prefix}blogs WHERE mature = 0 AND spam = 0 AND deleted = 0 AND site_id = %d” ), $current_site->id );

    function bp_blogs_record_existing_blogs() {
    global $bp, $wpdb;

    /* Truncate user blogs table and re-record. */
    $wpdb->query( “TRUNCATE TABLE {$bp->blogs->table_name}” );

    $blog_ids = $wpdb->get_col( $wpdb->prepare( “SELECT blog_id FROM {$wpdb->base_prefix}blogs WHERE mature = 0 AND spam = 0 AND deleted = 0” ) );

    Hi Guys,

    Just an update on the Groups Widget thing:

    User Blogs – None of the links ‘Newest’, ‘Active’ or ‘Popular’ work either. Return a 404 Error. I re-saved the ‘Permalinks’ pages on the individual Blogs but it didn’t fix anything. Individual Group Name Links work ok.

    Primary Blog – Everything seems to work fine there. All Group Avatars appear where they should (including in the Groups Widget), and ‘Active’, ‘Popular’ and ‘Newest’ links work ok too.


    Stephen G



    What i have to do if i have a fresh wordpress 3.0 and buddypress 1.2.4 installation? i have no backup because i haven’t used it.



    @Travel-Junkie Thanks so much for the ‘missing blogs’ fix! It worked perfectly. Which is amazing since this was my first attempt to get ‘inside’ and ‘manipulate’ an online database. First I downloaded the backuped copy of the database to my local computer. Then downloaded and installed HeidiSQL so I could open the database and get the line of code you cited (i.e., “INSERT INTO `wp_bp_user_blogs”). I ran a search, found and copied the resultant code, then opened phpMyAdmin on my online (HostGator) server, clicked the SQL tab, pasted the code, and away she rode! Opened the site, and all the missing blogs (over 50 of them) were back! So again, THANK YOU for the clarity of your instructions. VERY MUCH appreciated!!!



    i have instert: INSERT INTO `cb_bp_user_blogs` VALUES(1, 1, 1);
    but it did not work…
    i have a fresh install of wp 3.0 beta 2 multisite and buddypress 1.2.4
    the values are correct because i have only one user and one blog (default or first blog) and the id’s are correct.
    whats wrong?


    You have a fresh install? have you created any user blogs before the upgrade to BP1.2.4? In fact was this an upgrade to BP 1.2.4 or simply a first install/activation?

    You will only have an issue with this table if you are already running blogs created under WPMU (don’t think the issue arises if adding BP to WP 3.0 with user blogs already created but might be wrong?)

    Edit/ oops yes there is an issue wp_user_blogs does not pick up the fact that there are blogs on a WP 3.0 install

    @0815 travel junkies instructions earleir in the thread explain how to deal with this issue but if you have very few blogs then simply re-enter the values however you may need to start at id ‘2’ as I believe – but may well be wrong – that blog_id would start at ‘2’ for a new install with ‘1’ being held for upgrades from WPMU




    Your advice worked like a charm !
    Thanks a lot !



    i have a fresh install. i have no blogs created but the first default blog is not shown.
    it was no upgrade. i have installed the new bp 1.2.4.

    the admin bar is not shown my blog under “my blogs” and redirect me to “Home”.

Viewing 25 replies - 1 through 25 (of 39 total)
  • The topic ‘Upgraded to 1.2.4 and now No Blogs Showing!’ is closed to new replies.
Skip to toolbar