Skip to:

Upgraded to WPMU 2.7 now I have an error

  • When you try to sign up onthe signup page here is the error…. thoughts?

    Warning: Invalid argument supplied for foreach() in /home/exbriefc/public_html/wp-content/mu-plugins/bp-xprofile/bp-xprofile-signup.php on line 104

Viewing 25 replies - 1 through 25 (of 35 total)

  • danbpfr



    I had a similar problem a few hours ago, after updtate… Make sure you have all files updated… I forgot one little file last night and have the error, coz new functions were added between rev 944 and 960.

    can’t help more !

    i guess I will run the auto update thing and see what happens, this is a pain inthe a$$

    yeah that auto update thing…does not work. Serious issues still on MU2.7

    Anyway when you sign up you get the error, but th username is still created and you get the confirmation email…however, you can not activate it…you get an “invalid key” error when you try.

    Anyone else have this happen?

    ok, I have the most current versions of BP and WPMU running……..same error!

    You are not running any other plugins that subscribe to the signup process do you? This is still the error you are getting?

    Warning: Invalid argument supplied for foreach() in /home/exbriefc/public_html/wp-content/mu-plugins/bp-xprofile/bp-xprofile-signup.php on line 104

    i have recaptcha that is on the signup page.

    and yes still getting the error.

    I haven’t seen this problem on any of the test installs I run, also on upgrades from 2.6.5. Has anyone else seen this error at all?

    Never, that is why I was asking exactly if that is the same error since there is another thread on this:


    wonder if it was ever resolved in the other thread by anyone?

    i sure hope this can be figured out. Kind of hard to get registered users if nobody can sign up….

    ok, I completely deleted the database, and all traces of WPMU and BP…total site-wipe. I then installed WPMU 2.7. I tested it to death and everything worked, everything! I installed BP…. I am still getting the same error. So whats the next step?

    wow, nobody seems to have a clue, that makes using BP 100% impossible…whats a site with no users?

    Burt Adsit


    Lets start from scratch here. Do you have the x-profile tables in you db? You should have:




    Where (tableprefix_) is set to something like ‘wp_’ depending on how you specified it on wpmu install.

    When you look at the tables with phpMyAdmin is there any data in the bp_xprofile_groups table? There should be 1 record in there on a clean install. id == 1 and name == ‘Basic’.

    In the table bp_xprofile_fields there should be 1 record it should have id == 1, group_id == 1 and name == ‘Full Name’.

    If you don’t have all the above you will get the error you describe. If you don’t have all of that then the required tables for bp are not being created and populated properly.

    Name value in my bp_xprofile_groups table is BASE, not BASIC. I assume that’s what you meant.

    EVERYTHING Else is exactly the way you said it should be.

    In addition to this…..

    I have narrowed it down to being somehow related to my Home theme….don’t ask me how.

    I switched the theme to the “BP Home Theme” and this error does nto happen, then back to my custom home theme…and bingo…there is the error when signing up again.

    I have the MU Default (Kubrick) theme and I have made some minor changes to the theme, but it is basically intact. It worked without error on MU 2.6 with original BP beta, then I upgraded to MU 2.7 and the BP Beta2 and now this error.



    Burt Adsit


    We need to narrow this down further. Make a copy of the custom theme you’ve created. Save it someplace. Wipe the directory /wp-content/themes/home. That’s where the theme labeled “WordPress mu Homepage” is located. I’m guessing you modified that one. Upload a fresh copy of that directory to the server. No mods nothing. Right out of the download zip. Activate that theme and then see if you get the error.

    done. no errors that way

    Burt Adsit


    Was that the theme you modified? If so what were the modifications?

    the theme thats there now is the original MU Default theme that comes with MU 2.7…I activated it to test the signup process and it worked fine. I will put the custom theme back up and see what happens

    ok same problem

    Burt Adsit


    Whatever mods you have in there is causing the problem.

    i see that. it’s strange that it worked PERFECTLY in the MU 2.6/BP 1.0 setup…perfectly. I haven’t changed anything in the theme since then, just upgraded MU and BP. Therefore something that changed in MU or BP has pissed my theme off, but I can’t possibly know all the changes that were made that pertain to this issue, I really am a novice at this whole deal. Any help is appreciated, if I can just get past this I’m all good. I fixed all the other issues I had….. so far. Not even sure where to start looking. I really did not change too much as far as functionality at all. I spent countless hours modifying the theme so I cant scrap it all and start over now!!!! LOL. thanks.


    Burt Adsit


    Both bp and mu have changed radically since the versions you mentioned. I have no way of knowing what conflict is causing the problem. Start by turning of all your mods and turn them on one by one. When the problem crops up the last mod is the culprit.

    I hear you. Wow, I am at a total loss with this. I really changed only cosmetic things in the theme, and nothing to do with the core functionality. I am not sure where to even start on this. I am speechless. This sucks. Thanks for all the assistance. Most of the MODS I did were to the actual files (PHP) and I am not sure if I can pull them all. Any idea what would be the best place to start looking? What area of the theme would you start in…which php file? The odd thing is it pulls up the sign up page correctly so its good until that point, but that file is not in the theme, and then it all goes bad from there. This really does not make any sense to me at all.

    Burt Adsit


    Where did you change these ‘cosmetic’ things. List the files you changed. You are running without *any* plugins at all right? If you have plugins activated or in mu-plugins other than bp remove and/or deactivate them. Try again.

    i changed these files:







    -wp-signup (all I did here was change <div id=”content” class=”widecolumn”> to <div id=”content” class=”narrowcolumn”>)

    Then I added some independent scripts which all work fine and are unrelated to the signup process.

    gonna pull the plugins and see what happens again right now.

    pulled all the plugins…..made no difference, still have the error (and the plugins were all there and activated with the other theme I tried that worked fine).

Viewing 25 replies - 1 through 25 (of 35 total)
  • The topic ‘Upgraded to WPMU 2.7 now I have an error’ is closed to new replies.
Skip to toolbar