Skip to:

Upgrading to 1.1-rc/1.1-beta

  • There are a few things to be aware of when upgrading to 1.1-rc/1.1-beta.

    1. BuddyPress no longer uses a two theme setup, one theme controls everything on your installation. To use the new theme setup you must remove your /wp-content/bp-themes/ folder and move the new themes to the /wp-content/themes/ folder.
    2. Your themes are backwards compatible if you do not wish to use the new theme setup. You can simply leave your bp-themes folder in place. However, you will not see many of the new features of 1.1 and there is no guarantee of future support in coming versions.
    3. BuddyPress now expects bbPress to be in a specific location /plugins/buddypress/bp-forums/bbpress/ as it no longer uses XML-RPC. You must have bbPress installed in that location to use group forums. You can still use an external installation of bbPress, but BuddyPress will use its own internal bbPress files with your bbPress DB to load forums within BuddyPress.

Viewing 9 replies - 26 through 34 (of 34 total)
  • The trunk version of BuddyPress has fixes for subdirectory installs. I’ll probably release a second beta tomorrow. Perhaps wait until then to upgrade if you are using WordPress MU in a subdirectory, or use subversion if you know how.



    Do anyone know if the issue of installing buddypress into a blog with id other than #1 works yet?

    I was running the older vs. and when I tried setting blog id#30 it never worked right so I wiped the system and started over. Simply waiting until a vs. of bp works in subdomain blog other than 1

    If it does are there new instructions for getting it to work in blog other than 1?



    using WPMU 2.8.4a + 1.1-beta + Atahualpa 3.4.2 theme

    I deleted the old bp-themes, and moved the 2 folders to /themes/

    I am having issues similar to @driz’s (

    1. When I select my atahualpa theme as active, I get the message

    You do not have any BuddyPress themes installed.

    Please move the default BuddyPress themes to their correct location (move /…/html/wp-content/plugins/buddypress/bp-themes/ to /…/html/wp-content/bp-themes/) and reload this page.

    I can still see my main blog (with the atahualpa look), but when I choose to open /members or /groups etc, I get redirected to Home

    2. When I select bp-default as the active theme, everything works fine, but I obviously don;t have my customized look-and-feel I had with atahualpa

    How do I make atahualpa work again?

    Jeff Sayre


    Just a friendly reminder to all.

    If you have an issue other than an upgrade issue then please start a new thread. This thread is only for discussions of upgrading to 1.1-beta from a previous version.



    Just upgraded to buddypress 1.1 beta and I can say that it is really great! With the 1 click integration with bbpress, it is really good! But 1 question, can I use this 1-click integration to create a site wide forum just like here in, wherein the forum is not just a collection of all forum posts from the different forums used in buddypress components (primarily in Groups). Hope you could help me out on how to do this. Thanks in advance!


    Mike Pratt


    Finally starting diving into 1.1 on my dev site and encountered a strange issue.

    wpmu 2.8.4a, bbPress 1.0

    just using plain default theme for now. forums work great. saved all my old posts. all seems ok BUT

    on back end no option panel for profile fields. on front end all profile data is gone but name and website. Under My Profile it just has Public (no edit profile or change avatar)

    Is this just a butchered install or something else?

    Mike Pratt


    disregard prev comment. prob solved. guessing incomplete file transfer on upgrade. complete deletion and re-install solved issue. Thanks

    Okay… I must be an idiot but I can’t even get the plugin activated. I installed a fresh WPMU 2.8.4a with a fresh database and no plugins. No problem so far. Then I placed the release candidate files (bp-activity, bp-blogs, etc.) inside wp-content/plugins/buddypress and the plugin doesn’t even show up in the admin area. Wha? I went to “Site Admin” as well and enabled plugins in the options area. No dice. Weird. It just says “No plugins to show”

Viewing 9 replies - 26 through 34 (of 34 total)
  • The topic ‘Upgrading to 1.1-rc/1.1-beta’ is closed to new replies.
Skip to toolbar