Skip to:

Upgrading to 1.1-rc/1.1-beta

  • There are a few things to be aware of when upgrading to 1.1-rc/1.1-beta.

    1. BuddyPress no longer uses a two theme setup, one theme controls everything on your installation. To use the new theme setup you must remove your /wp-content/bp-themes/ folder and move the new themes to the /wp-content/themes/ folder.
    2. Your themes are backwards compatible if you do not wish to use the new theme setup. You can simply leave your bp-themes folder in place. However, you will not see many of the new features of 1.1 and there is no guarantee of future support in coming versions.
    3. BuddyPress now expects bbPress to be in a specific location /plugins/buddypress/bp-forums/bbpress/ as it no longer uses XML-RPC. You must have bbPress installed in that location to use group forums. You can still use an external installation of bbPress, but BuddyPress will use its own internal bbPress files with your bbPress DB to load forums within BuddyPress.

Viewing 25 replies - 1 through 25 (of 34 total)

  • gerikg





    Good stuff! I hope to upgrade to WPMU 2.8.4a, so I can test BP 1.1-beta either this week or the next.

    Will probably stick to legacy theme support until I have time to play with the parent/child theme structure.

    I’m now pondering over whether I should use an internal installation of bbPress now that I’ve seen the new BP forums in action ( I’ll cross that bridge when I get there!



    Hi !

    Seems to have good new functionnalities !

    I have one problem though :

    I use a fresh install (WPMU 2.8.4 + BuddyPress 1.1 Beta); no plugins;

    I moved /bp-default and /bp-sn-parent to /themes;

    and I get

    Not Found

    The requested URL …./wordpress-mu/blog was not found on this server.

    Then I did copy my old .htaccess file to the fresh WPMU installation; and now I have

    Page Not Found

    The page you were looking for was not found.

    What is the problem ?



    Maybe an idea here; in the Theme Options, it says this :

    The template files are located in /themes/bp-sn-parent/groups. The stylesheet files are located in /themes/bp-default.

    I installed 1.1 and was greeted with this:

    Fatal error: Class ‘WP_Widget’ not found in D:www/myaxelis/wp-content/plugins/buddypress/bp-core/bp-core-widgets.php on line 14

    the next time I tried to load my WPMu/buddypress page. Where did I go wrong.

    @Nfzgrld: WPMU 2.8.4 only please.



    @Andy : any idea for my problem ?


    Jeff Sayre


    @Nfzgrld: WPMU 2.8.4 only please.

    Specifically use WPMU 2.8.4a, as plain 2.8.4 had a security issue.



    I’ve been testing the beta and I must say it’s great. The installation of the forum is just amazing. One click and it was done and working like a charm – WOW.

    Everything works fine except one tiny little problem which I don’t think is a bug. I am just wondering if anybody else had the same problem.

    All the main buttons (blog, members, groups, forums and blogs) take me to a 404 page “Page Not Found”. Everything else works fine. I can go to profiles, groups, group forum etc. without a problem. The links on the buttons look fine, just what I would expect them to be.

    My setup:

    fresh install of WPMU 2.8.4a

    fresh install of bp 1.1 beta

    fresh install of bbpress 1.0.2

    using out of the box bp theme

    It’s running on my local machine with xampp. Htaccess file is in place and url rewriting is working fine. Themes (bp-default and bp-sn-parent are in the themes directory and only the bp-default is activated.

    Any ideas???


    P.S. Thank you everyone who contributed to 1.1beta release. You did an awesome job.

    @Robert: Are you running a subdir or subdomain WPMU install? Do you have WPMU in a subdirectory on your server?



    I have subdomain WPMU install. It worked fine with 1.0.

    I changed the domain localhost to (using HostsXpert)

    to access the site I have to type

    the site root directory is: C://xampp/htdocs/

    subdomain is

    The main button links read as:

    GROUPS >

    BLOGS >

    and so on.

    When I go to my profile the link is:

    and it works fine.

    strange, isn’t it?

    Looks like its the subdirectory messing things up, can you add a bug for this and write what you have about in it? Thanks.



    Thanks Andy. I will.

    EDIT: done – ticked created



    updated all the files mu 2.8.4a, bp 1.1-beta and bbpress 1.0.2 all works fine and configured without a problem but forums directory give me a white screen…

    the forum for the groups works fine.

    any idea about this problem? thanks



    Got the same problem than Robert…

    If you are running WordPress MU outside of the root, for example: then you are going to experience problems with the 1.1 beta. I am fixing right now.

    Finding two bugs (?) in the beta-version:

    1. When updating the status in the sitewide-activity it shows double (2-times)

    2. The widgets are not translated… Could that be a bug, because in earlier versions everything was fine (I am using a german localization)

    Anybody else experiencing this?

    The rest: JUST GREAT! Although I have to figure out what I will do now with my highly costumized theme…

    Just like to say that I’ve experienced the same problem as Robert with new 1.1 beta having my WPMU installed in no-root folder and with subdirectory variant.

    I just hope that fixes Andy was speaking about would affect such case too.

    Apart from that I like the new version very much and new template system also despite the fact that I have completly rewritten my customized templates :)



    readme.txt says,

    Move “/wp-content/plugins/buddypress/bp-themes/bp-sn-parent” and

    “/wp-content/plugins/buddypress/bp-themes/bp-default” to “/wp-content/themes/”

    But when bp-themes does not exist, alert box with message below appears on General Settings page.

    Please move the default BuddyPress themes to their correct location (move /var/www/html/test/wp-content/plugins/buddypress/bp-themes/ to /var/www/html/test/wp-content/bp-themes/) and reload this page.

    Which is correct?

    Jason Giedymin


    I want to point out that if you have a highly customized site, you may want to start fresh and then port over piece by piece. The end result will be the same, that you’ll accomplish your goals but the process will be smoother and faster. Strictly from a down-time, money is time, point of view… at least this is what I’m experiencing…

    The warning should not appear if you have a BuddyPress enabled theme activated.



    Can I ask if there are known CSS issues with IE7 on the default theme?

    FF is fine after the upgrade but the CSS is not right in parts of the profile for IE7. When on the Profile only in IE7 you get a very long page.

    Also when rolling over the wire to post the whole profile will drop down about 2000px.

    If anyone has an updated CSS file or has a fix that would be great. As mentioned everything is fine in FF. I can supply a link if needed.



    Sorry I was being lazy. The issue for IE7 is in 3c-left.css.

    IE fixes are being worked on.



    Hi Andy; non-root folder means that I need to run my WPMU in


    instead of

    http://localhost/mysite/wpmu ?

    You told me in another post that I should use bp_core_new_subnav_item() instead of bp_core_add_subnav_item(); but the 1.1 does not work yet here so if I just need to move my installation for the moment, I can do it…

    thanks :)

Viewing 25 replies - 1 through 25 (of 34 total)
  • The topic ‘Upgrading to 1.1-rc/1.1-beta’ is closed to new replies.
Skip to toolbar