Skip to:
Content
Pages
Categories
Search
Top
Bottom

User avatars and gravatars broken link

  • Profile photo of ProfC
    ProfC
    Participant

    @profc

    Hi, I have this problem: many users of my social network have lost their Avatar and Gravatar. Instead of the original image I can see a broken link icon. Besides this, If I try to upload a new image I cannot do it, It gives me back a black frame. The Avatar directory is the default one, wp-content/uploads/avatars. I can see it if I right-click on the image box, with a sub-directory for each user, I guess, named 1, 2 etc. Should I change this directory and where?

    I don’t know why it did happen. First I had forum and users pages on custom directory, but some days ago those links became wrong (I don’t know why), so I turned them to the default pages from buddypress settings/pages

    My configuration is
    Buddypress 1.7
    WP 3.5.1

    and many other buddypress-related plug-ins.

    Many thanks,
    Gabriele

Viewing 4 replies - 1 through 4 (of 4 total)
  • Profile photo of @mercime
    @mercime
    Moderator

    @mercime

    @profc first thing is upgrade to BP 1.7.1. Change to BP Default and see if issue is resolved – no black frame. Check if your preferred theme has been upgraded for BP 1.7+. Do also double-check that the plugins you’re using have been upgraded to latest BP version as well.

    Profile photo of ProfC
    ProfC
    Participant

    @profc

    @mercime I up to date BP to 1.7.1 but the problem si still there. I also tried to switch to the default theme but nothing has changed. I still have broken link instead of avatar pics and i cannot upload a new avatar. Please, help me.

    Profile photo of ProfC
    ProfC
    Participant

    @profc

    hi again, I found this

    https://buddypress.trac.wordpress.org/ticket/4571

    is this a solution to the problem?, may you please tell me ho to patch a php file? is the file to patch bp-core-avatars.php?

    thanks,
    g

    Profile photo of ProfC
    ProfC
    Participant

    @profc

    Hey, no one can help to solve my issue? Pleas, I don’t want to start again from the beginning.

    Avatars link are like the following:

    http://www.sitename.net/wp-content/uploads/avatars/56/808d387ede62f1eade7ee8c6dbfd36cd-bpthumb.jpg

    I can see the folder and the file through filezilla; I cannot save the image from web page.

    Thanks,
    Gabriele

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘User avatars and gravatars broken link’ is closed to new replies.
Skip to toolbar