Skip to:

User Blogs gone! What do I do now

  • zageek


    I upraded my BP instalation from 1.1.3 to 1.2 and found that I had some problems, so I deleted the buddypress plugin and then reinstalled it.

    Now I have reinstalled 1.2 and used the backwards compatibility plugin and I cannot access any of the blogs from the front end. I assume they are still there because I can see them in the backend. However when I try to edit the posts it kicks me out to the front end.

    I am running WPMU 2.9.1 with BP 1.2. What can I do now because it seems like I can’t do anything to access the data.

    When I deleted buddypress did it also remove the user blogs from the database I thought it wouldn’t because isnt that handled by WPMU?

Viewing 25 replies - 1 through 25 (of 35 total)

  • disbas


    Having similar problems. Some of my users can’t access their blogs. The backend that is. BuddyPress counts fewer blogs than WPMU has registered.

    Similar troubles in this thread:

    STRANGE – and very BAD :-(

    Help, Andy!!! :-)

    If the blogs are not set to be public (visible to search engines) then they will not appear anywhere unless you directly visit the blog.

    Are you saying that if you directly visit the blog URL, you can’t access it?



    My users don’t see their blogs. Not in WPMU under My Blogs, not in the buddybar, not in buddypress under blogs.

    If they directly visit the URL/wp-admin, the back-end is there. The blog is set to public (just double checked that).

    My problem seems similar to the problem in

    Yes – having the exact same problem. My site users are not able to see the Blogs there are associated with under the “My Blogs” drop down in the main Buddypress Admin bar in the front end. Again, this is after an upgrade to WP 2.9.1 and BP1.2.

    It really is a strange and very BAD issue, Andy!

    To narrow it down in my case:

    It only seems to happen to random users (some see their blogs, some don’t)

    If it happens:

    1. The user doesn’t see the blog listed under “my blogs” in the admin-bar

    2. The blog isn’t listed in the blog-directory

    3. In the profile the “my blogs”-Tab says there is (1) Blog, but when you click on it it’s empty

    4. You CAN access the blog with the direct URL

    5. You CAN access the backend from the blog

    6. When writing a new post it DOES appear in the activity

    So far. Hopefully it helps to narrow and hunt down that strange bug!



    Just logged in as one of my troubled users.

    He sees My Blogs (1) in the BP-theme. But when he clicks it, there’s no blog. There’s no blog in the my blogs section in the buddybar either.

    It’s strange. Most of my users don’t have this problem. Just two of them who work on the same blog.

    @disbas – Can you confirm that the blog in question is public or private?



    Public. Set it to private and then to public again.

    Same with me

    I’ll see if I can reproduce this, if anyone can work out steps to reproduce that would be handy.



    As we say here in South Africa “Eish!” (pronounced “aysh” and no its not a swearword)

    I checked everything and my users blogs are all set to public. Even the root blog seems inaccessible which why I presume I can’t even see the “front page” with all the widget areas, the only thing that is working is the groups section

    Heres how I ended up in this pickle:

    I have had some issues here and there with 1.1.x but otherwise everything was working fine before I migrated to 1.2…

    Then I decided to updgrade to 1.2 without checking to see if there would be issues. Immediately after the upgrade I had some problems where my theme was broken. It didn’t occur to me that 1.1.x themes might be incompatible with 1.2 and so I thought it was my theme. I was getting an error saying that “bp_group_pagination_count() ” does not exit in “mytheme/groups/group-loop.php”

    Upon inspecting the logs and looking in the trunk code in TRAC I discovered what I though to be typos in the code. The code in “groups/ground-loop.php” in TRAC said actually called a function with the “bp_groups_pagination_count() ” note the change from “group” to “groups” in the function name. So I thought I had it sorted. I edited my them and changed the function call to bp_groups_pagination_count() and all seemed well except that I couldn’t see my user blogs or my other pages ( which have custom slugs). I also noticed that when I visit my site it lands me on the “groups” section.

    So I deactivated 1.2 and deleted it using the backend thinking that if I completely remove my upgraded BP 1.2 and start from scratch it would all be good. Then I went to install “new plugins and to the search to search for buddypress and then I installed 1.2 all over again. I also installed the backwards compatibility plugin which I updated just now as well. Then I started to get the same problem and noticed that I couldn’t even edit the root blogs posts from the backend and neither can the users edit their blogs.

    After scratching my head I went to go and look within the database tables and I can see that the posts are still there, so its clearly and issue with rendereding the content through BP. Because when I deactivate BP press completely and go back to Kubrick I can suddenly see all my content by going to the links to the different pages directly.

    So my site is in limbo at the moment ,which is all part of the fun I guess. I hope that helps you Andy and whoever else is looking into this.

    No doubt the other users will have followed a different path to get to where I am but I feel its something to do with the migration to BP 1.2 that has somehow altered some data somewhere that effects the output when BP is active together with the backwards compatibility plugin

    I made a (very-unspecific) ticket:

    I was the first to post about this issue actually (in that other thread). I’ve tried to reliably reproduce it and I’m afraid I cannot. Blogs are set to public. It always seems to happen when a new user registers and/or is promoted to a blog admin. I’m not sure if this is a BP bug or a WPMU bug… but I couldn’t find anything about this issue on the WPMU forums. At one point even my original admin user (username “admin”) couldn’t see any blogs listed. And I went into Site Admin > Options and switched the order of the admin usernames listed (on a lark) and that fixed it?! Very random… and bizarre. I wish I could outline steps to reproduce it.

    p.s. unlike zageek… everything else is working perfectly. The only issue is no blogs being listed under “My Blogs” in the admin bar and in the users profile. So it’s not really all that critical. Everything still works. But it’s confusing to see a “Blogs (3)” tab in the profile with no results… and it’s a pain to have to type “wp-admin” in the address bar of your browser rather than being able to use the shortcuts in the admin bar.

    I believe all these problems relate to when a user is *added* to a blog with higher than subscriber privileges. BuddyPress wasn’t recording this action correctly. I’ve fixed this in the 1.2 branch. Please give that version a go and see if that fixes your issues. Remember to de-activate/activate BP to refresh your user blogs table.

    [blockquote]I believe all these problems relate to when a user is *added* to a blog with higher than subscriber privileges. [/blockquote]

    Yes, this fits with my experience that blogs dissappear, when I changed the automatic configuration role for new users. With a new fresh WMPU and BP 2.1 – 2755 branch without any old data or upgrade it is working now.

    @Andy: Yes. I was never able to reliably replicate the problem and outline specific steps… but when it DID happen… it was always sometime after added a new user.

    The only way I could replicate it was by using an old DB that had the problem. r2755 didn’t fix it in that case… but maybe that’s to be expected since that DB was generated by a pervious version of BP. Not sure. All I know is… my current installs are all fine for now.

    @David Lewis @karto Could either one of you try reactivating the latest 1.2 branch version on your existing database? It should wipe your user blogs table and correctly recalculate it. Please then try adding a user to a blog and see if it works correctly for you.


    Do I get that right: This problem should NOT appear, if users have created a blog normally themselves (so that they are automatically an admin)?

    If that would be the case, it’s NOT maching our troubles. Blogs have disappered for users like that…

    I’ve fixed a number of issues related to registering blogs in different scenarios, so the best way to put this to bed is for you guys to please test it.

    Hi Andy this is what I did:

    Kopied trunk r2766 over the 1.2 stable files. Activated again.

    Problem is still there. The one user I know for sure still doesn’t see his blog in buddybar, under “my blogs” etc and it’s not listed in the blogs-directory (but it is set public!!!)

    Ps: If it helps, I could PM you the login of that perticular user, so that you can see for yourself… (he would be ok with it)

    @Michael Berra – did you log in as this user and confirm they cannot see the blog? Also – don’t use the trunk, use the 1.2 branch:

    yes – I logged in as that user – doesn’t see it. I will try again with the branch… (by the way – any more ideas on this very strange issue: – sorry to use this thread, but it’s important to me :-))

    Your second issue is fixed in the 1.2 branch. Let’s keep this on topic.

Viewing 25 replies - 1 through 25 (of 35 total)
  • The topic ‘User Blogs gone! What do I do now’ is closed to new replies.
Skip to toolbar