Skip to:

www / root problem (blog shows, but not members / groups / etc)

  • online


    I can’t get anything but [wordpress]/blog to show up.

    I think there may be an issue with hosting provider redirecting to “www” — I’ve already installed plw123_true_http_host.php (for the wpmu installation)

    But I can’t get anything in buddypress to work (besides /blog — which was created with wpmu install)

    For example: tried to update avatar, but get sent to homepage… O_O

    HELP ?!?!?

    (note: I don’t see anything like “member” directory in wp-content — could that be part of the problem?)

Viewing 15 replies - 1 through 15 (of 15 total)

  • online


    I think the problem may actually be the placement of the buddypress themes (this is not explained anywhere that I can find). I just watched the video about installing on a Mac and I’m trying to figure out where it should be placed (hope I don’t break anything)… :|



    The buddypress themes should be place in the normal WP theme folder:


    Upload bp-sn-parent and bp-default to the theme folder and activate the bp-default theme :)



    that’s what I started out with — so basically both (2) folders get moved into the theme folder, right?



    perhaps the problem is that I had “create accounts” locked when I installed buddypress — does the installation actually create “members”, “groups”, etc blogs (and couldn’t, so that’s why it can’t find them)?

    Jeff Sayre


    does the installation actually create “members”, “groups”, etc blogs

    No, those are simply slugs that are appended to the URI.

    To help us better troubleshoot your issue, please answer these questions.



    Thanks Jeff — good question!

    1. Which version of WPMU are you running?

    WordPress MU 2.8.6.

    2. Did you install WPMU as a directory or subdomain install?


    3. If a directory install, is it in root or in a subdirectory?


    4. Did you upgraded from a previous version of WPMU? If so, from which version?


    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    Yea, mostly (except that I had to install plugin to dealt with “www” subdomain issue [see above / top] )

    6. Which version of BuddyPress (BP) are you running?

    Latest (1.1.3)

    7. Did you upgraded from a previous version of BP? If so, from which version?


    8. Do you have any plugins other than BuddyPress installed and activated?

    Yea, “GD Star-Rating” + “Visitor Maps and Who’s Online” (I guess I could do without this one if Buddypress would work ;) )

    9. Are you using the standard BuddyPress themes or customized themes?


    10. Have you modified the core files in any way?


    11. Do you have any custom functions in bp-custom.php?


    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    I clicked to istall forums, but haven’t touched that since (absolute beginner with that)

    13. Please provide a list of any errors in your server’s log files.

    None (at least not that I can see)

    14. Which company provides your hosting?

    “Freenet.DE” (I think somehow affiliated with either GMX or Strato :/ )

    Bonus: trying to set it up here >>



    I might have found some additional clues about this problem. Seeing as I had only created mu + bp, I only had an admin account — so I decided to sign up for a regular user-account.

    Signup link didn’t work either, but login link did — then on the standard login page I clicked register and got wp-signup.php in the navigation bar plus these error messages:

    Warning: Cannot modify header information – headers already sent by (output started at /mnt/web1/50/41/52223341/htdocs/x/wp-content/themes/bp-sn-parent/header.php:3) in /mnt/web1/50/41/52223341/htdocs/x/wp-includes/pluggable.php on line 865

    Warning: Cannot modify header information – headers already sent by (output started at /mnt/web1/50/41/52223341/htdocs/x/wp-content/themes/bp-sn-parent/header.php:3) in /mnt/web1/50/41/52223341/htdocs/x/wp-includes/pluggable.php on line 865

    Does that help any? O_O

    For starters, disable all plugins (other than BuddyPress) whilst you get the main issue resolved.

    Since you say the signup link didn’t work either, I think this is a ‘pretty URLs’ issue. Ask your webhost if mod_rewrite is enabled (or equivalent)



    I sent them a message a couple hours ago (but don’t know how fast they will respond since it’s Sunday).

    I’ve disabled the 2 other plugins, but I’ve left plw123_true_http_host.php in place (since otherwise not even wpmu would work).

    I hope I can get this to work, because I am really eager to use BP.



    I *finally* got an answer (actually I got it yesterday already :).

    A representative from my hosting provider wrote to me say that I could place a php.ini file in any directory I wanted to make modifications, but that they could not help / provide support for issues with php. So I am completely without a clue what to do next. O_O




    i had the same problem with Strato and the plw123 plugin

    without the plugin wpmu doesn’t work, but with it buddypress doesn’t work at all

    here is what you need to do!!!!

    you need to reinstall WPMU after editing a few files to force it to use the “www” prefix, and you will only be able to use sub-directories.

    edit line 9 and 10 in wpmu-settings.php, just comment them out or remove them.

    if( substr( $domain, 0, 4 ) == 'www.' )

    $domain = substr( $domain, 4 );

    then go to index-setup.php and do the same with lines 515 and 516

    then go down in that same file and do the same with lines 683 to 687

    if( substr( $_POST[ 'basedomain' ], 0, 4 ) == 'www.' ) {





    then go down to line 696 and do the same there

    $_SERVER[ 'HTTP_HOST' ] = str_replace( 'www.', '', $_SERVER[ 'HTTP_HOST' ] );

    now reinstall wpmu and make sure to put the “www” in front of the domain name although it tells you not to do so. now wpmu and buddypress both work.

    you can do the same thing without reinstalling, but that requires you to make the changes for the domain name manually in the database..




    oh, cool — I was almost going to give up! O_O

    I will try this and post my SUCCESS (crossing fingers ;)




    * does happy dance *




    Hi there,

    I dont understand the fix you’re proposing Issidha, because when I go to the WordPress MU files you indicate need tweaking, I dont SEE those lines pertaining to taking out the www in front of URLs… ??

    I tried entering the domain name where i’m trying to have Buddypress with a www. in front but I have the same issue:

    — > The main page is showing up but all other pages ( Members/Blog…) are not accessible: ie, I get a wrong URL message.

    As in:

    Trying to go to : http://www.sitename/groups

    *** The requested URL /groups was not found on this server. *****

    I and other users CAN access wp-admin ( http://www.sitename/wp-admin/) , as if only the WordPress MU was working, and not all the Buddypress features.

    I also installed a fresh copy of WP MU, and installed Buddy Press 1.1.3, as recommended, through the instal Plugin of the WP MU dashboard.

    I had also installed a couple more plugins, the Buddypress SEO, Hashcash and a forum subscription plugin for BP, which I just deactivated to see if that helped. But it makes no difference.

    Thanks for your advice…



    just curios: what is the story with this plw123_true_http_host.php plugin? Where can I find it?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘www / root problem (blog shows, but not members / groups / etc)’ is closed to new replies.
Skip to toolbar