Skip to:
Content
Pages
Categories
Search
Top
Bottom

After activating child theme tags and categories not working correctingly ?

  • after reading how to create buddypress child theme i have created and activated buddypress child theme placed in ( public_html/funjog.com/wp-content/themes/bp15child ).
    After activating theme when i click on tags and categories it displays all the post from that tag or category but when i click on any link to view post an error is displayed

    “Page not found
    We’re sorry, but we can’t find the page that you’re looking for. Perhaps searching will help.”

    Actually problem is with the url’s, at the end of post url’s %20rel= is added, here is full url of a post,

    http://www.funjog.com/blog/2011/09/28/phati-phati-aankhon-se-youn-na-dekh-mujay/%20rel=

    and when i remove %20rel= from thr url the url works fine and post is displayed and i can browse previous and nest post.
    Please help me how can i fix this error that my categories and tags work fine.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Looks like you changed the format of the archive.php in your child theme. I’d look at the code you placed there first.

    @mercime
    Actually i want to display only titles of posts from categories and tags, i mean if some one click on category or tag only post titles should display from that category or tag, and i want to dispaly 30 post on each page.
    please help how can i do this ?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @tahirtaous I’d use WP_Query on archives.php from available ways to do so in this article http://digwp.com/2011/05/loops/ Cheers.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @tahirtaous I’d use WP_Query on archives.php from available ways to do so in this article http://digwp.com/2011/05/loops/ Cheers.

    Avatar of dude
    dude
    Member

    @pinhit

    why does start a new post take me to the community page?

    anyway had to jump in here because I can’t start a fresh post..

    like the title of this blog states (After activating child theme tags and categories not working correctingly ?)

    I followed the instructions for creating a new bp child theme and put the following in my new style.css file:

    /*
    Theme Name: BuddyPress (my child themes name)
    Theme URI: http://buddypress.org/extend/themes/my child themes name
    Description: child theme for BuddyPress.
    Version: 1.0
    Author: my name
    Author URI: http://buddypress.org/
    Template: bp-default
    Tags: buddypress, two-column, grey, dark
    */

    when I go activate my child theme in admin I lose my sites header banner, and all the work associated with my menus is broken..?

    I copied all my previously edited files from the bp default theme to my child theme, but did not move or touch anything associated with the bp default functions.php, should I be doing this even though I do not need to make any edits with this file?

    Using bp 1.5 with wp 3.2.1 the bp default template

    Many thanks in advance

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == when I go activate my child theme in admin I lose my sites header banner, and all the work associated with my menus is broken..? ==
    You don’t need to copy over the functions.php of bp-default at all. Seems to me that this is more of a CSS mixed with missing tags issue. How did you add styles to your child theme?
    1) @import parent theme’s default.css and then add your styles in your own stylesheet OR
    2) did not @import parent theme’s default.css and created stylesheet from scratch?

    Avatar of dude
    dude
    Member

    @pinhit

    I did not copy functions.php over

    2) did not @import parent theme’s default .css

    I followed the instructions given here:

    http://codex.buddypress.org/theme-development/building-a-buddypress-child-theme/

    Avatar of dude
    dude
    Member

    @pinhit

    I started a style.css from scratch, but I was not sure what to put in the Theme URI so just copied the buddypress default and added my child themes name at the end.

    I was not sure what to put in the Author URI so again just copied the buddypress default Author URI

    hope this helps

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.