Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress Links 0.3-beta released for testing

  • Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    OK, guys. You talked me into it. I just committed version 0.3-bleeding to trunk and tagged it 0.3-beta.

    This is BETA. No guarantees that things won’t change. DO NOT use this bleeding edge on a live site.

    * Baseline BuddyPress 1.2 support, REQUIRES BP 1.2-RC2 or higher

    * Removed classic theme support (may re-support in the future if there is a huge demand)

    * Wire support has been dropped and replaced with the activity stream

    * Deep and seamless activity stream integration, complete with RSS feeds

    * @mentions support, complete with e-mail notifications

    * Lightbox for viewing photos and videos without leaving the site

    * Moved template files to plugin dir to ease future upgrading

    * Added support for template overriding from child theme

    * Moved link loop item HTML from hard coded PHP to a template (links-loop-item.php)

    * Added the much requested filters for link REL and TARGET

    * Completely hooked into default theme AJAX (no duplicate functionality)

    * Fixed several trivial bugs

    You can download the 0.3 beta here:

    http://wordpress.org/extend/plugins/buddypress-links/download/

    (It may take a few minutes to show up there)

    Please post all bug reports to this thread.

Viewing 25 replies - 26 through 50 (of 59 total)
  • Avatar of geoffm33
    geoffm33
    Participant

    @geoffm33

    @MrMaz For some reason when I went to test today the voting was working just fine! Not sure why it didn’t work when I tested yesterday.

    Two issues I see:

    1) Can’t add a link from my profile > Links tab. Not sure if I am supposed to be able to, just seemed like a logical place to do it from,.

    2) When I activate the plugin, the activity stream is filtered to show only Link related activity even though the filter is set to “No Filter”. When I de-activate, I can see all my activity (including Link related activity).

    Using WP single 2.9.1, latest trunk from BP and bp-default theme.

    Thanks!!!

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    @MrMaz No, It’s not installed in a subdirectory. Pretty plain basic install actually nothing strange.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    MrMaz: Latest bleeding version of BP Links works beautifully! And even on a subdirectory install of BP. Works well and the AJAX for grabbing the avatar and item description is way cool!

    Couple of suggestions:

    -On the Links Directory page, for each BP link, can you remove the “Home” hyperlink, I don’t see the difference between clicking on that and clicking the “Comments” hyperlink

    -When you’re on a BP link, you see two tabs: “Home” and “Admin” (if you have the privileges to do so). Can you rename “Admin” to “Edit”? I think the word “edit” makes more sense.

    -Minor thing: In the WP admin area, can you move your “BP Links” settings menu under BuddyPress’ menu?

    -Major thing: Is it possible for the activity permalink to display the link avatar and vote panel? (eg. hxxp://example.com/activity/p/RAND-NUM/

    –If not, if possible, can you remove the “View” link from the activity comment?

    —eg. “Ray posted a comment on the link MYLINK: 2 minutes ago · View · Delete” (remove View)

    —Reason why the “View” link should be removed is an activity comment refering to a BP link doesn’t make much sense without the link avatar or vote panel. The user can still click on MYLINK to view all the comments for it.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    One bug I just noticed, if you check a user’s profile activity (eg. example.com/members/admin), only the links activity is shown. All other activity is gone.

    Avatar of nickmy
    nickmy
    Participant

    @nickmy

    David can you please share the files u use on your webseite please

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @r-a-y

    Thanks for the great feedback. I will be going over these tomorrow.

    BTW, when RC3 comes out you will need an updated version on bp links that I haven’t committed yet.

    Avatar of David Angel
    David Angel
    Participant

    @davidangel

    @nickmy

    I’ve just used MrMaz’s beta.

    @MrMaz

    I’m not sure exactly how the comments are supposed to work, but I think something isn’t right with them: http://appleusers.net/links

    I would have thought clicking on the comments for a given link would show you a thread of those comments, but right now it just goes to the homepage with a box to comment on the link?

    Thanks for the sweet work!

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @David Angel

    There are a couple of bugs with how links hooks into the activity stream, and the comment count, etc. I have them fixed in my local copy, and when BP 1.2-RC3 comes out I am going to release another beta.

    If you still think something is funky after that, we can tackle it.

    Avatar of msrecko
    msrecko
    Participant

    @msrecko

    Hi,

    I’m using BP rc3 (WPMU), and BP Links 0.3 bleeding, and there probably CSS problem.

    I have 4 links, but BPL show me only 1.

    Pls. see http://blogge.rs/links

    regards,

    srecko

    Avatar of msrecko
    msrecko
    Participant

    @msrecko

    Hi,

    same this is with Links at my profile:

    Pls. see the: http://blogge.rs/members/admin/links/

    br,

    srecko

    Avatar of PJ
    PJ
    Participant

    @pjnu

    @MrMaz, it worked on my regular wordpress site, but not my wpmu one for some reason. It says the page was not found. Have other wpmu users had difficulties with the 0.3-beta on their sites?

    Is there a way to make the Delete link more visible? It took a bit of looking around to find it.

    Also, if I’m using the 0.3-bleeding, and future versions for BP 1.2 come out, can I simply overwrite the buddypress-links folder? I think it might be yes but I wanted to ask.

    Thank you.

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @msrecko, @pjnu

    There have been a few changes in BP trunk that have required changes to BP Links over the past few days. Right now for everything to work properly you must have the latest BP trunk AND the latest BP Links trunk.

    Sorry for all of this. I will be tagging another beta that is pretty stable after BP 1.2 is tagged final to avoid any more confusion.

    Avatar of PJ
    PJ
    Participant

    @pjnu

    @MrMaz

    I’m running the latest BP 1.2rc3 and downloaded the 0.3-beta from

    http://wordpress.org/extend/plugins/buddypress-links/download/

    When I click the Links tab to go to my.com/links, it says “Page Not Found”

    I’m not sure why this is happening with the latest of each.

    Avatar of msrecko
    msrecko
    Participant

    @msrecko

    @MrMaz

    I’m running the latest BP 1.2rc trunk and latest 0.3 trunk (with WPMU 2.9.1.1).

    “My Links” show me list of all links not only mine (number in (numebr of links) of my links near to “My links” is ok).

    Regards

    Srecko

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @pjnu

    I suggest you wait for BP 1.2 final to be tagged, after which I will be releasing a new beta that is more stable.

    Avatar of idotter
    idotter
    Participant

    @idotter

    @pjnu same problem here

    Avatar of PJ
    PJ
    Participant

    @pjnu

    I’m not sure when 1.2 final will be out. The revisions of the release candidates moved by quickly, so one can hope it would be soon?

    If you’d like a BP 1.2.rc3+WPMU tester, drop a message.

    Also is http://wordpress.org/extend/plugins/buddypress-links/download/ the place to look to if there are revised betas coming out (say 0.4-beta for example)? Keep up the great work!

    Avatar of idotter
    idotter
    Participant

    @idotter

    1.2 is here, do you have a version that works MrMaz? ;-)

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Is this updated for WP single?

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @idotter

    If you can’t wait, just download the development version, it should work with 1.2.

    @Modemlooper

    At least two people have it working with single WP. Download the development version and give it a shot.

    Avatar of geoffm33
    geoffm33
    Participant

    @geoffm33

    I have 1.2 stable and the development version. Everything looks good with the exception of the link home page (not the Links page).

    I get:

    Call to undefined function bp_dtheme_firstname() in /public_html/wp-content/plugins/buddypress-links/themes/bp-links-default/activity/post-form.php on line 18

    Running WP 2.9.1 Single User

    Avatar of bennyticklez
    bennyticklez
    Member

    @bennyticklez

    Whenever I try to add a link i get the following error message:

    Please fill in all of the required fields.

    As far as I can tell there is only one field. The link url. The other 2, Edit Avatar Options & Edit Advanced Settings have nothing in them.

    I am running wordpress single user, BP 1.2 stable and BP Links dev. version.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    http://tempsg.com/buddypress/

    click the links link throws up error

    but when I activate a child theme then when you click links it redirects to home page.

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @geoffm33

    Thank you. Apparently that function was removed from the core at some point and I missed it. I just commited a fix for that. Wait a while for the development version zip to update, then try downloading again.

    @bennyticklez

    Are you selecting a category? That is required too.

    @Modemlooper

    I can tell by the error I got on one of your pages that you are not using the latest dev version of links.

    Avatar of bennyticklez
    bennyticklez
    Member

    @bennyticklez

    @MrMaz yes. i select “humor” and input a url. That’s when the error happens.

Viewing 25 replies - 26 through 50 (of 59 total)

The topic ‘BuddyPress Links 0.3-beta released for testing’ is closed to new replies.