Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can\'t activate BP default theme

  • Avatar of Slava UA
    Slava UA
    Participant

    @slaffik

    After upgrading on one of my BP sites to BP 1.2 I can’t activate BuddyPress Default theme. I’m getting this message:

    The active theme is broken. Reverting to the default theme.

    What should I do to solve this?

    What I did:

    1) re-uploaded all bp files;

    2) edited manually 3 database entries in options table. After doing this WITHOUT reloading any of wp-admin page BP Default is applying to my site and everything seems ok. After reloading any of admin pages – WP default theme is activating (lol). Can’t even explain it.

    3) even child theme is not activating (I’ve tried Unplugged).

    Would be thankful for your help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem.

    The buddypress default theme is not activateable since I upgraded to Buddypress 1.2, and is still not solved after upgrading to Buddypress 1.2.1.

    I also get the message:

    The active theme is broken. Reverting to the default theme.

    This error message apparently appears if the activated theme has no index.php or style.css

    here is a snippet from the theme-php:

    /**

    * Checks that current theme files ‘index.php’ and ‘style.css’ exists.

    *

    * Does not check the ‘default’ theme. The ‘default’ theme should always exist

    * or should have another theme renamed to that template name and directory

    * path. Will switch theme to default if current theme does not validate.

    * You can use the ‘validate_current_theme’ filter to return FALSE to

    * disable this functionality.

    *

    * @since 1.5.0

    *

    * @return bool

    */

    Our default theme is and should stay K2 for new users, so we can’t change that. But apparently we need an index.php which the buddypress default theme seems not to have.

    Any Ideas?

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    What version of WPMU are you both on?

    I’m on 2.9.1.1

    right now i’ve fixed this for me by just disabling the validate_theme function in my themes.php, so it works fine now.

    But this may not be for everyone.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Make sure you disable any caching plugins or scripts (WP Super Cache, object cache, etc.).

    yes, super cache was deactivated, all plugins were for that matter, so i think it must have been another problem.

    Also this bug only appeared when I tried to activate the theme, an other admin had no such problem. The only thing that worked for me was uncommenting this part of the themes.php:

    <?php if ( ! validate_current_theme() ) : ?>

    <div id="message1" class="updated fade"><p><?php _e('The active theme is broken. Reverting to the default theme.'); ?></p></div>

    Avatar of Ted Mann
    Ted Mann
    Participant

    @tedmann

    I’m having this same problem when trying to upgrade tonight. Every theme displays “The active theme is broken. Reverting to the default theme.” when I try to activate. Using WPMU 2.9.2 and BP 1.2.1.

    Help!

    Avatar of Ted Mann
    Ted Mann
    Participant

    @tedmann

    maledei1, you made that edit to the theme.php file in wp-admin?

    I really don’t want to mess with the core. Could this be a problem with WPMU 2.9.2?

    Avatar of Ted Mann
    Ted Mann
    Participant

    @tedmann

    I was able to get the default theme working by moving bp-default into the themes folder. I know that’s not how 1.2 is supposed to work, but the best I could come up with.

Viewing 8 replies - 1 through 8 (of 8 total)

The topic ‘Can\'t activate BP default theme’ is closed to new replies.