Skip to:
Content
Pages
Categories
Search
Top
Bottom

Friendships are missing in Requests and Invites

  • Avatar of Aeryn-Lynne
    Aeryn-Lynne
    Participant

    @aeryn-lynne

    Buddypress Version 1.6.1
    WordPress 3.4.2

    As title suggests, friendships are missing both in the friendship requests pending page and the group invite friends page (for group admins)

    For Pages:
    user-profile/friends/ – current friendships do show
    user-profile/friends/requests – do not show despite active pending states

    The message “You have no pending friendship requests.” continues to show up.

    Likewise groups/Group-Name/send-invites/ does not show a list of friends to invite to group for the group admin.

    I recently had a lot of issues with bbPress and had to remove the plugin manually (deleting through FTP because I would receive a query error by clicking on the deactivate button – for that plugin only) and I’m wondering if this has affected the friends core plugin for my installation of BuddyPress.

    The site has been customized quite a bit, and as a live site for a client, I can’t re-install Buddypress in hopes that it will fix the friendships area if that means that all current users would be deleted. If I can re-install Buddypress without affecting MySQL then I might consider it.

    I’ve found the area in MySQL that handles friendship requests, and can manually change the 0s to 1s with these new friendships showing up on the site, so I know that part is working. But for some reason its not translating to the site on its own for users to validate the requests themselves.

    Where do I look to see why friendships are not being acknowledged by buddypress?

    I wish I could give a link to the site for you, but it’s under a members-only script.

    I’ve also tried searching out related topics, but haven’t found any that have this specific issue nor any resolves for those that are close.

    1. Which version of WordPress are you running? 3.4.2
    2. Did you install WordPress as a directory or subdomain install? Directory
    3. If a directory install, is it in root or in a subdirectory? root
    4. Did you upgrade from a previous version of WordPress? If so, from which version? Not recently
    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting. Everything else functions well.
    6. Which version of BP are you running? 1.6.1
    7. Did you upgraded from a previous version of BP? If so, from which version? Fairly sure I started with 1.6.1.
    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones? 24 – Too many to list.
    9. Are you using the standard BuddyPress themes or customized themes? customized
    10. Have you modified the core files in any way? I don’t believe so.
    11. Do you have any custom functions in bp-custom.php? not in that file
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? Manually disabled bbPress – am concerned this might be part of the problem. I’m not sure if I downloaded this on its own or if it came part of BP. If separate, they were downloaded on the same day.
    13. Please provide a list of any errors in your server’s log files.
    WordPress database error Table ‘mydb_ivdb4wp.pd’ doesn’t exist for query SELECT DISTINCT u.ID as id, u.user_registered, u.user_nicename, u.user_login, u.display_name, u.user_email , pd.value as fullname FROM wp_users u LEFT JOIN wp_usermeta um ON um.user_id = u.ID LEFT JOIN pd ON u.ID = pd.user_id WHERE u.spam = 0 AND u.deleted = 0 AND u.user_status = 0 AND pd.field_id = 1 AND u.ID IN (19) ORDER BY pd.value ASC LIMIT 0, 20 made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), do_action(‘template_redirect’), call_user_func_array, bp_template_redirect, do_action(‘bp_template_redirect’), call_user_func_array, bp_screens, do_action(‘bp_screens’), call_user_func_array, friends_screen_requests, bp_core_load_template, load_template, require_once(‘/themes/AggregateNEW/members/single/home.php’), locate_template, load_template, require_once(‘/themes/AggregateNEW/members/single/friends.php’), locate_template, load_template, require_once(‘/themes/AggregateNEW/members/single/friends/requests.php’), bp_has_members, BP_Core_Members_Template->__construct, bp_core_get_users, BP_Core_User::get_users
    14. Which company provides your hosting? GoDaddy (VPS)
    15. Is your server running Windows, or if Linux; Apache, nginx or something else? Linux / Apache

Viewing 18 replies - 1 through 18 (of 18 total)
  • Avatar of Aeryn-Lynne
    Aeryn-Lynne
    Participant

    @aeryn-lynne

    Sorry to be a pain, but does anyone have a suggestion? For me this issue is a high priority (the site will be seen by a slew of potential new customers for my client in less than a week’s time). I really need to find a fix for this…

    Is the server running on object or page caching? If you aren’t sure, are you running W3 Total Cache or any other caching plugins and what the settings are?

    I am assuming that error in your post is recent. It’s saying that a database table mydb_ivdb4wp.pd doesn’t exist. “mydb_ivdb4wp” is your database name. Where you have the part “LEFT JOIN pd”, it should look like this:

    “LEFT JOIN {$bp->profile->table_name_data} pd” (the middle part is replace by the name of an xprofile database table).

    Now to figure out why. If you look in your database, do you have these tables? wp_bp_xprofile_data, wp_bp_xprofile_fields, wp_bp_xprofile_groups, wp_bp_xprofile_meta ?

    Also, has this always been broken or has it just broke itself?

    Avatar of Aeryn-Lynne
    Aeryn-Lynne
    Participant

    @aeryn-lynne

    I’m currently not using a cache plugin until our site is truly out of beta, just so that I can ensure everything sets up well.

    The database name is correct/exists, I did shut off the xprofile extension in buddypress though. I have users creating their info in the wp-admin/profile.php section so I didn’t need xprofile to run.

    It did work initially, as I had been able to confirm friendships on the front end before. It was probably before I turned off xprofile as well….

    So I’ve just turned xprofile back on and can now find people to invite in groups and pending friendships. Problem solved, woot!! :)

    But now the xprofile area is back which for me is an issue. Is there any way of disabling the xprofile form so that users must edit their info in wp-admin/profile.php? For this site its less work if all member info remains and is edited there only.

    Thanks for helping me fix my initial issue @djpaul!! I’ve been tearing my hair out on this, lol.

    Glad you found a fix, but I think you found a bug in BuddyPress! What page (URL) was causing the errors you saw in your server logs?

    Avatar of Aeryn-Lynne
    Aeryn-Lynne
    Participant

    @aeryn-lynne

    Nevermind, I’ve figured out what to change to make wp-admin/profile that place to go. :)

    Again, thanks for your help on this!

    Avatar of Aeryn-Lynne
    Aeryn-Lynne
    Participant

    @aeryn-lynne

    Oops! Sorry didn’t see your message initially. I think the error would generate in the log when someone would check to see if they had a pending friendship? The logs didn’t have a specified page from what I could see.

    I can try to recreate the error and give you that log…

    Avatar of Aeryn-Lynne
    Aeryn-Lynne
    Participant

    @aeryn-lynne

    I’ve tried recreating the error to get an error-log, but nothing so far.

    I was able to recreate the error though where turning off xprofile would mean that pending friendships and the invite friends to groups areas would show “no pending friendships” or a blank list respectively.

    Sorry I couldn’t be more help on this @djpaul.

    Avatar of John McLearran
    John McLearran
    Participant

    @guykreativ

    How did you fix your issue? I am now experiencing the same thing…

    Avatar of chamaxou
    chamaxou
    Participant

    @chamaxou

    Hi !

    Would you just tell me how to have xprofile turned on ? It could fix my problem… ;)
    My buddypress is in french, so does xprofile stands for Extended Profile in the settings of buddypress ?

    Thanks !
    Max

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Avatar of chamaxou
    chamaxou
    Participant

    @chamaxou

    Thanks @mercime !

    Avatar of Anton
    Anton
    Participant

    @nat0n

    I’m having the same issue here, or is it the other way around maybe? I can see my pending invites if Extended profiles checkbox is unchecked – enabling it gives me “no pending friendships”. What to try next?

    Avatar of Anton
    Anton
    Participant

    @nat0n

    No news here? I can confirm that the problem exist with only 1 plugin active (BuddyPress), network activated or not, and may be connected to the issue where the names of group members don’t show up at all (if the user hasn’t edited their WordPress profile name that is, then it’s cool).

    Avatar of imath
    imath
    Moderator

    @imath

    Hi @nat0n

    I think you are using a deprecated method to get users. The only way I’ve found to reproduce the issue was to force BuddyPress to use BP_Core_User::get_users() which is deprecated since version 1.7 of BuddyPress.

    If i’m right about the above paragraph, I strongly advise you to use BP_User_Query to quickly solve the trouble.

    Avatar of Anton
    Anton
    Participant

    @nat0n

    Thanks. However, the only place I can find those are in the bp-friends and bp-members directories of the core plugin. No match in either plugins or themes. Don’t feel comfortable editing those myself..

    Avatar of Anton
    Anton
    Participant

    @nat0n

    Don’t know if this is helpful, but both these return bool(false) when not disabling profile sync:

    var_dump(bp_has_members( 'type=alphabetical&include=' . bp_get_friendship_requests() ))
    var_dump($members_template->has_members())

    So is this a WordPress bug then..?

    Avatar of Anton
    Anton
    Participant

    @nat0n

    I finally got down to make a ticket out of it, if people have similar problems: https://buddypress.trac.wordpress.org/ticket/5372

Viewing 18 replies - 1 through 18 (of 18 total)

The topic ‘Friendships are missing in Requests and Invites’ is closed to new replies.