Skip to:
Content
Pages
Categories
Search
Top
Bottom

none of my members can start groups, “create” tab missing.. please help!!

  • Avatar of cnatural
    cnatural
    Member

    @cnatural-1

    for some odd reason none of my users or i can start groups on my buddypress site, i checked to see if groups were enabled in my settings and it was on. i noticed that if i disable the start group setting my whole website on the front end goes outta wack. has anyone else noticed this problem or can tell me what to do please help starting groups on my site is a very important feature. i also started a group when i first started the site called help and support so i know it worked at one point. not sure if maybe updating my wordpress to 3.0.4 might have done it but it doesnt hurt to mension..

    P.S. just noticed my Events plugin is doing the same thing, nobody can create an event…

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of paulhastings0
    paulhastings0
    Participant

    @paulhastings0

    Try disabling the Events plugin and then seeing if your groups are working right again.

    Also, what version of BP and WP do you have?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    As part asked you do need to provide as much relevant info on your install/setup as possible if you want help.

    Are you running a custom theme? suffusion?

    If running a custom theme please disable it and revert back to BP-default theme and then check for the group creation button.

    I’m having the same problem. Custom theme, but using BP default theme makes no difference. I’m running WP 3.0.4.

    See for yourself: http://www.vistagranderesort.com user: guest password: vistagrande

    I had this problem going through the default drop downs, but when I added direct links (ie: http://website/groups, http://website/events) the options were there. Does that help?

    @l8knight: I’m not sure. Tell us how you did it.

    Avatar of youlichika
    youlichika
    Member

    @youlichika

    Hi, I also notice this bug when I click my account -> groups -> my groups , then the creat button is display, I notice the url like: `http://site/wordpress/username/groups/`
    but if I remove the username `http://site/wordpress/groups/` I can see the creat button.
    Then, How to move the creat button to users page?

    We’ve decided that BuddyPress is too buggy; we’re going in a different direction. If one can’t get basic stuff like this to work, something is very wrong.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @rjhoward of course you’re free to develop in whatever platform is easier to tweak and mold to what you want. There are other options in the market – free and paid.

    Related to create group problem above, when you can’t get default BP behavior working in your install, change to bp-default theme and deactivate all plugins except BuddyPress plus rename bp-custom.php and the mu-plugins folder.
    Cheers.

    Avatar of cnatural
    cnatural
    Member

    @cnatural-1

    hey guys sorry im so late on responding back, i started to lose hope on getting feedback since everywhere else i went for help (suffusion support forum never respond to any of my help post, wordpress.org at least someone was nice enough to direct me here) was pretty much pointless. but anyway i decided to dump the suffusion theme because i figured there wasnt any point in using a theme that didnt have much of dependable support forum and bought the platform pro theme and so far not only am i impressed but i realize u get what you pay for (free has its limits).
    i looked into what @youlichika said and http://site/groups/create/ takes you directly to the create page that i thought no longer existed. so i went thru my cpanel file manager and edited bp-groups.php and at line 155 i added this:

    bp_core_new_subnav_item( array( ‘name’ => __( ‘Create’, ‘buddypress’ ), ‘slug’ => ‘create’, ‘parent_url’ => $groups_link, ‘parent_slug’ => $bp->groups->slug, ‘screen_function’ => ‘groups_screen_group_create’, ‘position’ => 50, ‘user_has_access’ => ‘groups-create’ ) );

    and i got the create a group tab added next to invites, its not perfect but it gets the job done. im going to do the same thing for events and let you guys know how it turns out. thanks again everybody for replying to my post i found exactly what i was looking for and im more than happy to share what ive learnd hoping to help the next person being ignored from other forums lol

    Avatar of jcampbell120
    jcampbell120
    Member

    @jcampbell120

    thanks for that cnatural. Tried to edit the adminbar.php and just had a create group link on every subnav!!

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.