Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Register – Confirmation/Activation Email Is Not Sent Out

  • Avatar of MikeTime360
    MikeTime360
    Member

    @miketime360

    Hi. I set up a BuddyPress 1.5.3.1 website on BP default theme 1.5.3.1.

    Initially the registration process worked.

    But now a few weeks in, the Confirmation/Activation Email is NOT being sent out.

    Any ideas?

    Thanks.

    -Mike

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of aces
    aces
    Participant

    @aces

    Have you tried installing http://wordpress.org/extend/plugins/wp-mail-smtp/ then sending a test email from the settings page?

    The debug information should indicate where the problem is and the error codes can be googled for further info if necessary….

    Avatar of MikeTime360
    MikeTime360
    Member

    @miketime360

    Aces,

    Good idea. Cool pluggin. I was looking for a SMTP pluggin, but some how missed this one.

    I was able to install WP-Mail-SMTP.

    I sent a “test” message from inside WP-Mail-SMTP and it went through.

    However, when I tried to sign up / register a test member, NO Confirmation / Activation email was sent

    I removed and re-installed BP, but still same problem.

    Any other ideas?

    Thanks.

    -Mike

    check your junk folder

    Avatar of MikeTime360
    MikeTime360
    Member

    @miketime360

    Rockter,

    Good idea. I did look in junk folders. Still no email.

    I am convinced it is not being sent out of BP/WP registration.

    Other ideas?

    Thanks.

    -Mike

    Avatar of aces
    aces
    Participant

    @aces

    Avatar of MikeTime360
    MikeTime360
    Member

    @miketime360

    Aces,

    I tried the Mail From plugin. That did not work.

    I did finally have success (thanks to your post links and some tests).

    Here is what worked:

    1. Created a brand new email address at my host called noreply@mydomainname.com.
    2. Installed the WP Mail SMTP plugin.
    3. Entered the new noreply email account info into WP Mail SMTP and used it as the SMTP for the site outgoing mail.

    Then I tested it. I entered a new test member. I received the Confirmation / Activation Email. I clicked and was activated.

    It’s not perfect, but it works.

    Thank you for your persistent help.

    -Mike

    Avatar of fredtavernier
    fredtavernier
    Participant

    @fredtavernier

    Hi Mike
    about your 3. and the SMTP options, i think that i need to fill in the fields with my host parameters?
    Do you confirm?

    Fred

    Avatar of Jay Collier
    Jay Collier
    Participant

    @jcollier

    We are using WP-Better-Emails. Works great. Still have to suggest people check their spam folders.

    Avatar of RabiBD
    RabiBD
    Participant

    @rabibd

    Jay Collier
    You have rescued me from a big…. problem. Thanks. WP-Better-Emails works great and activation link receiving problem is solved.

    Another think from my site, when new user click activate link, eventually it is activated. But still the page says “Activate your Account” and under this, “Invalid activation key” highlighted with red button and says bellow “Please provide a valid activation key.” Although the user can access his/her profile perfectly. Can anyone help

    Site Address: http://www.public-post.com/

    Thanks

    Avatar of RabiBD
    RabiBD
    Participant

    @rabibd

    Again problem with WP-Better-Emails. I just wanted to customize few things like small logo, contact email for request and then it stop responding again. no activation email or mail to admin. Reinstalled plugin but no luck. what’s wrong!..

    Avatar of RabiBD
    RabiBD
    Participant

    @rabibd

    Is there any perfect solution for it? please…..

    Avatar of premiumwebsites
    premiumwebsites
    Participant

    @premiumwebsites

    I had the same problem and discovered that the Facebook, Twitter, and Google+ buddypress plugins were conflicting with the email send. When I removed those fields from the register page the emails started to come through again.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.