Skip to:
Content
Pages
Categories
Search
Top
Bottom

Remove sploggers from activity / Memory Limit / WYSIWYG in forum

  • Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    Hi, I have three issues I need help resolving with my site.

    I am using:

    Wordpress 3.5

    BuddyPress 2.2.3

    Here’s a link: http://www.livingcm.org

    First, I am using the plugin “Confirm User Registration” which allows me to require users to be confirmed before they can become members of the site. I am also using Private BuddyPress which, I know is not up to date with the latest version of BuddyPress, but it’s the only way I’ve been able to make the site private and I need that functionality. The issue I am having is that sploggers who attempt to register – who are not confirmed by me and are not showing up as members on the member page of the site – are showing up as new members on the home page activity feed. Is there any way to prevent them from showing up on the activity feed until they become actual members through my confirmation process as they would on the member page?

    _______________________________________________

    Second,

    I am getting this error on my dashboard under “Incoming Links” and “Plugins”:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 1966080 bytes) in /home/cgoegan/public_html/livingcm.org/wp-includes/SimplePie/Item.php on line 2736

    I read in a post that I should see this: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    But when I follow the instructions and go to the wp-settings.php file, there are no MB specified. Should I enter them in there? All I can find is this:

    Set initial default constants including WP_MEMORY_LIMIT, WP_MAX_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.
    wp_initial_constants( );

    _____________________________________________________

    Lastly, How can I add WYSIWYG editing – or any kind of editing that would add links, bold, italic; the basics – to our forum? I tried a plugin and activated it and it did absolutely nothing. Maybe I was missing something. Can anyone recommend one that is functioning well?

     

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Re Memory Error – do not touch the wp-settings.php file. Here’s a codex page which has info about increasing memory limits

    Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    I tried this:

     

    If possible, increase the memory limit in the wp-config.php file by adding `define (‘WP_MEMORY_LIMIT’, ’64M’);`.

    but it didn’t work :( I’m not sure where to add the recommended lines in the other files – they are full of unintelligible code to me and I’m concerned about messing with it without knowing where exactly I should put it.

    Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    Here’s another issue I’m having in my WP Super Cache settings:

    Notice: PHP caching enabled but Supercache mod_rewrite rules detected. Cached files will be served using those rules. If your site is working ok please ignore this message or you can edit the .htaccess file in the root of your install and remove the SuperCache rules.

    Please help!

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    hi @ngoegan,
    on what type of host are you ? Shared, VPS ?  How many memory_limit do you have on your server ?
    On cheap host, using WP+BP is already to much. If you add 1 or 2 plugins and a cache plugin, it comes to quickly to disaster….

    But also you can’t ask for help if you don’t  play with the common rules. You are using latest WP & BP and a outdated plugin. Don’t be surprised that it doesn’t work ! Or very wobbly…

    Private BuddyPress
    Requires:
    3.0, BuddyPress 1.2 or higher
    Compatible up to: 3.1, BuddyPress 1.3

    Deactivate it and you will certainly see a difference.
    You also use WP Super Cache. Don’t forget to clear the cache and to deactivate this plugin while testing BP.

    Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    Thank you, yes I am on a cheap host so it’s possibly the cause, although I had it all set up before without the problem.

    Are there any alternative options to private buddypress. The entire site becomes useless if it can not be private. I’m coming from a private ning education site and it just wouldn’t fit our community’s needs so I feel I have no choice but to use this outdated plugin.

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    Avatar of Slava UA
    Slava UA
    Participant

    @slaffik

    About spam registrations – I have already answered here: http://buddypress.org/support/topic/thousands-of-spam-subscribers/#post-151777

    Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    I’m using Wanguard and that seems to be working better now after a few days. It worked perfectly, then I had a smattering of sploggers, then it’s been quiet again. Hopefully it stays that way. If it remains a problem, I will look into your recommendation Slava. Tks.

    The memory issue wasn’t Private Buddypress after all. I deactivated all my plugins, deleted bbpress/buddypress and reinstalled them, then reinstalled one plugin after the other in the right sequence – buddypress first, then buddypress upgrade plugins after – the problem is gone.

    I did talk to my host though and they said I need VPS, which I’m not convinced of yet. We’ll see.

    In the meantime – is there no WYSIWYG editor for bbPress?

    Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    Okay, the problem is back.

    When I activated WP Super Cache it showed up again.

    On Dashboard, “Incoming Links” and “Plugins” both show this error: Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 491520 bytes) in /home/cgoegan/public_html/livingcm.org/wp-includes/SimplePie/Misc.php on line 843

    I tested the cache in WP Super Cache and it said

    The pages do not match! Timestamps differ or were not found!

    Things you can do:

    1. Load your homepage in a logged out browser, check the timestamp at the end of the html source. Load the page again and compare the timestamp. Caching is working if the timestamps match.

    2. Enable logging on the Debug page here. That should help you track down the problem.

    3. You should check Page 1 and Page 2 above for errors. Your local server configuration may not allow your website to access itself.

    So I tried that and they are different. One is:

    http://livingcm.org/wp-login.php?redirect_to=/

    and the other is:

    http://livingcm.org/

    The reason is because I have a private site and unregistered users are directed to a different page than the home page.

    Any idea how to fix this without removing the privacy that I need for the site. Does this occur with everyone who has a different registration page and home page?

     

    Avatar of ngoegan
    ngoegan
    Participant

    @ngoegan

    bump

     

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.